Dual monitor setup lost after reboot

Hi all,

I’m trying to get an external monitor hooked up to my laptop with the intention to use both simultaneously using TwinView. Actually, I’m not “trying to make it work”: everything works fine, using NVIDIA X Server Settings. However, when I reboot these settings are lost and I have to manually expand my desktop again.

I’ve found that running NVIDIA X Server Settings as root should allow one to “Save to X Configuration File”, in order to let it automatically load the right settings. When I click this option, however, I’m asked to manually provide a file name with my home folder as the default location. I’m confused how to proceed - where should I save this configuration? Or should I be taking a completely different approach in the first place? (note: KDE ‘Display and Monitor’ doesn’t work. Only when I use the NVIDIA-thingy KDE will recognize that my desktop is expanded to a 3600x1080 resolution)

Thanks for any help! :slight_smile:

You need to run nvidia-settings as root user;

kdesu nvidia-settings

Tried that, but the problem remains, unfortunately. Saving the X configuration settings leaves me in my home folder with a blank file name line. :frowning:

Hmm, are you saving the file to /etc/X11/xorg.conf?


No, I’m afraid I’m not saving it to anywhere. I get a window asking to supply a path (which is blank by default, but hitting ‘Browse’ brings me to my home folder) and an option ‘Show preview’. Also, there is a tick box ‘Merge with existing file’, which is greyed out (edit: and unticked, which seems logical since no path is supplied).

So, which driver are you using, the manual install or repository?

I use the proprietary download and manually created my xorg.conf as well as disabling the no KMS and using nomodeset at boot.


I’m using the repository install. If I manually create Xorg.conf (I suppose this is done by ‘Show preview’) and save it to /etc/X11, should that work, or do I need to do something in addition to this? (currently I have no Xorg.conf file anywhere, only Xorg.conf.install)

Edit: would it be possible that I could get it to work by simply disabling KMS? Perhaps what I’m saying makes no sense at all, please let me know if that’s the case, but could KMS be overriding the changes I make in nvidia-settings when I reboot?

The configuration files live down in /etc/X11/xorg.d now, so I’m assuming one of the files here needs modification as this is what’s used by the repo version…

Have a read here;
openSUSE Graphic Card Practical Theory Guide for Users

Alright, I read post #3 (nVidia Graphic Hardware) twice and am ready to do this (tomorrow, probably). Two things are still unclear to me, however:

  1. If I use nvidia-xconfig to create Xorg.conf, is it automatically complete and directly placed in the right location? (as opposed to ‘Xorg -configure’, which needs Xorg.conf to be modified and moved manually after its creation)
  2. When I installed OpenSUSE a few days ago I left Ubuntu in charge of boot loading (I didn’t install any boot loader under OpenSUSE but rather updated Ubuntu’s GRUB2 to list it). Do you happen to know how I can get to a run level 3 full screen terminal without starting X? (or would pressing “3” in the boot loader managed by Ubuntu also allow me to load OpenSUSE in this mode?)


I read through the thread once again and think there may be an easier solution. Before I apply it, however, I was hoping whether someone could take a look and let me know if this could potentially break my system:

I can let nvidia-settings show a preview of X configuration settings, which I don’t know where to save to (as Xorg.conf no longer exists). See the code below. Can I simply add the relevant sections to the respective files in /etc/X11/xorg.conf.d ? Or would that break things?

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 270.41.06  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Mon Apr 18 15:13:48 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 60.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 770M"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24

I got it working. Just for those reading this thread in the future:

  1. Run nvidia-settings as root
  2. Set settings as desired
  3. Hit Save to X Configuration File
  4. Enter /etc/X11/xorg.conf in the blank path area
  5. Save, reboot, and notice how well it works :slight_smile:
    (6. I had to readjust my font sizes because the same sizes looked really small after doing this, for some reason)

You can set the dpi option in the xorg.conf file by checking the output from;

xdpyinfo |grep resol

Then add the option in the ‘Device’ section, for example;

Option "UseEdidDpi" "False"
Option  "DPI" "96 x 96"

Awesome, thanks! :slight_smile: