Dual monitor problem

Hi All,

I am new to SUSE and Linux but, I installed SUSE 11.1 x64 on Compaq 6715b laptop and it works fine. The only problem I have is with my second 24" monitor. My laptop LCD monitor and my second monitor both are using the same resolution. Nothing I do changes the resolution of the second monitor. I configured SaX2 to build one big display out of all screens but all I get is a copy of my desktop on both screens. I am using ATI Radeon X1200 Series videocard and KDE 3.5. Please help! Thanks in advance.

Bellow is my xorg.conf file:

/…/

SaX generated X11 config file

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
EndSection

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “IgnoreABI” “on”
Option “ZapWarning” “on”
EndSection

Section “Module”
Load “extmod”
Load “dbe”
Load “glx”
Load “freetype”
Load “dri”
EndSection

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Driver “synaptics”
Identifier “Mouse[1]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “HorizScrollDelta” “0”
Option “InputFashion” “Mouse”
Option “Name” “Synaptics;Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[3]”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “ImPS/2 Generic Wheel Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 331 207
HorizSync 30-62
Identifier “Monitor[0]”
ModelName “LGPHILIPSLCD LCD MONITOR”
Option “DPMS”
Option “PreferredMode” “1280x800”
VendorName “LPL”
VertRefresh 43-60
UseModes “Modes[0]”
EndSection

Section “Modes”
Identifier “Modes[0]”
EndSection

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 16
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 24
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
SubSection “Display”
Depth 8
Modes “1280x800” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
EndSubSection
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”
EndSection

Section “Device”
BoardName “ATI Radeon X1200 Series (RS690 791F)”
Driver “fglrx”
Identifier “Device[0]”
Option “SaXDualHead”
Option “XAANoOffscreenPixmaps” “true”
Option “Capabilities” “0x00000000”
Option “SaXDualMode” “Xinerama”
Option “ForceMonitors” “auto,crt1”
Option “SaXDualHSync” “31-50”
Option “SaXDualMonitorModel” “ACERVIEW 7133S”
Option “SaXDualVSync” “55-90”
Option “VRefresh2” “55-90”
Option “Mode2” “1920x1200,1900x1200,1920x1080,1600x1200,1680x1050,1600x1024,1600x1000,1400x1050,1600x900,1280x1024,1440x900,1280x960,1366x768,1360x768,1280x800,1152x864,1280x768,1280x720,1024x768,1280x600,1024x600,800x600,768x576,640x480”
Option “FSAAScale” “0”
Option “FSAAEnable” “off”
Option “VideoOverlay” “on”
Option “SaXDualMonitorVendor” “ACER”
Option “HSync2” “31-50”
Option “DesktopSetup” “Horizontal”
Option “SaXDualResolution” “1920x1200”
Option “SaXDualOrientation” “LeftOf”
Screen 0
VendorName “ATI”
EndSection

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Section “Extensions”
EndSection

i had a similar issue with my nvidia card when i first started, nvidia and ati don’t release their drivers openly but there is a link from openSUSE’s wiki page if you search for ati. i know that the nvidia drivers come with a very nice GUI for configuring things like second monitors(not sure about ati however) but the tools by the company have worked far better for me than trying to use dual head mode through SaX2

Well, I tried to install the drivers from ATI, but my machine hanged and I had to deinstall them. At this point I’m stuck not knowing how to proceed. Any suggestions will be gladly appreciated. Thanks.

did you leave dual head mode in sax enabled when you tried to install the drivers? there is a possibility that you will need to default your sax config before you install the drivers as it may be the cause for the hang while your system tries to figure out which config to use.

I finally managed to get ATI driver to work, I had to install an older version(9.3) of the driver in order to make it work. But I still have he same problem. Now my monitor is recognized correctly in Catalist control center, but I can’t change the resolution from the display manager. Also, in the display options it says that I have only one display enabled. How can I enable the second one?

Thanks for the help.

That’s what I suspected when I saw your xorg.conf - no references to screen(1) in there. But as I don’t know anything about ATI cards (I have NVIDIA) I kept quiet. Don’t know how to enable second monitor with ATI software but I’d suggest to keep away from Sax and to try editing Xorg manually. Just google for the info needed to add sections for a second monitor.

I googled for example xorg.conf file that may help, but everything I try results in bad conf file. Bellow is the latest xorg.conf file I have. Can someone please take a look and help me out with this. Any help is greatly appreciated. Thanks.

/…/

SaX generated X11 config file

Version: 8.1

Contact: Marcus Schaefer <sax@suse.de>, 2005

Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>

Automatically generated by [ISaX] (8.1)

PLEASE DO NOT EDIT THIS FILE!

Section “ServerLayout”
Identifier “Layout[all]”
Screen 0 “aticonfig-Screen[0]-0” 0 0
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
InputDevice “Mouse[3]” “SendCoreEvents”
Option “Clone” “off”
Option “Xinerama” “off”
EndSection

Section “Files”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
EndSection

Section “Module”
Load “dri”
Load “dbe”
Load “freetype”
Load “extmod”
Load “glx”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”
Option “Xinerama” “off”
EndSection

Section “InputDevice”
Identifier “Keyboard[0]”
Driver “kbd”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”
EndSection

Section “InputDevice”
Identifier “Mouse[1]”
Driver “mouse”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Name” “Belkin F8E842-DL Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “InputDevice”
Identifier “Mouse[3]”
Driver “synaptics”
Option “Buttons” “5”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “on”
Option “HorizScrollDelta” “0”
Option “InputFashion” “Mouse”
Option “Name” “Synaptics;Touchpad”
Option “Protocol” “explorerps/2”
Option “SHMConfig” “on”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”
EndSection

Section “Modes”
Identifier “Modes[0]”
ModeLine “1280x800” 83.5 1280 1344 1480 1680 800 801 804 828
ModeLine “1280x800” 69.8 1280 1328 1360 1440 800 803 809 823 +hsync -vsync
EndSection

Section “Monitor”
Identifier “aticonfig-Monitor[0]-0”
Option “VendorName” “ATI Proprietary Driver”
Option “ModelName” “Generic Autodetecting Monitor”
Option “DPMS” “true”
EndSection

Section “Device”
Identifier “aticonfig-Device[0]-0”
Driver “fglrx”
BusID “PCI:1:5:0”
EndSection

Section “Screen”
Identifier “aticonfig-Screen[0]-0”
Device “aticonfig-Device[0]-0”
Monitor “aticonfig-Monitor[0]-0”
DefaultDepth 24
SubSection “Display”
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section “DRI”
Group “video”
Mode 0660
EndSection

Did you just fiddle with the video-related bits or cut and paste someone else’s entire xorg.conf? Did you save backups of xorg.conf before editing it?

This is the xorg.conf file that was generated by the ATI Catalis control center, and yes, I do have backup of the old xorg.conf file that was generated by SaX2. I don’t see what will be the point of pasting someones xorg.conf file.

I agree about the cut and paste, it was your previous message which made me ask. I know nothing about ATI’s control center so I don’t know why it produces “bad” xorg.conf, but I still can’t find any references to two monitors in that file. Usually, with a dual monitor setup, the xorg.conf has references to screen 0 and screen 1, and their relationship (clone, xinerama, or whatever).
There must be someone around here with experience of ATI cards and dual monitors?

I’m having the same basic issues but using an ATI Radeon 8400 XT. I’ve tried installing the ATI drivers from both ati-driver-installer-9-4-x86.x86_64.run and ati-driver-installer-9-3-x86.x86_64.run. Here’s the really twisted thing - sax2 is actually telling me I’m running in xinerama mode - but my display is cloned (same image to each monitor).

I even tried copying a backup of my old xorg.conf from when I finally got xinerama mode working the last time with the same result. I can get it working from the RPMs provided through YOU or the ‘one-click-update’ on the wiki, but 3D doesn’t work and everything is unusably SLOW!!! (like 1-2 fps slow, and glxgears and fgl_glxgears wont run).

:frowning: Is there anyone out there who can help?

Xinerama is incompatible with 3D acceleration: any kind, not just Compiz.