Dual monitor configuration

I am trying to configure a dual monitor setup with openSUSE 11.1/gnome 64 bit.

  • computer: HP dv9700t laptop
  • graphics card: NVIDIA GeForce 8600M GS
  • external monitor: Samsung SyncMaster 2253BW, analog connection
    Both monitors have max resolutions of 1680x1050.

I would like the desktop extended to the external monitor, which is positioned to the right of the primary/laptop monitor. Preferably the system would know whether or not the external monitor was connected, and act accordingly.

I followed steps for openSUSE 11.1-AMD64 at Nvidia Installer HOWTO for SUSE LINUX users.

  1. Updated the kernel with YOU.
  2. Entered YAST->Software->Software Management. The package x11-video-nvidiaG02 was preselected, and I installed it.
  3. Ran sax2 -r.
    All this went without a problem.

Then I got into Yast -> Graphics Card and Monitor. Whenever I activate Dual Head Mode, press “Configure,” and run the test, I get the desktop only video on the external monitor (which does look fine). BUT the laptop monitor is blank. This is true whether I select “Cloned Multihead” or “Xinerama.” If I save the configuration and reboot, then, again, the laptop display is blank.

For completeness, I should mention that the “Monitor” entry on the Display1 tab shows LCD 800x600@60HZ (wrong). But below that under “Properties” it shows the correct resolution.

Similarly, when I am in Configure, it shows the Second Monitor as VESA 1024x768@60HZ (wrong).

I see various postings about changing the xorg.conf file, but they are older, for different distros, or refer to data groups (not sure if that is the right term) within xorg.conf that differ from the ones mine has.

Thanks for any suggestions.

Hi
You need to configure at runlevel 3 using the command;


sax2 -r -m 0=nvidia


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.27.15-2-default
up 7:39, 3 users, load average: 0.10, 0.10, 0.09
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

Hi Malcolm, thanks for your reply. I gave that the alternative sax2 command you suggested a try at run level 3. Unfortunately, it produced exactly the same result–basically, in single monitor mode, only the laptop monitor works. In dual mode, only the external monitor works.

Hi
What about running nvidia-settings can you see both screens. Is there a
Fn (Function) keypress required to enable both screens. Have you also
checked the BIOS settings?


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.27.15-2-default
up 10:11, 3 users, load average: 2.36, 1.49, 0.77
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

Can you please tell me what you mean by running nvidia-settings?

With respect to a Fn keypresss–under Windows, the function key combination (fn-f4 on this computer) that would ordinarily change screen modes does not work. You have to get into the Nvidia Control Panel (accessible under Vista by right clicking on the background), which has a window for “Set Up Multiple Displays.”

Hi
The application is called nvidia-settings it should either be in your
menu system or open a konsole/console session and enter;


nvidia-settings

I did a test here yesterday with this notebook, my internal panel is
1024x768 and the external 1280x1024;

  1. Power off system
  2. Boot to grub screen and here use the system function keys to get
    both monitors to display grub screen.
  3. Boot system and login (I did loose the external screen after the
    desktop reached)
  4. Run nvidia-settings and you should see both monitors displayed
  5. Got the X Server Display Configuration and select the external
    monitor and enable.

At this point you should be good to go.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.27.15-2-default
up 21:09, 1 user, load average: 0.44, 0.27, 0.23
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

Well now, that made a difference! It does actually work now, something I never thought I would see. Thanks so much, hopefully that will be a big boost for productivity.

A few footnotes:
a. Steps 1 and 2 - the fn keys simply will not toggle video modes on my computer, but that does not hurt the outcome.
b. Running nvidia-settings has to be done as root, because otherwise the application cannot save the xorg.conf file.
c. The terminology is different from the SaX2 X11 Configuration in Yast/Graphic Card and Monitor. Here “Twin Display” is what was needed to extend the desktop to the second monitor.

I am using a four headed X setup and dual monitors work well with the NVIDIA driver, but attempting to get Xinerama for the third and fourt head fails. This works very well with the 11.0 distro but fails in 11.1.

I use separate monitors with absolute positions for 11.0 and this does not seem to work with 11.1.

Does anyone know of a workaround for this?

@knaveofhearts

Extra help for you:
Go ->application->system->configuration->Nvidia Settings->X server display Configuration from there you can playing around with it.

Good luck;)

Mike

Im using TwinView it works for me:) Im using 11.1 with two ViewSonic monitor

Cheers

Mike

Using two monitors works fine with TwinView or Xinerama. I encounter problems with monitors three and four. I have no problems with the 11.0 release using four heads, only 11.1 is causing me grief.

TwinView works fine except I am looking for Xinerama not dual twin view.

Is anyone else experiencing issues using more than two monitors with the Nvidia proprietary driver and interested in working this out with me?