Dual-monitor adjust required virtual size

Hi, I’ve recently installed linux and am having problems running with two monitors. The message I receive from gnome-display-properties is: “required virtual size does not fit available size: requested=(2960, 1050), minimum=(320,200), maximum=(1680, 1680)”

I am trying to run the laptop monitor LVDS 1280x800, and the VGA at 1680x1050, located to the right of LVDS

Here are my specs:
Dell Inspiron 6000
-1.6 GHz Intel Pentium M
-I think my laptop has the ATI Radeon graphics processor, but I haven’t found where to verify this
-openSUSE 11.2, GNOME desktop environment

Is there a way to change the virtual desktop size? I haven’t found xorg.conf (only xorg.conf.install, which has different entries), as some forum posts suggest. I haven’t played much with xrandr, I was hoping there was a simpler way to resolve this issue.

Thanks for the help!

Verified graphic processor:
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Mobility Radeon X300]

I have a similar issue with my laptop. I run a setup similar to yours; as in I have an extra monitor. I’ve never been able to get it working. The best that I’ve found out is that the graphics card in the laptop isn’t designed to have a HI Res external monitor. I usually have my monitor set to 640X480. When you think about it in the Windows world… What would you actually connect to that port? Most don’t really notice the difference between 640X480 vs 1280X1024 through a projector or TV. The only thing that really matters is the quality of what your putting to the screen.

Of course this could just be me… or the fact that I run KDE…

I’m fairly certain a previous install of windows had no problem with a second hi-res monitor using this hardware. Also, I previously had a second Dell laptop with SLED 11.0 installed, and there was no problem with the dual-monitor setup through the gnome-display-properties graphical configuration tool.

Interesting additional behavior:

  1. I lower the combined 2 screen resolution to within the virtual desktop maximum, hit “Apply”, and both screens go black and never revert, forcing a reboot.

  2. When I choose the option to mirror screens, gnome-display-properties crashes.

I’m a KDE user. So, I don’t know if the CTRL+ALT+BACKSPACE+BACKSPACE trick works for you. That combo restarts X; from my understanding.

Are you using the Opensuse provided driver of the Vendor Provided driver? You can pull the vendor driver from here:
Graphics Drivers & Software

Thanks psybernetik. I ended up running SaX2, which had a lot more configuration options, and was able to have it write the xorg.conf file and setup dual-head mode. For some reason the 2nd monitor resolution was limited to 1280x, but I couldn’t figure out how to up the res, and at least having the second monitor is good enough for me for now.

I’m using gnome, but gnome-display-properties had a note saying to use Ctrl-Alt-Bksp-Bksp to revert and this didn’t work for me (from what I remember from last week).

I believe I’m using the openSuse provided driver, but when I have some extra time later on I’ll try the vendor driver from the link you’ve posted.

Thanks to all for the help! Consider this issue closed for now!

It’s great post of information