Dual Install worked, until four hours ago!

I have openSUSE 11 and XP installed on my desktop. I am new to linux but I had this up and running for the past week and could go into both, and have repeatedly. Then today I go to access the windows C drive while inside openSUSE and nothing is there. It was there last night!!! I am not sure what happened but that is not the main problem. Somehow in trying to fix it I now cannot boot Linux. I go into XP recovery stuff whether I like it or not and I can not find a way to get linux to come back up. I was able through the control panel and one of the utilities to confirm that my partitions are still set up the way I had them. I have no idea what to do and I have been at this for hours. PLEASE help if you can!! Thanks for the time as always!!! If any other information is needed let me know and I will gladly post it!

Do you think it could possibly be a hard drive failure? It’s got all the makings of one.

How old is your hard drive?

I don’t think so. But how would I check or know if it was? I am able to access everything that I have in windows and I can see the other partitions like I said, they just don’t have the labels that they have when I view them in yast, if I put the live CD in. The live CD is the only way that I can get into openSUSE currently.

The hard drive is the one that came with the computer and I would say that it is about three years, maybe a little bit more.

you’re hard disk is fine. what has happened is that your xp ntfs partition has become what ntfs-3g ( the linux ntfs driver that allows access to your windows files ) calls ‘inconsistent’ which means it won’t touch it with a 10 foot pole, because it risks corrupting data. ( similar to a damaged ext3 partition, read-only access, except ntfs-3g just doesn’t mount it at all )

just boot into windows to fix it, then run a disk check on the C: drive. it will probably demand a reboot. ( ensure your plugged in, it can take some time ).

however, since you have attempted to fix it these instructions are useless. how did you fix it? did you run fixmbr from recovery console? or did you do a repair installation? either way, you need to reinstall grub, something i have never done.


If it appears that the Windows installation has vanished you better get it back first. Suse will wait for you to do that. What you do depends whether you’re running vista or xp. Which is it?

Oh. Sorry. I misunderstood.

he’s running xp.

Ok there were multiple questions. I am running XP, but XP runs, I just tell it to start normally and it does just that. I can then do everything in windows that I normally do. It goes through recovery mode though to get to the “start normally” portion. I am wondering if that is part of the issue though. When I had SUSE up and running GRUB loaded my OS options and I had windows 1 and windows 2, now windows 2 actually loaded everything normally. Thanks to my fiance though, she let it load through windows 1. I don’t know what that would have done, I simply offer that tidbits in case it explains something to someone. I have never done it because I knew that windows 2 was the proper choice.
In regards to how I tried to fix it, lets just say I tried for four hours before I posted this and I did alot in that time frame. I don’t think that I actually did anything useful but I also did not change anything. MOst of my time was spent wandering through parts of windows I have never dared to enter before and trying to find options and files that I was unable to find. I was aware I was in areas that I shouldn’t be if I didn’t know what I was doing so I didn’t actually do anything, that I am aware of.

OK if windows is running normally you can get Suse back. The procedure might block windows booting temporarily but that’s easy to fix. So to get Suse back you do steps 1 and 2 that I quote below:

Step 1 for openSUSE 11.0 - Assisted Boot into openSUSE: Insert Suse’s installation CD/DVD and reboot the computer. On the boot screen choose to “Repair Installed System”. Wait for three choices and select “Expert Tools”. Then click option “Install New Boot Loader”. Select the partition where you installed Suse (if asked). You’ll get the Grub GUI setup screen. Check under the Tab “Boot Loader Installation” that the checkmark is in “Boot from Master Boot Record” and remove any other checkmarks. Click “Finish”. Wait for message “The boot loader was installed successfully”. Click OK → Next → Finish. Ignore any error messages and reboot. That should install an elementary Grub and allow you to boot to openSUSE. So do that and it will take you to step 2

Step 2 - Reinitialise and Reinstall Grug: Once Suse has fully booted and settled down, go to Yast → System → Boot Loader. The Grub configuration screen comes up with the Tab “Section Management” activated. In the lower right is a drop-down selector labelled “Other”. Select from “Other” the option “Propose New Configuration” and then wait for Grub to analyse your partitions and display a new configuration. This may take a while. Important: When that finishes, activate the tab labelled “Boot Loader Installation” and select to “Boot from the Master Boot Record”. [Yast will often default to booting from the root or boot partition rather than from the MBR but that’s for experts only – always choose the MBR.] Then click Finish to save the changes and install the reconfigured Grub into the hard drive’s MBR. If you get a message that "The bootloader boot sector will be written to a floppy disk … don’t bother with the floppy – just click OK to proceed and install to the MBR. Reboot and you should be able to boot to openSUSE using the Grub menu screen. Frequently you can also boot to Windows after completing Step 2.

The context of that quote is on this link, for further background:
GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

I suggest you try with that to get Suse back and see whether the entries in Grub’s new menu will allow booting to windows, and let us know.

I tried your walk through this morning but when I rebooted with the openSUSE live CD in the drive and went through the options on the boot screen, I could not find, or did not have, the option to “repair installed system.” Maybe it is there and I am missing it, I am a bit tired from last nights escapade with this whole thing so maybe I missed it. If you could be a bit more specific as to where I can find/ how I can get to that option that would be great. I went as far as just running the live CD and telling it to install, just to see if “repair installed system” would be an option from there but, as you probably already knew, it was not. Once I discerned that I was not going to have that option I canceled the install, so everything is the same as I said last night, at least as far as I can tell. Thanks again!!

There’s that wretched live CD again. I’ll have to write how to fix it with the live CD ionto that tutorial.

Here’s what you do:
For purposes of this example, suppose the Suse root partition is sda5, which in Grub speak is (hd0,4). I hope you can mentally change what I say to suit your partition, whatever it is.

Boot off the live CD, all the way. When it settles open a console and enter su to become root, then enter grub to get into the Grub programme.
enter this:

find /boot/grub/stage1

In the response you should see (your version of) (hd0,4). That’s just to confirm things. You should see it. Now enter this:

root (hd0,4)
you should get Filesystem type is … etc
then this:

setup (hd0)
You should get checking … etc etc… yes (three times) and … succeeded.
Now enter quit. Reboot and remove the CD – with luck it should boot to Suse.

How did it go?

I want to make sure, and although I a bit embarrassed, I really don’t want to screw things up anymore than they are. So on my partition I have, other than windows C and D:
linux swap

I am assuming that the root is the last one ( / ). I just want to make sure. I can then just go into YAST and into partitioner to check the location ,I thought mine was SDV3 or something but maybe not, either way point being that I should be able to check in partitioner. Then if mine is different from sda5, and I think that it is, where can I get the correct “grub speak” for that partitioner, I am pretty sure I can figure it out from the link you posted to Grub Boot loader full tutorial, but I really don’t want to guess at any of this.

Don’t be embarrassed by this – it’s so confusing.
If you go into Yast partitioner the columns are Device, Size, F, Type, Mount. The root partition has a single character in the Mount column; viz: /
The device designation is given in column Device. It’s like “sda5”. Tell me what you have and I’ll give you the correct Grub speak.

I will get that information and post it up hopefully tonight. This is making alot of sense though. I was hoping to have this fixed before my business trip tomorrow but I don’t think that is going to happen, thanks for all the help and I will hopefully get this finished Monday night, fingers crossed! If nothing else I understand what it is I am supposed to do, thanks to your help! Thanks again and I will try and post the device designation tonight so I can get the grub speak for that particular designation from you.

I thought that I followed the instructions in the previous post but I get the output below each time I try. Maybe I missed something but I am not sure what I supposed to do either way. I don’t what to do when it doesn’t recognize the command, I am wondering if I am inputing it improperly somehow. Thanks.

linux@linux:~> su
linux:/home/linux # grub
Probing devices to guess BIOS drives. This may take a long time.

GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

Minimal BASH-like line editing is supported. For the first word, TAB
lists possible command completions. Anywhere else TAB lists the possible
completions of a device/filename. ]
grub> find /boot/grub/stage1
find /boot/grub/stage1
grub> root(hd0,4)

Error 27: Unrecognized command
grub> root(hd0,4)

Error 27: Unrecognized command
grub> setup(hd0)

Put spaces in “root (hdx,y)” and “setup (hdx)”

I will check to make sure when I get home but I only copied the first attempt. I tried multiple times and I am almost positive that it still said that it was an unrecognized command when I tried putting the spaces in as well. I will try again though.

This is what I get, doing what you did. Note the different response when I include a space:

grub> find /boot/grub/stage1
find /boot/grub/stage1
grub> root(hd0,4)

Error 27: Unrecognized command:(
grub> root (hd0,4)
root (hd0,4)
Filesystem type is ext2fs, partition type 0x83:)

You were correct. I fixed the problem in minutes once I got home tonight. Thank you very much for all of your help, and you patience. These forums are great and without people like yourself willing to donate there time to help others they would not be what they are, so thanks!! Now I off to try and figure out what the hell I have done to the openSUSE install on my laptop and why it won’t boot into SUSE. Thanks again!!!

Glad you’re glad, sad I mislead you with my typo – but it all had a happy ending http://www.swerdna.net.au/forumpics/smiley/beer.gif