Dual Install Win 7 and LEAP 42.2 problems

Hi guys, I’m new to Linux so I am very confused with the problems I encountered trying to install both Win 7 and OpenSUSE LEAP 42.2.
I want to do this on my laptop, where I will be doing my thesis on - and I need Linux for certain softwares for scientific analysis but since I am not very used to Linux so I want to dual boot and keep Win 7 for games and internet etc.

It’s an Acer laptop with a SSD of 120GB, and I want to install both of them on it.
First I tried what I found mainly on Google - have Win 7, shrink partition, install OpenSUSE and it is supposed to be able to install on the free space and also take over the bootloader with GRUB.

And when I was trying to do so when I install OpenSUSE, I get the message - YaST2 - Operation not permitted on disk /dev/sda
“The partitioning on your disk /dev/sda is either not readable or not supported by the partitioning tool parted used to change the partition table”.

I proceeded to partition in Windows using Partition Wizard and try to simply use mount points to tell what the installer to do.
I created the “/”, “/home” and “swap” and then the installer asked me for the /boot/efi.
I told the installer to use the 100MB System Reserve from Windows for this purpose and apparently it didn’t go well…

So then I googled for possible conflicts and what to do and tried a handful of things.
as i said, i’m not too experienced with Linux infrastructure so I have no idea how to deal with /boot/efi - I googled and I tried to use UEFI mode instead of Legacy mode - and apparently Win 7 or older does not support UEFI so that failed.
I went back to Legacy mode and tried to use GPT disk mode and that also didn’t help.

I wiped my SSD clean and did a fresh, sole install of OpenSUSE - it went fine.
I did a fresh install of Win 7 (absolutely fresh) and proceeded to install OpenSUSE - same message of Operation not permitted again.

I just don’t understand why the OpenSUSE installer - YaST2 cannot partition my disk when other people never seem to have this problem.
It seems to be it is the Win 7 installation or MBR that blocks or be incompatible to the OpenSUSE installer, but how is that possible when Linux is supposed to be able to dual boot in the first place.

Please help! Thanks!

others with more experience will guide you on dual boot, but… for your info… dual boot is only really a necessity for gamers etc. running windows inside virtual box, if you choose linux as the default, is a much better solution from the point of view of convenience and management.

High end games may not run in a VM, depending on which VM is used

Be sure that Windows is not using Dynamic disks for it’s file system. Linux does not do dynamic disks

If you have resized Windows partition to leave free unpartitioned space for Linux then it still should work. But it must be unpartitioned space

Windows 7 works fine with UEFI booting, so what system and BIOS settings are available for UEFI booting, CSM, Native etc?

For a fresh install of windows 7 and a linux, I would use the following setup…

sda1 - type ef00 size 260MB (vfat)
sda2 - type 0c01 size 128MB (windows reserverd)
sda3 - type 8300 size 30 GB (linux, btrfs NO SNAPPER!)
sda4 - type 8300 size 20GB (linus /home)
sda5 - type 8200 size (1.5 or 2x RAM) (swap)
sda6 - type 0700 size (balance of device) (windows 7)

I would fire up a rescue system and use gdisk to configure the above…

Do you windows install and use the custom option to select sda6, let it do it’s thing, then install openSUSE and use the expert partition to first rescan the devices, then select sda1 as /boot/efi and no format, sda3 for / and sda5 for swap…

For windows install iso I use rufus on windows to create the UEFI/MBR bootable windows images, on linux I use imagewriter for openSUSE versions.