Dual head problems OS11 GNOME NVidia

Problem description:

I’ve connected an external monitor to the VGA output of my laptop. I configured sax2 (enabled dual head display) and set it to “Cloned display”. With “nvidia-settings” I’ve configured all settings accordingly and detection of the monitor is correct (both sax2 and nvidia-settings). If I hook up the external monitor, it turns the external monitor into my primary display (zero), which I don’t want. The laptop screen is set to be one.

If I restart the X-Server the following happens:

  1. The display is set to the external monitor and the laptop screen (correct)
  2. If I click “Computer” it displays the menu only on the primary display
  3. If I click “Computer” on the laptop screen, the menu is displayed on the primary screen and programs are opened there.
  4. I can’t drag programs over to the laptop display, thus defying purpose of two displays

Technical Specs:

  • Asus Z53M
  • openSUSE 11 x64 AMD Turion X2 GNOME
  • NVidia Geforce Go 6100
  • Compiz enabled (seems to be disabled with dual display)

To begin with, do not use sax2 if you have an nVidia card. Always use the nvidia-settings program, as sax2 will overwrite all the nvidia settings.

You didn’t describe how you want it to work, but you probably want it to work “the right way”, where that is defined as “how I do it” :slight_smile: The defaults for X and dual monitors are completely and totally broken, and defy logic as to why anyone would run it that way, never mind have it the default way.

So run the nvidia-settings as root. I use KDE, so I’m not sure how you do it on GNOME, but I modified the KMenu entry to be ‘kdesu nvidia-settings’. This way, you can actually write changes to the X config file.

Click on the X Server Display Configuration item. You should see your two monitors on this screen. s Click on the Configure… button underneath the display view and select Twinview. That’s the key - this makes it so that the monitors are all on the same desktop.

Click on the Save to X Configuration File button and accept the default. Quit out of the settings and the reboot (well, you can just restart the X server if you know how to do that but rebooting is easier to explain). Now you should have both monitors acting as a single screen.

Yet another try.

Twinview is not doing what I want it to do. It changes the laptop dekstop to display 1024x768 instead of the 1280x800. The connected display is a (square monitor) that can handle 1280x1024 easily. I’ve used nvidia-settings to configure both.

With twinview I can’t put something on either display and run it fullscreen. Seperate X gives me two displays, but I can’t interact between them, menu on the monitor right is opened on the left (scenario 2 in openingpost).

When I enable Xinerama that won’t be saved to my x.conf file. Restarting X is no solution to the problem, because after some fiddling, it wants to output 1280x1024 to my laptop screen, which the laptop can’t handle and all turns black (hard reboot is required to overcome this then).

What I want is the Winblows like config, that the monitor left is acting as a seperate monitor from the right one, where you can interact between them by draggin your programs over. So that I can use a remote desktop on the external monitor and local installed programs on the laptop.

Another post, got it working as I want now.

I used nvidia-settings and set it to twin view again. Just restarting X wasn’t enough and I rebooted the entire laptop. I now have both displays working like a charm, with the same behaviour as in Winblows.

Thanks hieronymous :slight_smile:

All I need now is that TSC can go full screen to 1280x1024, but that is another issue for an other topic. :wink:

great to hear it! Now never, ever ever use Sax2 (or Yast) to change the settings, or you’ll mess it all up. Just use the nvidia tool