Dual Booting Ubuntu and 11.2

Just sucessfully installed a sual boot with 11.2/ubuntu 10.4. 11.2 was installed first, than ubuntu. ubuntu recognizes and displays 11.2 on its bootloader, 1…2 does ot show ubuntu on its boot menu.

so this mean I have to edit menu.lst and physically add the menu entry (root, load the kenel, and load initrd)…correct?


Ubuntu uses a newer version of Grub. (2) It is best to have Ubuntu grub installed and use ubuntu to control the boot.

would there be any recommendations on how to get Ubuntu to show up on the opensuse 11.2 boot menu screen?

In ubuntu

sudo update-grub


sudo grub-install /dev/sda

Maybe I was not clear, Ubuntu uses a newer grub. Suse’s grub will not boot Ubuntu because it is an older version of grub. You need to replace the Suse grub with the newer Ubuntu grub and control the boot in the Ubuntu disto which will boot Suse.

Note this is not the same as the chaining used in a Windows boot.

Sorry ignore that last post. You already have Ubuntu showing 11.2:P

To boot ubuntu from 11.2 menu, why?


now, I see what you mean, …


just to prove if I have understood a bit what is possible:
Out of openSUSE 11.2 you cannot control the new Grub 2.
openSUSE 11.3 will not come with Grub 2 by default but it possible will be possible to load and install Grub 2 after that. 11.3 - Grub 2 - openSUSE Forums
So if subcook69420 in the future would like to have 11.3 instead of 11.2 it could be nice to have openSuse’s Grub 2 out of the repositories (or at least the yast-programs that will be able control that)…
The possible possibilities in what order the installations/updates of 11.3 and/or oS/U Grubs could/should be installed before/after/beween 3. …:\

Greetings pistazienfresser

That’s an error on your part gogalthorp, sorry. OpenSUSE can boot Ubuntu just like it boots any other distro. It makes no difference that Ubuntu now has Grub 2 because openSUSE doesn’t use the Ubuntu Grub to boot Ubuntu, it addresses the Ubuntu kernel and initrd directly.

@subcook69420: Here’s how to add Ubuntu entry into openSUSE’s loader:

#Don’t change this comment - YaST2 identifier: Original name: none#
title Ubuntu 10.4 booting via symlinks
root (hd0,8)
kernel /vmlinuz root=/dev/sda9 ro quiet splash
initrd /initrd.img

Of course, you have to alter (hd0,8) & sda9 to match your real Ubu partition

See this for full explanation: HowTo Multiboot Ubuntu from openSUSE using the GRUB bootloader

As always, thanks for the help guys :slight_smile:


I did the same thing as subcook69420. openSUSE 11.2 was installed first beside Windows Vista and then latest version of Xubuntu. Everything worked fine (only grub was bit ugly) untill I upgraded openSUSE to 11.3. Now I cannot boot to Xubuntu.

There is no entry about Xubuntu in /boot/grub/menu.lst

Would be possible to fix it without reinstalling Xubuntu?


A) (I have not tried jet, still on 11.2:) )
Install Grub2 instead of Grub legacy (should be now in the repositories but still no graphic tool for it from openSUSE 11.3)
B) (s. above) Go to HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive and try to use swerdna’s HOW-TOs analog to get excess to your Ubuntu system and reinstall and update your Grub2 from there.
C) I will have to look for my Ubuntu-live-CD but is there not an option to repair/reinstall Grub2 from there (like from the openSUSE DVD - only for the old GRUB legacy…)?


Thank you for quick replay

B) didn’t work for me so I’m gonna try A). But how to revert back to old grub in case any problems? Will it be enough if I use repair tool from installation DVD to restore original Grub?

I just switched from grub 2 to suse grub legacy, it was easy.

All I need is your info:

fdisk -l

Tell me which partition is which

You can boot GRUB 2 (of Ubuntu) from GRUB legacy(of openSUSE)… I have a dual boot between openSUSE 11.3 and Ubuntu 10.04…

Just add these lines to your /boot/grub/menu.lst in openSUSE with just changing your hard disk number i.e. hd(0,X) according to the root partition of Ubuntu - yes just post the results of the output from fdisk -l and I can tell you the correct number:

title Ubuntu 10.04
    rootnoverify (hd0,X)
    kernel /boot/grub/core.img

Here’s fdisk -l result

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        3648    29302528+   7  HPFS/NTFS
/dev/sda2   *        3649       60801   459081472+   f  W95 Ext'd (LBA)
/dev/sda5            8762       11372    20972857+  83  Linux
/dev/sda6           11373       60410   393897703+  83  Linux
/dev/sda7           60411       60801     3140676   82  Linux swap / Solaris
/dev/sda8            3649        7295    29294464+  83  Linux
/dev/sda9            7296        8760    11767581   83  Linux

Great but which partition is Ub*

Yes whichever is the number of the partition with your Ubuntu, subtract one from that number and substitute it for X in my previous post…

For eg. if you had installed Ubuntu on /dev/sda8 - then you need to put (hd0, 7) in the GRUB entry…


sda9 is Xbuntu root partition. How to find what ‘hd’ is it?

So try as suggested, i have to sleep now

title Ubuntu 10.04
    rootnoverify (hd0,8)
    kernel /boot/grub/core.img


#Don't change this comment - YaST2 identifier: Original name: none#
title      Ubuntu  
root       (hd0,8)
kernel     /vmlinuz root=/dev/sda9 ro quiet splash
initrd     /initrd.img