dual booting sle11 and windows 7

i want a dual boot system with sle11 and windows 7.i have already installed 7.when i am trying to install suse suse can’t find the installed windows and i can’t resize or edit a
ntfs partition.suse asked to format the whole harddisk.how to install sle11 with windows 7.please help me i am new to linux:(

Use the partitioner in windows (in control panel) to shrink the windows partition. Make sure no residual Linux partitions were left on the drive (delete from in windows if there are some there). This leaves empty space at the end. Then the SLES installer should choose to use the empty space and leave windows 7 alone.

Once you have created empty space with the windows partitioner, prevent the SLE installer from changing windows’ partition.

thank u swerdna.it is working.i shrink the local c volume by 15gb.when installing sle.it told the memory is not sufficient to install.please tell me the recommended shrink volume.after i shrink the volume by 25gb.when i go to install sle the same error “no automatic proposal possible specify mount points manually in the partitioner dialog” i saw,please help me in fixing this problem.

To bein with this is NOT an SLE forium, this is an openSUSE forum. People may try to help you here nevertheless (we are all very friendly girls and guys), but it may reach beyond our knowledge and you may better go to: NOVELL FORUMS.

IMHO when the installer tells you that there is not enough memory, then it means that there is not enough memory, not disk space. This conclusion does not come from my experience with SLE (which I haven’t), but from my experience with computer terms.

I think 25Gb is enough. And this installation procedure is common across SLE and openSUSE IIRC. You need to use the advanced option and add the partitions.

But there is a complication in that windows 7 nearly always uses two partitions and SLE likes to have three partitions, so the total needs are 5 partitions. However you can only have four primary partitions on a hard drive. So you have to have a mix of primary partitions and logical partitions within an extended container partition.

I would first create a 25Gb extended partition to occupy the whole clear zone. This will be a container wherein you place the three partitions that you need for SLE. Then create in that container a root partition of 10Gb, a swap partition of 1Gb and a home partition of 14Gb (you know your needs – modify that if you think a different proportioning is appropriate).

And before you do any of that: I think you are new to this business of partitions and it’s a super-tricky area. So you must back up all important windows data before you start. I would (myself) additionally make a disk image of the whole windows shebang before I began, so if it goes nuts because I clicked the wrong button, I could write windows back over the top of the whole mess, if I made a mess, which I often did make when I was a new user.

Finally, you are in the openSUSE forums as hcvv noted. While I’m sure that this approach is the right one, it’s up to you to decide whether you want to start again in the SLE forums over at Novell or just get on and do the job


@swerdna. It could be a bit more complicated John. As he reports that the installer says “it told the memory is not sufficient to install”, * am still afraid there is not enough memory to install. When there isn’t and IIRC then there must first be a Swap partition to get the install going. And becuse that Swap partition must be there before the install starts, it then reports "no automatic proposal possible ". I can be wrong, but it is difficult to decide from here.

@vike4. Please report how much memory your system has.*

you are, of course welcome to seek/accept and use all help offered
here, but be advised that since your subject line says you are working
with the enterprise offering of Novell named SUSE Linux Enterprise
Desktop, then you have rights to seek assistance from the directly
folks who produce that software, at forums.novell.com

yes, there is a family connection between the focus of this forum
(openSUSE) and SLED…but they are not the same product and while
openSUSE provides updates and patches without cost for the version’s
life time, after 60 days that requires a fee paid to Novell for SLED

there are advantages to that (version longevity for one, SLED 11 has
several years of life remaining, openSUSE 11.4 just out, will drop
dead September 15th 2012 <http://en.opensuse.org/Lifetime>)

if you intended to install the free and open source openSUSE then you
want a download from here: http://software.opensuse.org/

your money, your time…

you might save yourself some time by reviewing the new user info in

as well as information linked on the openSUSE download page…

CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

On 2011-03-27 20:06, swerdna wrote:
> I think 25Gb is enough.

Not enough memory means not enough RAM. He probably needs to create a swap
partition first. He really must ask about this in the SLES forum, I don’t
know if the SLES installer will catch that swap.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Though I’m not a computer engineer… This message (if related to memory) can be legit and there are known cases in which it might pop in… a couple of things that can be done:

  • Grab the motherboard manufacturer’s manual and check if there’s an option close to ‘Fix Memory Holes’ and enable it;
  • set ‘mem=256’ on boot kernel parameter for installation;
  • Boot the installer with the PAE Kernel (I would personally pick this one) and later on the runtime fix it; (IF SLES SHIPs WITH ONE, I don’t know, I’ve nerver used SLES)

This are some of the possible workarounds… but there’s more…

Boot the installer on rescue mode, load fdisk and create a swap partition (primary). This can also solve the problem under certain circumstances… As this is SLED, I would definatly for Novell support as they can debug backtrace the origins of this easier. Providing the relevant info would help a long way.

@hcvv my product:hp probook 4520s,300gb hdd,2gb ram,intel core i3 processor.

Hm, RAM enough.

Personally, I’d just ignore the message and create the partitions.

On 03/28/2011 12:36 PM, swerdna wrote:
> Personally, I’d just ignore the message and create the partitions.

in which case (since his first post says “suse asked to format the
whole harddisk”) i’d expect a high probability that Win7 and any
collected data already on the disk would be removed, over-written, or
otherwise corrupted/lost…

@vike4, i’d strongly advise you to make an off machine (or at least
off this drive) backup of all data you wish to keep, before
proceeding with this install…and, be sure you have the ability to
reinstall Win7 even if your entire hard disk is erased…

CAVEAT: http://is.gd/bpoMD
Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
[NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

Well, of course do not follow that suggestion of “formatting the whole hard disk”. There are possibilities enough in the installer to go expert (or what it is called) and do exactly what you want.

i shrink the windows partition 30gb though suse told me there is not enough memory.what can i do?please help me.the swap partition was 768mb and root partition was 1.67gb.i can’t change this size.i am going to format the entire disk and reinstall the os.can i install suse first before windows please help me.i am waiting.

On 2011-03-28 14:36, vike4 wrote:
> i shrink the windows partition 30gb though suse told me there is not
> enough memory.what can i do?please help me.the swap partition was 768mb
> and root partition was 1.67gb.i can’t change this size.

You have to, those sizes are too small. Where are those 30 GB?

> i am going to
> format the entire disk and reinstall the os.can i install suse first
> before windows please help me.i am waiting.

They have already.

You should really ask in the SLES forum, not here.

Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

thanks for swerdna,hcvv and all other wise penquins.my problem was fixed.thank u so much.