Dual booting OpenSuSE on my gateway

i’ve just got my gateway laptop which has a recovery option. Due to my observation, the computer has 3 primary partitions when I firstly got it: 12.7 GB, whose property is system recovery (empty and hidden); 100MB whose properties are ACTIVE, primary partition; partition C whose properties are BOOT, system, primary partition, crash dump and page file. Seems that when the machine starts, it firstly read the 100MB partition and then it is leaded to the partition C, where the windows 7 is installed. I SHRINKED THE PARTITION C AND CREATED 3 LOGICAL DRIVES.
Now I want to install OpenSuSE 11.4 on one of my logical drives. What should I do to keep all things well, which means I will be able to dual-boot and also keep my recovery function well? What’s more, what I do not want is that the windows 7 cannot be chosen at boot or neither of them can boot!

@grubstreet! Can’t you ask in your neighbourhood? lol!
(next partition two blocks from here)

sorry I do not know what you mean in this joke…

Please post the ouput of

fdisk -l

Nevermind. All ways lead to Grub. One way would have been to leave the space unallocated and let the setup organize the partitions for you. But if you already created 3 logical partitions, as you stated - a better approach anyway - here’s what you can do:
[li]Make sure these partitions have the appropriate size: [/li][LIST]
[li]25-40 GB for /[/li][li]2 GB for swap[/li][li]the rest for /home[/li][/ul]
If the size of your partitions are not +/- in this range, you should resize them before proceeding. You can do that in Windows, if that’s how you did previously.

[li]In openSUSE setup, select [b]Create partition setup[/b] and [b]custom partitioning (for experts)[/b].[/li]

[li]Select the partitions you dedicated to Linux one by one. Don’t touch the Windows partitions![/li][ul]
[li]Format / (root) in ext4 and choose mountpoint [b]/[/b][/li][li]Format swap as swap with mountpoint [b]swap[/b][/li][li]Format /home in ext4 and choose mountpoint [b]/home[/b][/li][/ul]

[li] To make sure that the setup manages the Grub installation properly (it should), click on [b]Booting[/b] in Installation Settings and open the [u]B[/u]oot Loader Installation tab.[/li]You should have [x] Boot from extended partition checked and all other options unchecked.

[li] When you’re done with the installation, you should see the Grub menu at boot where you can choose between openSUSE or Windows. However one of the following situations might occure:[/li][ul]
[li]the added Windows boot entry might be wrong [/li][li]there might be two entries (one of them booting into the Windows recovery environment - which is not what you want!) [/li][li]an entry to boot Windows might be missing[/li][/ul]
In any case, there are details that can be fixed later by writing the correct Windows boot entry in the file /boot/grub/menu.lst or installing and using [b]updategrub[/b] for this purpose.


This is the theory. We can not guarantee that it will work on you computer until we see your partition table. This is why you should post the the output of the command fdisk -l, as already suggested.

I am using windows 7 but I couldn’t find fdisk when using cmd.

The Linux fdisk was meant. You have to boot Linux from a live CD - before installing it - open a terminal and issue this command there.

Of course not, I do not know anything abot Windows :), that is why I try to help on an openSUSE forum. Also people here reported that Windows partitioning programs report next to nonsense when asked what the partitioning is like. >:(

Long ago Windows used to have a fdisk program note that is not the same as the Linux fidisk program. But I think they no longer have it. You need to be running some form of Linux to run fdisk, maybe from a CD.