Dual-Booted Windows and Suse, but No Option to Boot one or the other appears. Solution anyone?

Too Long Didn’t Read (TLDR): I have Windows 7 installed on its own partition and Suse on another. Both boot up properly after repairing their installs with the appropriate disc. However, I have no option of selecting what O/S that I’d like to load. Please help me solve this issue lol.

Hey guys, I just recently set up my laptop to dual-boot with Windows 7 and openSuse Enterprise 11.x. Originally, I had Windows 7 taking up my entire disk, so when I installed Suse I shortened the NTFS partition and installed Suse on the newly created ext3, along with swap and root. I set it up properly and installed correctly as well.

Now, the problem I am facing is that I do not have an option to select which O/S to boot when I start up my computer. After I installed Suse, it shows the O/S screen but only displays Suse and its Failsafe counterpart.

I booted Windows with my 7 disc and repaired it, fixing the MBR so Windows can boot. After I did that however, it boots straight into Windows without any O/S selection. I then booted from the Suse disc and corrected the problems with the MBR, and yeah, just like you guessed, it boots right into Suse lol. I just repaired Windows again and the same problem occurs.

So basically, I have Windows 7 installed and working on its partition, and Suse working properly on its partition. My problem now is that I need to fix my computer so that the O/S selection screen appears when I boot up and I can choose between Windows and Suse.

I’m sure someone out there knows how I can fix this, and if you do, please respond! Any help is greatly appreciated!!

Thanks everyone.

Hello sgrayjr289,

Just to get an idea of your disk layout.
Could you post the output of this command:

fdisk -l

That’s strange, openSUSE should auto-detect the Windows installation and add it to the Grub bootmenu.
Anyway, you can’t use the Windows MBR because it’s impossible to boot Linux with it.

So make sure you use GRUB and not the Windows bootloader.
Could you post the output of this command:

cat /boot/grub/menu.lst

You should add a section for Windows 7 which looks like this:

title Windows 7
    root (hd**X**,**x**)
    chainloader +1

Before you add this you need to replace the **X **and the x.
Replace the first one with the harddisk Windows is installed one.
Note that Grub starts counting at 0, so your first harddisk will be 0.

Replace the second x with the partition, again the partitions are counted from zero.
So the first partition will be 0.

This could also be done through YaST.
Start YaST->System->Bootloader.

Good luck!:wink:

Thanks for the response Edward. I was going to submit my terminal command responses so you could look at them, but the Windows boot options you listed to add to /boot/grub/menu.lst is exactly what I needed.

title Windows 7
root (hdX,x)
chainloader +1

I added those lines to the file, changed the partition to the NTFS System Reserved one, rebooted, and it works perfectly. Thanks again!