Dual boot XP and openSuse 11

I have been running openSuse 10.3 for a while now. I just downloaded the v11 dvd, did a clean install and the install seemed to go fine until the bootloader section. Maybe I made a mistake, but I’ve always used Lilo instead of Grub. So I changed the bootloader to Lilo and it didn’t install. I switched it back to Grub and it installed. Upon reboot, the screen flashed the word Grub and instantly booted into XP. I rebooted with the install DVD again and selected repair and bootloader. I then switched it back to Lilo and it says it installed but it does the same thing; screen flash, Lilo, boots XP. Am I doing something wrong?
My system:
Asus A8V
AMD Athlon64 4000+
1gb ram
Western Digital 80gb x2
nVidia FX6200

sda1- WindowsXP Pro - uses whole drive
sdb1- openSuse - /
sdb5- openSuse - /home
sdb6- openSuse - swap

Should I try to write a configuration by hand or am I just missing something. I haven’t had a issue with any bootloader since I selected Grub when I installed Suse 9.0 a long time ago. Different machine as well.

Thanks for the help.

As you know dual booting Xp and suse should not be problem.
Where did you install the boot loader ?
Is it now GRUB or LILO ?
I myself always use Grub.
From my experience the repair option works good
You did not supply the contains of the boot loader so I can not determine what is going wrong.


Well, actually I found grub4dos to be a less problematic solution.

See here:
[SOLVED] Booting into an installed opensuse 11 system with grub4dos - Boot Land](http://www.boot-land.net/forums/index.php?showtopic=4983)

On some systems, Windows starts behaving strangely if someone else touches the MBR.

So, its best to install grub to the boot partition, and use grub4dos to boot into opensuse.

Hope this helps.

Grub seems pretty reliable from an sdb install – put boot code in the mbr of sda-- seems to work except you have to tweak Grub’s entry for windows sometimes to make it this in your situation:

title Windows XP
rootnoverify (hd0,0)
chainloader (hd0,0)+1

Probably you should repair it again and make sure in the Grub config under the tab “Boot Loader Installation” – make sure to uncheck the root or boot partition and put the checkmark into the MBR selection or it won’t work for an sdb install on a repair sometimes. That should get you into Suse OK but the repair process usually leaves windows out. So reinit grub again after a normal boot and it will attach windows, which if it hiccups you should check that it looks like the above.

For a fuller explanation look on this link.

Thanks for the suggestions all. I will give them a shot and get back with the outcome.

OK, got it going. Thanks for the help.

Just for interest – what did you do?

I went ahead and re-installed the whole system. Grub still wouldn’t work so I booted from the install DVD again (repair) and told it to use LILO. It didn’t actually see the windows partition until I rebooted into openSUSE again and made the addition to LILO there. Working fine now. I just have to figure out how to make this nVidia card work properly now.