dual-boot with Windows 7


I am a novice with Linux and just recently tried to install openSUSE on a Windows 7 machine (HP EliteBook Folio 9470m). I checked the System Bios and it is selected as legacy and no uefi with/without CSM.

After the install, I am unable to see Windows in the Grub menu :frowning:

How, I initially performed the install was shrinking the drive to an non allocated partition of 50 GB for the Leap42.3 and installed openSUSE on it.

Outputs to fdisk-l and parted-l looks as below.

linux-bed1:~ # fdisk -l
Disk /dev/sda: 167.7 GiB, 180045766656 bytes, 351651888 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xf602d214

Device Boot Start End Sectors Size Id Type
/dev/sda1 2048 1023999 1021952 499M 7 HPFS/NTFS/exFAT
/dev/sda2 * 1024000 246792239 245768240 117.2G 7 HPFS/NTFS/exFAT
/dev/sda4 246794238 351651839 104857602 50G 5 Extended
/dev/sda5 246794240 248893439 2099200 1G 82 Linux swap / Solaris
/dev/sda6 248895488 290004991 41109504 19.6G 83 Linux
/dev/sda7 290007040 351651839 61644800 29.4G 83 Linux
linux-bed1:~ #
linux-bed1:~ #
linux-bed1:~ # parted -l
Model: ATA INTEL SSDSC2BF18 (scsi)
Disk /dev/sda: 180GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 524MB 523MB primary ntfs type=07
2 524MB 126GB 126GB primary ntfs boot, type=07
4 126GB 180GB 53.7GB extended type=05
5 126GB 127GB 1075MB logical linux-swap(v1) type=82
6 127GB 148GB 21.0GB logical btrfs type=83
7 148GB 180GB 31.6GB logical xfs type=83

I created a directory within /mnt and called it hdd and tried to mount /dev/sda2 without luck. As said I am a novice so I might be doing something wrong there. But the output looks as below.

linux-bed1:~ # cd /mnt/hdd
linux-bed1:/mnt/hdd #
linux-bed1:/mnt/hdd # pwd
linux-bed1:/mnt/hdd #
linux-bed1:/mnt/hdd #
linux-bed1:/mnt/hdd # mount -t ntfs /dev/sda2 /mnt/hdd
Failed to read last sector (350625839): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn’t setup yet,
or it was not setup correctly (e.g. by not using mdadm --build …),
or a wrong device is tried to be mounted,
or the partition table is corrupt (partition is smaller than NTFS),
or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount ‘/dev/sda2’: Invalid argument
The device ‘/dev/sda2’ doesn’t seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
linux-bed1:/mnt/hdd #
linux-bed1:/mnt/hdd # mount -t ntfs /dev/sda1 /mnt/hdd
ntfs_mst_post_read_fixup_warn: magic: 0x99e09640 size: 1024 usa_ofs: 9471 usa_count: 49059: Invalid argument
Record 0 has no FILE magic (0x99e09640)
Failed to load $MFT: Input/output error
Failed to mount ‘/dev/sda1’: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it’s a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the ‘dmraid’ documentation
for more details.
linux-bed1:/mnt/hdd # ^C

I am open to all suggestions - won’t like to screw up the current installation of Windows 7 though.