dual boot windows and linux, installing linux from image

currently running Xp Pro on first 30gb partition of hard drive with second 30gb partition formated as NTFS(My Documents). The hard drive has unused partition space of around 20gb. Also have second internal Hard Drive with 20gb FAT32 partition with 80gb unused partition space.

I had extracted openSUSE-11.2-iso to the FAT32 partition. Then I had used a virtual drive to mount the original linux.iso while running windows. The program started and ran a few commands. Then required restart.

The boot now contained a boot menu with windows and openSUSE installer. The Installer required CD, Network, Or HardDrive for setup files. I selected hardDrive, select the FAT32 partition, “/”, and pressed enter. The Installation Begain. I got to the partition setup process which setups a Swap and Linux partition. initiated install.

it begains by seting up the partitions and as it adds the windows mount points for the three partitions NTFS, NTFS, and when it tries to mount the FAT32 it creates an error.

the error states the partition busy, basically cause it is supplying the setup files. Trying to run the install again i can not edit the FAT32 partition to unmount as it contains the setup files.

is installing openSUSE from a hardDrive possible while running windows without using CD or DVD?

The simple answer is yes. Assuming you have downloaded a Live CD version, you can put it on a USB stick and install from there.

Live USB stick - openSUSE

to clairify my situation…
I have extracted my opensuse iso to the c:\ of windows xp. I then use poweriso virtual drive to mount the iso image. This launches the setup wizard which make a few changes then requests for reboot. my boot now has a menu which contains opensuse installer.

it asks for CD, to which i press back. it then asks for preferred language. Then Asks for installation source. I select Hard Drive which then asks for which partition. Eventually i get into the Installation which asks for user name and information, and partition setup.

Originally I had extracted the iso to a logical partition to launch this setup, only to find the installation to fail when it tries to create a mount for this windows partition.

When i extract the iso to the primary partition (C:) the installation completes this section and proceeds to further install. Only to fail around 13%.

Unable to create repository… url "hd:/?device=/dev… Device is Busy… cannot access installation media… check whether the server is accessible.

I have seen threads somewhat simular to this but only from dvd installations to which people refer the problem is related to a corrupted download

I had seen a thread in particualr that i didn’t quite understand, but i feel my be the root to my problem. It describes that a NTFS can only be written to by the root user.

Ok, now I unserstand. I noticed through my trial and error that you cant edit a partition that is being used as the source medium. So I installed the iso to two partitions. I used a logical partition as the source of installation so that i could reconfigure the mount of the root partition. I also relized it was unessasary to extract the iso cause it can be utilized by entering the correct file name and extension when requested.

During installation setup, i had choose to edit my partition setup. I edited the Main Windows Partition. You must edit the fstab section of the mount. This will display a code which i don’t yet understand but at least know is where my corrections are to be made. I had replace the section “fmask=113,dmask=002” with “umask=0002”. I accepted all changes and began installation. After the partitions and mounts are created the same error i have always recieved appears. I choose to show details and replace the text that describes the URL location. I change the location from my logical partition to my root partition. And Voila. it works now.