[dual boot windows 10] windows crashed impossible to reinstall

Greetings !!

The windows 10 version crashed after only two monthes… windows 7 never crashed untill I had to change the whole hardware setup.

Now, I’m trying to reinstall.
But when all the files have been copied, after the first reset, I got grub (I was happy to know windows 10 didn’t messed it up) I got a
message indicating windows couldn’t install on this hardware. This is the same dvd I used to install windows 10 in september.

Any idea to proceed ?

Both systems are EFI…

…I don’t know what to do.

The installation can not resume, I got an error message telling me to reinstall.

Is your openSUSE Leap 15.2 installation still working?

If so, please provide the results of

# parted -l
# efibootmgr -v

Run the command as root in a console and provide the complete result including the command line and the next empty command prompt.

Is secureboot enabled in your UEFI?

Regards

susejunky

Sorry for the lateness…

Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  525MB   524MB   primary  fat16        esp, type=ef
 2      525MB   47.2GB  46.7GB  primary  ntfs         boot, type=07
 3      47.2GB  47.5GB  268MB   primary  fat16        esp, type=ef
 4      47.5GB  120GB   72.6GB  primary  btrfs        type=83


Model: ATA TOSHIBA DT01ACA0 (scsi)
Disk /dev/sdb: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  275GB  275GB  primary  btrfs        type=83
 2      275GB   500GB  225GB  primary  ntfs         type=07


Model: ATA KINGSTON SUV400S (scsi)
Disk /dev/sdc: 240GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End    Size    Type     File system  Flags
 1      1049kB  161GB  161GB   primary  btrfs        type=83
 2      161GB   240GB  79.0GB  primary  btrfs        type=83

and

BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0003,0001,0002
Boot0000* opensuse      HD(3,MBR,0xf22dd307,0x57e4800,0x80000)/File(\EFI\OPENSUSE\GRUBX64.EFI)
Boot0001* Hard Drive    BBS(HD,,0x0)..GO..NO........u.K.I.N.G.S.T.O.N. .S.V.3.0.0.S.3.7.A.1.2.0.G....................A.................................>..Gd-.;.A..MQ..L.0.5.2.0.B.6.8.7.3.5.0.0.0.3.5.6. . . . ........BO..NO........u.T.O.S.H.I.B.A. .D.T.0.1.A.C.A.0.5.0....................A.................................>..Gd-.;.A..MQ..L. . . . . . . . . . .1. .5.5.6.M.H.6.S.M........BO..NO........u.K.I.N.G.S.T.O.N. .S.U.V.4.0.0.S.3.7.2.4.0.G....................A.................................>..Gd-.;.A..MQ..L.0.5.2.0.B.6.6.7.7.6.2.0.5.B.A.F. . . . ........BO
Boot0002* CD/DVD Drive  BBS(CDROM,,0x0)..GO..NO........u.T.S.S.T.c.o.r.p. .C.D.D.V.D.W. .S.H.-.2.2.4.D.B....................A.................................>..Gd-.;.A..MQ..L.9.R.E.3.8.6.F.D.0.A.9.2.5.P. . . . . . ........BO
Boot0003* Windows Boot Manager  HD(1,MBR,0xf22dd307,0x800,0xfa000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)..BO

…the only thing is that I never remembered the way Windows need to be awared that its bootloader is somewhere (in the first partition in my case)
There was a command related to bcd, I think.

secure boot hasn’t been set.

Hi
Realistically, disk should be gpt, there are a few forum threads uefi/msdos…


Partition Table: msdos <=====
Disk Flags:
Number  Start   End     Size    Type     File system  Flags
1      1049kB  525MB   524MB   primary  fat16        esp, type=ef

…last partition set was GPT… I couldn’t install windows 10 untill I wiped out the whole partitions.
I lost a complete week-end doing so.

Here windows is there but the install don’t want to go further.
I will try to set up things following some tricks I got here to let the installer complete/resume.

You have two EFI system partitions (sda1 and sda3). That should not really cause problems but is a fact to keep in mind.

I’m not an expert on Microsoft Windows 10 but for what i know if you install MS Windows 10 on an UEFI system the drive you want to put MS Windows on must have a GPT partition table (and as far as i can see, none of your drives has such a partition table).

Regards

susejunky

Please have a look here: UEFI/GPT-based hard drive partitions | Microsoft Learn

Regards

susejunky

Hi
Not partition, but disk…

Backup and start again… boot from a live USB rescue and pre-configure the disk [wipefs and gdisk]? Likewise WinX needs a 16MB partition type 0c01

Something like;


sda type gpt

sda1 260M type ef00 (format via mkfs.vfat /dev/sda1)
sda2 16M type 0c01
sda3 X GB type 0700 (for WinX)
sda4 X GB type 8300 (for Linux)

When I use “os-prober” I got

sirius:/boot/efi # os-prober
/dev/sda1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/sda3@/EFI/microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
/dev/sdc1:openSUSE Leap 15.2:openSUSE:linux:btrfs:UUID=0f381669-91e2-48ac-a969-1c5d9b35550e:subvol=@/.snapshots/1/snapshot

…normally I got only one line, the one on /dev/sda3 (???)

It is like I have two windows on it…
Should I wipe the two partitions the /dev/sda1 and /dev/sda2 (efi partition and windows partition) ?
I can’t wipe the other partitions…

When I run “os-prober” here, it gives the EFI partition containing the Windows boot code. It does not list the partition where Windows is actually installed.

Your output suggests that both “/dev/sda1” and “/dev/sda3” are EFI partitions containing windows EFI boot code.

Corrected…

Seems to be weird… I drop Windows for now.

I run Windows in a VM works better then dual booting as long as you don’t need gaming

I’m 81 years old and thought I would give this a try. I very carefully followed your instructions to the tee. It worked just as you said and now I’m ready to build a new computer, maybe: How To Create And Use Bootable USB Drive To Install Windows 10 Free & Legally

Warning: Not yet tested by folks older than 81 years.

Again, 1177358 – EFI system partition: VFAT or FAT16 or FAT12 or FAT32? .

Windows + UEFI requires GPT + FAT32 for EFI system partition.
With Leap 15.2 and earlier you will get FAT
16
with volumes ≤ 512 MiB.

So, there are some ways:

  1. Format drive manually to get FAT32 for EFI system partition.
  2. Install Windows first with reformatting the whole drive. Then, when installing Leap, choose not to format EFI system partition.
  3. During installation of a Leap choose EFI system partition > 512 MiB. Check 1170625 – UEFI: ESP Partition is formatted with FAT16 instead of FAT32 .

To my experience Windows Installer doesn’t care. It happily installed using a 100MB partition created with Yast2 Installer:

**erlangen:~ #** fdisk -l /dev/sdc 
**Disk /dev/sdc: 465.78 GiB, 500107862016 bytes, 976773168 sectors**
Disk model: Samsung SSD 850  
Units: sectors of 1 * 512 = 512 bytes 
Sector size (logical/physical): 512 bytes / 512 bytes 
I/O size (minimum/optimal): 512 bytes / 512 bytes 
Disklabel type: gpt 
Disk identifier: 90C1973B-4A41-4E96-85BA-B7358EA77CCC 

**Device****    Start****      End****  Sectors****  Size****Type**
**/dev/sdc1       2048    208895    206848   101M EFI System 
**/dev/sdc2     208896  63119359  62910464    30G Linux filesystem 
/dev/sdc3   63119360 126033919  62914560    30G Linux filesystem 
/dev/sdc4  126033920 512202751 386168832 184.1G Linux filesystem 
/dev/sdc5  512202752 638033919 125831168    60G Linux filesystem 
/dev/sdc6  638033920 700948479  62914560    30G Linux filesystem 
/dev/sdc7  700948480 734502911  33554432    16G Linux swap 
/dev/sdc8  734502912 793495551  58992640  28.1G Linux filesystem 
/dev/sdc9  793495552 852088831  58593280    28G Linux filesystem 
**/dev/sdc10 852088832 852121599     32768    16M Microsoft reserved 
/dev/sdc11 852121600 976773119 124651520  59.4G Microsoft basic data 
****erlangen:~ #**

Windows Installer never touches used space. Installation is easiest with contiguous free space at the end of the drive. Procedure is somewhat confusing when installing in a gap between existing partitions.

I cannot contribute on what’s going on with the the OP’s system but I just wanted to share my experience installing W10 without a problem in a system with LEAP 15.1 and with 2 separate EFI partitions.
https://forums.opensuse.org/showthread.php/540920-W10-reinstallation-wih-existing-LEAP-15-1-on-the-same-SSD-Succesfully-on-GPT

No data is available about FATxx bitness on /dev/sdc1.

I never cared:

**erlangen:~ #** parted -l          
Model: ATA Samsung SSD 850 (scsi) 
Disk /dev/sdc: 500GB 
Sector size (logical/physical): 512B/512B 
Partition Table: gpt 
Disk Flags:  

Number  Start   End     Size    File system     Name                          Flags 
** 1      1049kB  107MB   106MB   fat16           EFI System Partition          boot, esp **
 2      107MB   32.3GB  32.2GB  ext4            Linux System 
 3      32.3GB  64.5GB  32.2GB  ext4            Linux System 
 4      64.5GB  262GB   198GB   ext4            Linux Filesystem 
 5      262GB   327GB   64.4GB  btrfs 
 6      327GB   359GB   32.2GB  ext4            Linux System 
 7      359GB   376GB   17.2GB  linux-swap(v1)                                swap 
 8      376GB   406GB   30.2GB  btrfs           Linux System 
 9      406GB   436GB   30.0GB  ext4            Linux System 
10      436GB   436GB   16.8MB                  Microsoft reserved partition  msftres 
11      436GB   500GB   63.8GB  ntfs            Basic data partition          msftdata 


Model: Samsung SSD 950 PRO 512GB (nvme) 
Disk /dev/nvme0n1: 512GB 
Sector size (logical/physical): 512B/512B 
Partition Table: gpt 
Disk Flags:  

Number  Start   End     Size    File system  Name                  Flags 
** 1      1049kB  106MB   105MB   fat16        EFI System Partition  boot, esp **
 2      106MB   13.2GB  13.1GB  ext4         Linux System 
 3      13.2GB  68.7GB  55.5GB  btrfs        Linux System 
 4      68.7GB  512GB   443GB   ext4         Linux Filesystem 


**erlangen:~ #**