Dual boot win10 - Tumbleweed Grub loading error


I just intended to join the OpenSUSE community by installing tumbleweed on dual boot with windows 10.

I went on uefi options, and desactivated the security boot mode. Then I did a copy of the iso on my usb, and installed tumbleweed. And here comes the complications.

I followed the automatic installation which offered me to create new partitions on my hard drive as followed:

As you can see, my windows partition hasn’t been erased (yeay!), and the allocated partitions for OpenSUSE are sda7 8 and 9;
with sda1 for UEFI and sda6 for BIOS Boot.

The thing is that when i reboot my computer, either it doesn’t boot any OS if the usb isn’t pluged:


Either I can log on what i think is usb live when the USB is pluged in:

From what I understood, this is a GRUB2 installation problem. How could I repair grub without harming my hard disk ?

Thank you for your help;


I’m not entirely sure what you did there.

However, when I look at your “df” output, I do not see a line for “/boot/efi”.

That probably means that you installed Tumbleweed for legacy booting instead of for UEFI booting. I’m guessing that is related to your problem.

You should be able to change that.

Mount your UEFI partition as “/boot/efi”, and add an entry to “/etc/fstab” for that. You can probably use Yast partitioner for that.

Once that is done – and I suggest reboot to make sure it is mounted, you can use Yast bootloader. Switch from using “grub2” to using “grub2-efi”. That should set you up for UEFI booting.

On second thoughts, that last step won’t work. You have to be booted in UEFI mode to be able to switch to grub2-efi.

May start by trying to boot your install USB in UEFI mode. You would need to do that for repairs. Or, if you manage to do that, you might find a reinstall to be simpler.

When you boot the installer in Legacy mode, there are some function keys you can use (with notation at the bottom of the screen). When you boot in UEFI mode, there are no function key notations. You can use that distinction to help see whether you booted in UEFI mode.

Well, first of all, thanks for your feedback.

I launched YAST, and saw what you where speaking about. Here is the disk partitioning:

sda hard disk
sda1 EFI Boot FAT SYSTEM /boot/efi
sda2 HPFS/NTFS NTFS Recovery
sda3 Microsoft Reserved
sda5 HPFS/NTFS NTFS Restore
sda6 Bios GRUB
sda7 Linux Swap SWAP swap
sda8 Linux native BtrFS /
sda9 Linux native XFS /home

sdb USB
sdb1 EFI (FAT-12/16) FAT
sdb2 Hidden HPFS/NTFS ISO

Here, it seems that sda1 has the correct /boot/efi path.
I went back on BIOS seting :
“Launch PXE OpROM policy”: Enabled controls the execution of UEFI and Legacy PXE Oprom
“Launch CSM”: Enabled : This option controls if CSM will be launched

If I understood well, the equivalent of sdb1 should be on sda. Should I format sda6 (BIOS Grub) to be the equivalent of sdb1: EFI (FAT-12/16) FAT

That partitioning looks okay.

In your earlier graphic, I did not see “/boot/efi” (mounted from “/dev/sda1”).

Maybe check the output from:

# efibootmgr -v

This might give an error (about “efivars” or similar), or it might give useful information about booting.

Well here is the prompt:

Bootcurrent : 0005
Bootorder: 0005,0006,0004,0007
Boot0004* CD/DVD Drive
Boot0005* UEFI: Corsair Voyager Mini (USB Stick)
Boot0006* Hard Drive BBS (HD,0x0)
Boot0007* Network Card BBS

So here is the anwser, it boot on 0005 which is my USB stick …

Additionnaly, on Yast > Bootloader was on GRUB2. I intended to change to GRUB for EFI but it prompts an error:

Execution of command </usr/sbin/shim-install config file /boot/grub2/grub.cfg ] failed
Exit code 1

Is Windows 10 using UEFI booting?

You did mention “secure-boot”. If you were booting with that, then it uses UEFI.

The output from “efibootmgr -v” does not appear to be showing Windows. It also shows booting your USB as the default, which might explain why you always need the USB.

Maybe you can list the output from:

ls /boot/efi/EFI

If you got BIOS Boot, your installer was not launched in EFI mode.

it doesn’t boot any OS if the usb isn’t pluged:

It sounds like GRUB (at least, boot sector) was mistakenly installed on USB disk (unfortunately your picture is too small for me to see what is written, but it does not look like installer in any case).

At this point the easiest solution is probably to reinstall making sure to boot installer in EFI mode. You probably need to re-create USB though.

Completed a reinstallation of the system, and now it works properly. Thanks for the help!