Dual-Boot w/Linux Query

Hi all,

I’m very new to linux and completely new to openSuse so forgive me if this question has been asked and answered many times before. I have been running Ubuntu (latest release) for just over a week now and have enjoyed it overall. The biggest caveat being it seems a tad sluggish. Anyway, I want to try OpenSuse as well and hope to create a dual boot setup. Using the OpenSuse live CD can I do this without knowing a lot of technical details or are there some things I need to know first?

From looking around on the forums it looks like it should setup just fine but I wanted to be sure prior to getting started. Thanks in advance!

As you said:

OpenSuse 11.x does its job perfectly to install and maintain a dual boot grub. So you will see a start menu which lets you change to Ubuntu. There, again, you get ubuntu’s own grub start menu again. Ubuntu HardyHeron leaves the grub installation alone, which is always an issue at kernel updates, which are entered as an additional choice into the grub menu.

Also, take care of correct drive paths in ubuntu’s grub menu and in /etc/fstab as well. Usually the path is shown in the grub entries like


boot (hd**m,n**)
root=/dev/disk-by...../part**X**

with m,n corresponds to the disc drive and partition number (counting always starts with 0!) and X is the partition number

In /etc/fstab you may have lines starting with
UUID
This value may alter, when your partition tables are changes (e.g. during installation of Suse). This results in a failure during mounting process.

You should correct the lines in advance of a change of your partititons. So, may be, for your convenience, try to prepare your disks in advance, so you do not have to let SuSe alter the partition table.

Consider two additional partitions, for SuSe / and /home. The swap partition can be used for both Linuxes.

You may use the /home partition for both Linuxes as well. However, this is a nice opportunity to make a big mess.:\

So, go ahead!

So basically its one or the other? lol

I’ll try a clean install and see how OS compares to the U. Sounds like it’ll be the easiest way to go.

Thanks for the reply. :slight_smile:

Well I cannot get either the DVD or live CD to be recognized during boot. After boot I get a dos-like screen with “boot options” in text. The only ‘option’ that will generate a response other than auto reboot is to enter openSuse-11.1 ISO ]. When I do that I get an error message saying “cannot find kernel image.”

I have burned the disks twice each (using good disks) at 2x and 1x with the same result. May I then assume it’s because I have Ubuntu installed? If so, is there a simple way to get this working?

Did you try to start in text mode?
How to try to get it work with the live CD: see here:
Help - Can’t boot liveCD or install 11.0 or 11.1 - openSUSE Forums
Another hint about graphics and windows memory hole, which could interfere is here:
http://forums.opensuse.org/install-boot-login/403995-installation-boot-error-question.html

If not, let us know…

@rdmike -

Could you please elaborate on exactly what you are seeing. You write that you cannot get the media to be recognized during boot but then after boot you get a DOS like screen, etc. So I’m not clear on what the behavior actually is. I.e., do you not see the first installation menu at all? Do you see it but only as text? Or? The more complete the description (or better yet, a screen shot) the better.

Update

Ok, I tried burning the image again using Sony CD/RW disks instead of the Verbatim CD-R disks I used before. This time around I saw the green welcome screen for choosing language and, after hitting enter got the main menu. Before I wasn’t getting anything save a dos like environment. (no gui at all only black background with white text)

So, the Live CD option would not load at all. I rebooted and this time used the check installation media, I think it labeled, option. That took a while but finally produced a result stating there was an error and the md5 checksum didn’t match. That’s strange to me as I used Transission to downlaod the file (x2) and then DownThemAll (x2) and the initial (before burning) checksum query matched ok. I used GnomeBaker to write the files as its the only one I have found that will allow me to burn at slow speed (K3b, and brasero would not go below 10x for write speed.)

I’m currently downloading the file, again, using Transmission but wonder if there’s a way to ensure you get the correct file via download? I haven’t had this happen before. I have had to dowwnload a file a second time, occasionally, never more than twice to get a good file.

I’ve read through the sticky on getting the file(s) fast which is what prompted me to try downthemall but wonder if there’s something small I am missing here? I get the feeling its probably something simple but hope y’all can help.

Thanks!

There are two different checks to perform. The first is the md5sum check against the downloaded iso file. The second is the media check option on the CD/DVD; it verifies the installation images burned to the disk. So the first check is verifying the download, the second check is verifying the burn (and the files verified are different, too).

Thanks mingus,

I understand the checks but what is confusing me is why the downloads are getting corrupted in the first place? As a comparison, I downloaded a copy of sindows 2000 pro for a desktop of my wife’s a while back and had no problems either with the download or the image burning, on cheap media, and at fast write speed. I’m not trying to start a linux versus sindows discussion rather, I feel there must be some little something I am missing that may, or is, causing a corrupt download and would like to get it figured out instead of downloading the same file countless times until I get a clean copy. See what I mean?

Thanks again for the help, I do appreciate it. :slight_smile:

Sure, I understand. Also, it’s not at all a linux-vs-windows kinda thing. You might be surprised that this is not all that unusual. Having done hundreds of large file downloads, I can testify that files do occasionally get corrupted. And then there are the issues with burners and compatibility with certain media and certain burns. I’m not familiar with Transmission. If the downthemall you are ref’g to, is the Firefox extension - you are moving the data via http in large sections which are reassembled on your machine (i.e., its speed increase comes from simultaneously downloading the sections). I don’t know where you are located geographically, but that can make a difference - the data has to move thru a number of servers and pipes before it reaches you, and not all infrastructure and service providers are created equal; so, it’s worth considering pulling the file from a mirror close to you. Better yet, I would try using a bittorrent client instead; a good client will check the blocks as received and request re-transmission of any that are faulty. Some clients can do a supplementary check at completion. The only thing you know for sure is that the problem is somewhere between the file server where the iso is and your machine - if the file on the server was corrupt, that would be discovered very quickly.

I gotcha. So, is it possible then that because I’m using a wireless connection the likelihood of corrupt files is increased? I’m not a network guy per se but wonder if that increases the chance(s) of packt loss (I think that’s the correct term).

Btw, thank you very much for your patience and understanding. I’m sure some of these questions may be tedious or redundant though to me they’re new and intimidating lol. I tried to get into linux a few years ago (a couple of different distros not openSuse) but felt stupid by replies to my posts for help. Y’all have been patient, informative, and helpful and to me, as a Linux initiate, that means a lot. So, in short, thanks! :slight_smile:

Not a problem at all, glad to be of some help. :slight_smile:

If you have wireless, then I assume you are using a home router. It is theoretically possible to have transmission problems between your wireless NIC and the router, but that is unlikely and if you aren’t seeing problems elsewhere, probably not the issue. There are serious network performance diagnostic tools, but they require technical expertise to use and understand. But you can do a simple “ping” to see if that shows any packet loss:

ping -c 10 software.opensuse.org

By the way, you’ll find the desktop Linux has improved enormously in just the last few years. Something to keep in mind re openSUSE is that it includes quite a lot of software and functionality, some of which is enterprise-class because openSUSE is upstream for Novell’s commercial offerings. As such, openSUSE is also “cutting-edge”; it will include the newest software and kernel and techniques. However, sometimes this results in glitches, particularly just at release. So occasionally there is a bit more effort required to get everything working as desired. Don’t hesitate to ask for help on these forums.

Allright, well I got openSuse installed but I had to use a wired connection to get a clean image, not sure why though.

It seems to be mostly running well but there are a couple of kinks; I expected that so no problem; we’ll get there. :slight_smile:

I wanted to install Thunderbird and had to manually do it because the package manager seemed to be having some difficulty. Here is a error quote I got when attempting to add new repositories per the Wiki.

Download (curl) error for ‘http://download.opensuse.org/distribution/11.1/repo/non-oss/content’:
Error code: Connection failed
Error message: Couldn’t resolve host ‘download.opensuse.org

Also, it seems every few minutes or so I have to manually click on my wireless network else I can’t get web pages to load. I know my wireless adapter is a bit of a stinker (realtek 8187b) but it worked ok in Ubuntu so I’m not sure what’s up with that?

Thanks again.

If you had to use wireline, I would do some checking on packet loss. Do a long ping to several domains and watch for any loss. Also, the iwconfig will summarize activity on the NIC, including packet errors or drops. I suggest you open a new thread in the network sub-forum for getting help setting up your wireless.

Not sure on forum etiquette so please forgive me coming in here but the title of thread is relevant and I seek further guidance please.

I have Suse 10.0 already installed on one partition. I have shrunk this partition to create enough empty space to install OpenSuSe (OS) 11.1 which I am trying to do from Live CD (no DVD drive on this machine).

The Live CD installer doesn’t seem to pick up that I have grub installed already on the machine. What I would like to do first is be able to dual boot either to the new Opensuse 11.1 or to the existing Suse 10.0.

So how should I proceed to install OS 11.1 on the new partition and then get it added to the exiting Grub boot process? Guidance would be much appreciated.

Budgie2

Thanks Mingus!

I’ll switch forums and start a new thread. :slight_smile:

Actually, usually you will get more/faster/better response with your own thread. But I’m happy to give you at least my reply here . . .

This can be a challenge, because the version of grub in 10.0 is different than in 11.0 - primarily, this has to do with a major change made in the 10.3 kernel which now uses scsi emulation for all hard disk drives (your hda will become sda, etc.). Having struggled with this several times now with a lot of heartburn along the way, IME your best bet is probably to install the 10.0 grub to its partition boot sector. Then install 11.1 on its own partition, not touching the other partition in any way yet. Then in your 11.1 menu.lst file add a chainloader stanza that calls the 10.0 stanza in its partition. You can install the 11.0 grub to either the MBR or to its own partition boot sector (or the extended primary, if the 11.0 root is on a logical) along with generic boot code to the MBR. The main thing is to not do anything with one grub that directly touches what your are doing with the other grub. And be careful installing with that CD; it abbreviates the installation process and IMO it would be better to use the DVD and enter the Boot Loader dialog to be certain it was being set up exactly as I want.

Good luck.

Hi Mingus,
OK. Will start new thread as this may help others and I have a clearer objective now.
Many thanks,
Alastair.