dual boot problem Tumbleweed, Windows 10

Since Yesterday all of a sudden Tumbleweed does not boot any more as it should but windows 10 starts, when I turn on my pc.

Dual boot setup were were I should get a grub screen were I can pick either Tumbleweed of Windows 10.

On the bright site typing this from Tumbleweed, so my Linux install is not really damaged, but I need to use the boot menu from my mobo to get Suse to boot.

After I have selected the Tumbleweed disk, ( F11 to get the boot menu from the mobo ) , Grub comes up and all looks as it should be.

So for some reason my pc seems to have forgotten it should start from the Linux disk.

I suspect windows to have done this, maybe an update, but more important how to fix this?

Both os have their own hard disk.

I am not impressed with uefi, or should I say windows 10. I have disabled fast boot on windows, but I often, not always, get when I do start windows 10, that it starts to fix the file system.
This only takes a few seconds, but I do suspect it to be related.

Feels like I should post this on a windows forum, because I am 99% sure windows is the problem here, but I doubt they can help me. :stuck_out_tongue:

Once you’re in TW, use YaST’s bootloader module. Simply open it, check that “Probe for other OS” is checked and hit OK.

Knurpht, I don’t think this is an issue with GRUB and os-prober wouldn’t help since OP’s UEFI skips right to W10. I had this problem after some major W10 updates in my dualboot systems.

There was probably some sort of BIOS/UEFI update on the OP’s computer.

Gps2010, you need to set priority to “Opensuse secureboot” EFI. How to do this depends entirely on your machine and process is different from machine to machine. Set the boot order to boot from your OpenSUSE drive using OpenSUSE EFI file. This will open GRUB which will allow you to choose between W10/TW.

As for your W10 fixing its system. This I cannot tell you what’s wrong but it doesn’t sound normal. I have multiple dualboot systems with W10 and OpenSUSE LEAP/TW and “fixing system” only happens when something is wrong with my HDD/SSD (If you share a partition between the OSes, depending how you have it set up, it may cause issues regularly).

Thank you and this did fix it, but I am a bit confused about it too.

Probe foreign os was already checked in Yast, but I clicked ok anyway ( instead of cancel )

Wonder if win10 overwriting something is causing this or a Tumbleweed update ?

This is not the fiist time this fixes the problem, lets hope I will remember it.

Will try to do some googling on how I can get windows 10 to behave.

Maybe a windows update enabled fast boot again ?

Another thought, to not use restart but shutdown in windows. Then turn on pc again to start Linux.
If I find anything use full , I will report it.

With UEFI, any update to booting might change the boot order. An update on Tumbleweed will put that first. An update (to booting) on Windows will put that first. It’s a minor annoyance that you can learn to live with.

On my system, if I hit F12 while booting, I get a BIOS boot menu where I can choose between Windows and openSUSE. There’s probably a key for that on your system. Use it as a fallback when booting goes wrong.

Windows uses fast-boot, so it does not properly shutdown the file system. And even if you turn off fast-boot, it does this. I eventually disable hibernation in Windows to prevent this. But there’s another simple solution. When rebooting from Windows to openSUSE, hold down the SHIFT key while clicking “restart”. That way, Windows will do a full shutdown. On the next screen, select “Boot from a device”, and it should give you a choice to boot openSUSE. That’s another workaround when the boot order goes wrong.

When back in openSUSE, as root, run:


That will tell you the boot order. You can then change the boot order with something like:

efibootmgr -o 0001,0003,0000

to set the order to what you want. The boot numbers to use are from what you see with the first “efibootmgr” command.

Please start your openSUSE and post the results of

# efibootmgr -v


# parted -l

(Run the commands as “root”.)

The results may help to explain what happened.



Here’s another possibility. I have had this happen.

You have openSUSE as first in booting. You boot to Windows using the openSUSE boot menu.

Your BIOS notices that you never use the Windows boot entry. So it decides to do some cleaning up of NVRAM, and deletes that entry.

No problem. You can still boot Windows with the openSUSE boot menu. But this time, Windows notices that there isn’t an NVRAM entry to boot Windows. So it puts one back. And that make Windows the first in boot order.

You no doubt had a Windows update that affected the bootloader, i.e. the EFI settings. Running the YaST bootloader module does what nrickert describes for you, by the choice of the default startup option.

It must be something like this. I also sometimes have windows disappeared from the grub menu.

F11 for me to get into the boot menu of the UEFI (bios) Asrock mobo

guus@linux-2ls4:~> su
linux-2ls4:/home/guus # efibootmgr
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0002,0006,0007
Boot0000* opensuse-secureboot
Boot0002* Windows Boot Manager
Boot0006* Hard Drive
Boot0007* opensuse
linux-2ls4:/home/guus # 

Linux-2ls4:/home/guus # efibootmgr -v
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0002,0006,0007
Boot0000* opensuse-secureboot   HD(1,GPT,74073301-124d-44a5-94d7-a68ba4d49f7f,0x800,0xfa000)/File(\EFI\OPENSUSE\SHIM.EFI)
Boot0002* Windows Boot Manager  HD(2,GPT,70e1d660-fa10-4c6b-af84-2f6220bf4308,0x109000,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...a................
Boot0006* Hard Drive    BBS(HD,,0x0)..GO..NO........u.W.D.C. .W.D.1.0.E.Z.E.X.-.0.8.W.N.4.A.0....................A.................................>..Gd-.;.A..MQ..L. . . . .W. .-.D.C.W.6.C.2.Y.R.T.3.1.6.F........BO..NO........u.S.T.>..Gd-.;.A..MQ..L. . . . . . . . . . . . .N.Z.0.1.9.W.H.5........BO
Boot0007* opensuse      HD(1,GPT,74073301-124d-44a5-94d7-a68ba4d49f7f,0x800,0xfa000)/File(\EFI\OPENSUSE\GRUBX64.EFI)..BO

Model: ATA WDC WD10EZEX-08W (scsi)
Schijf /dev/sda: 1000GB
Sectorgrootte (logisch/fysiek): 512B/4096B
Partitietabel: gpt

Nummer  Begin   Einde   Grootte  Bestandssysteem  Naam                          Vlaggen
 1      1049kB  556MB   555MB    ntfs             Basic data partition          verborgen, diag
 2      556MB   660MB   104MB    fat32            EFI system partition          opstart, esp
 3      660MB   676MB   16,8MB                    Microsoft reserved partition  msftres
 4      676MB   1000GB  1000GB   ntfs             Basic data partition          msftdata

Model: ATA ST1000DM010-2EP1 (scsi)
Schijf /dev/sdb: 1000GB
Sectorgrootte (logisch/fysiek): 512B/4096B
Partitietabel: gpt

Nummer  Begin   Einde   Grootte  Bestandssysteem  Naam  Vlaggen
 1      1049kB  525MB   524MB    fat16                  opstart, esp
 2      525MB   27,0GB  26,5GB   ext4
 3      27,9GB  998GB   970GB    xfs
 4      998GB   1000GB  2148MB   linux-swap(v1)         swap

Thank you it might be something I will have to live with.

At least I have two easy fixes at hand.

Use the UEFI bootmenu and secondly go into YAST, and mark probe foreign os, even if its checked already, just click ok. :slight_smile:

Your UEFI should boot Boot0000 = opensuse-secureboot first. If that fails it should try to boot B0002 = Windows Boot Manager.

You can use efibootmgr to set the boot order (as root):

# efibootmgr

will show you all the boot entries (Bootnnnn) known by your UEFIs NVRAM. With

# efibootmgr -o nnnn,mmmm

you can set the boot order.

You even can put your own Boot-Entry into your NVRAM

# efibootmgr --create --disk /dev/sdx --part 1 --label "NAME" --loader \\EFI\\PATH\\BOOTLOADER.efi

See man efibootmgr for more details.

Your system got two EFI system partitions. This is not a problem but can sometimes cause unexpected results.

If you want to learn more about UEFI you can read


Those articles helped me a lot when i got my first UEFI-board.



Thank you and I will do some reading.

I do know how I ended up with two UEFI partitions, but had no idea until now this is not right ?

I had allot of issues to get windows 10 installed with UEFI.

test profile picture

About installing Windows 10 with UEFI,is this a good way?

I did not say that having more than one EFI system partition (ESP) “is not right”!

The specification https://uefi.org/specifications definitely allows for more than one ESP in a system. However if you do not yet feel familiar with UEFI having more than one ESP will make life not easier for you.



So far, I think ease really depends on machines. For my Dell Alienware 15 for example, the BIOS/UEFI allows me to browse and search for and specify /.efi for each boot option. This is the same for my custom work desktop.

At the same time my Lenovo T420, T430, W530, T480, Panasonic CF-19 do not let me specify which efi partition and efi file, but UEFI/BIOS seem to be able to automatically search and find them all of the time even if there are more than single /EFI partition on each drive (All of my setup other than Legacy Lenovo W530 have one EFI partition for Windows 10 and one for OpenSUSE).

Personally, I see an advantage of having two /EFI partitions because for my backups, I typically clone a whole setup and the backups are bootable if need be.

The problem I had was that Windows 10 decided to be installed with an mbr, which is the old way.

The new way is UEFI

You can install windows 10 and SUSE both using an mbr or both using UEFI.

You cant mix this.

So you probably want UEFI and format a GPT disk.

If you read the links susejunky gave us, this gets explained. :slight_smile:

Thank you. :slight_smile:

I might have to do more reading and look in he UEFI. I remember at one time, in the UEFI not seeing an option to add a second os.
This was most likely a user error on my site though, because I know this is possible with my mother board.

The only minor issue I have is after selecting WIN10 in the GRUB screen, windows 10 goes to check the file system, but not always.

This takes only a few seconds, so we can conclude it does not check the entire disk.

I will have to do some testing if holding the shift key on shutdown of Windows 10, will fix this. :slight_smile: