Dual boot problem-lost opensuse 11.0

Whatever made me do it, still not quite sure. Probably the geek in me wanted to run another Linux flavor along with what had been a very dependable install of Opensuse 11.0…So, I installed the latest Ubuntu (9.0.4??) on the same drive, all was well for quite some time!!
As of yesterday, started Opensuse 11.0, let it perform some of the updates needed/recommended, rebooted and now opensuse does not run/boot.
The menu option is still there, but error message says “file not found.”. I tried booting off the DVD and running repair but still seems not to want to work.
Can someone point me to good source for attempting to get this repaired and working again?
Greatly appreciated,

Tony …

Try doing the following, carefully following all the steps:

…you can start again and install new Grub code in the Master Boot Record and also overwrite any corrupt menu files (menu.lst) in the existing openSUSE installation with a new menu file.

Boot from your installation DVD. On the first menu screen, select Repair Installed System. After the Kernel & the repair program load, you come to the Repair Method screen with three options:

• Automatic Repair
• Customised Repair
• Expert Tools

Choose Expert Tools and the repair Tool Box window will open. From there select to Install New Boot Loader. Select the partition where you installed SuSE (if asked). You’ll get the Grub GUI setup screen. Check under the Tab “Boot Loader Installation” that the checkmark is in “Boot from Master Boot Record” and remove any other checkmarks. Click “Finish”. Wait for message “The boot loader was installed successfully”. Click OK → Next → Finish. Ignore any error messages and reboot. That should install an elementary Grub and allow you to boot to openSUSE.

The quote is from here: HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive
In particular it’s from the segment titled “Reinstall Grub in the Master Boot Record and write a new Grub menu into openSUSE”.

If that remakes an elementary boot menu, you can boot back to openSUSE and proceed to make an extended bootloader that includes Ubuntu. That extra step is covered in this tutorial: HowTo Multiboot Ubuntu from openSUSE using the GRUB bootloader

The crux of that second tutorial is to put htis entry into menu.lst in openSUSE:

#Don't change this comment - YaST2 identifier: Original name: none#
title       Ubuntu 9.04 booting via symlinks
            root (hd0,8)
            kernel     /vmlinuz root=/dev/sda9 ro quiet splash
            initrd      /initrd.img

Of course, change (hd0,8) and sda9 to fit your situation.


I use Linux Mint’s boot splash screen, so this is what I did for my particular situation.

This happened yesterday for me as well after doing some updates, which included an opensuse kernel update, and doing a reboot, I got to the Mint Boot splash menu and it still showed OpenSuse’s old kernel Selecting opensuse gave me an error 18, file not found, I think.

I have Windows XP, Linux Mint Gnome, Pardus 2008.2 KDE, and OpenSuse11.1 two on one hard drive, two on the second hard drive.

I had to do some simple menu.lst editing to show the latest kernel for opensuse.

I rebooted into Mint. Then clicked on computer that showed the partition file systems. Mounted opensuse. Opened /boot/ and could see the latest kernel with the various files like vmllinux, intrd, system map, etc. Showing I copied the kernel number. Of course, I could have also made a note of the kernel number during the opensuse update process, but I didn’t…

Then in Mint Gnome terninal:
gksu gedit /boot/grub/menu.lst (enter password)
and under opensuse section, everywhere it had the old kernel listed I pasted the new kernel. Save.
Reboot and out of Mint boot splash select opensuse and it comes up.

I’ll have to look into the links swerdna provided, as it would be nice if Mint automatically detected the kernel change. It does detect other operating systems, including Linux, during install and adds it to the menu.lst,


If you want an entry in Mint that doesn’t break when there’s a kernel change in openSUSE you can use the following method:

OpenSUSE has symlinks “vmlinuz” and “initrd” in the /boot directory that point to the current real vmlinuz and initrd. The boot entries call these symlinks (/boot/vmlinuz and /boot/initrd) which call the correct contemporary values in the /boot directory. When an online update replaces the real vmlinuz and initrd in the /boot directory, the symlinks are updated to point to the new files. Thus a bootloader entry based on symlinks is never obsoleted by the online update process, unlike a bootloader entry that uses actual kernel numbers.

The entry you could edit into Mint’s menu.lst is this:

Swerdna’s entry to boot the openSUSE installation on /dev/sda5 by symlinks

title openSUSE 11.1 (on /dev/sda5) by symlinks
root (hd0,4)
kernel /boot/vmlinuz root=/dev/sda5
initrd /boot/initrd

That’s for an example with openSUSE on sda5 *. You would alter it to reflect your true location for openSUSE.

For more information on this method, you could read the following tutorial which was written when I had the self same problem two days ago with Ubuntu and openSUSE (just pretend in your case that Mint is Ubuntu):
HowTo Boot / Multiboot openSUSE from the Grub Bootloader in Ubuntu*

Hi swerdna,

After I posted that, I thought I was asking too much, like some feature that would be implemented five years from now!

Yes, that makes sense, as the way I have been doing it seems a bit sloppy or just a bit of a hassle.

Thanks so much for the help, and I appreciate the links!

Warm regards,