Dual Boot OpenSUSE 13.1 and Windows 7 from Two SSDs

I installed Windows 7 on one SSD and once that was working, I connected the second SSD and installed OpenSUSE 13.1 to that SSD. Both OSes are working fine, but the only way I can boot into one OS or the other is to change settings in BIOS. Can someone walk me through the process of getting a grub menu or something when I turn on the machine? I am absolutely new to OpenSUSE, so I need step-by-step instructions, and I certainly do not want to clobber my Win7 install, since it is now fairly well customized.
I did not see any prompt during the setup of OpenSUSE to “install alongside Windows” or anything, so I’m hoping there is some way I can get a bootloader option to boot to one drive and one OS or the other.

I think the best way would be to st the boot to the openSUSE disk and set a menu item to the Windows.

You should be able to do that in Yast -boot section. Just be sure that prob for other OS’s is checked and then reinstall the grub the Windows should be picked up. Note if that does not work come back since there are manual ways of doing it also

Could you break that down for me in a bit more detail? I found something in the Yast Control Center called Boot Loader - that seemed promising. It says I have GRUB2-EFI enabled. I looked into the Boot Loader options, but I’m not sure how to explicitly tell it about Windows 7 on the other drive. The ‘Probe Foreign OS’ box is checked, but it seems like I need to add a line somewhere to include Windows 7 in the list of boot options. I literally just installed OpenSUSE this afternoon, so I’m not up to speed on where everything is yet. But hopefully we are on the right path here.

no you don’t add a line you need to uncheck and check the box to make a change and accept. the system should be probed and hope fully found. You may need to turn of secure boot in the EFI for things to link up??? Afterward you can turn it back on

Note you are using UFI BIOS so things are still a little iffy with that type. You may need to edit the /boot/efi files and how to do that is above my paygrade. Someone else needs to jump in

Ok, so I unchecked and rechecked the “probe” box. The secure boot box was already unchecked. The system processes all the data and completes ok, but when I reboot, all I get are options for 13.1 and 13.1 recovery. It is not finding Win7 on the other SSD. Not sure how to proceed.

On EFI machine I’m not sure either.

From the command line as root try


show use the result

Maybe you should show us also as root

fdisk -l

note that is a lower case L not a one

Doesn’t look like os-prober shows much, but here is the output from fdisk -l:

linux-12nl:~ # os-prober
No volume groups found
linux-12nl:~ # fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes, 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0x6e90e1a7

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
/dev/sda2 206848 488394751 244093952 7 HPFS/NTFS/exFAT
WARNING: fdisk GPT support is currently new, and therefore in an experimental phase. Use at your own discretion.

Disk /dev/sdb: 120.0 GB, 120034123776 bytes, 234441648 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: gpt

Start End Size Type Name

1 2048 321535 156M EFI System primary
2 321536 17108991 8G Microsoft basic primary
3 17108992 59054079 20G Microsoft basic primary
4 59054080 234440703 83.6G Microsoft basic primary

Disk /dev/sdc: 500.1 GB, 500106780160 bytes, 976771055 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0xe32a7afb

Device Boot Start End Blocks Id System
/dev/sdc1 2048 976768064 488383008+ 7 HPFS/NTFS/exFAT

Disk /dev/sdd: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk label type: dos
Disk identifier: 0x0cabd99a

Device Boot Start End Blocks Id System
/dev/sdd1 2048 1953521663 976759808 7 HPFS/NTFS/exFAT

Disk /dev/sde: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0xe8900690

Device Boot Start End Blocks Id System
/dev/sde1 63 1953520064 976760001 7 HPFS/NTFS/exFAT

So, sda is where Win7 is and sdb is where OpenSUSE is. I have also tried to use the EasyBCD tool from the Win7 side. While I can get it to present a boot menu, I can’t get the Linux option to boot me to the sdb (OpenSUSE) partition. So I am working this from both angles. A bit surprising that this is such a difficult task…

Would it be helpful (or necessary) to try to reinstall OpenSUSE 13.1 using different install options? I essentially followed the defaults and really didn’t understand the implications of UEFI BIOS on the dual-boot process. The Win7 side is now fairly well set up and established, so I definitely don’t want to clobber that side or reinstall. But OpenSUSE is still just a clean install, so I don’t mind doing it again if it can fix the boot loader problem.

Here is the output from efibootmgr -v:

Matrix2:~ # efibootmgr -v
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0001,0002
Boot0000* opensuse      HD(1,800,4e000,05791fba-769d-487e-a662-8d79908f4ae4)File(\EFI\opensuse\grubx64.efi)
Boot0001* Hard Drive    BIOS(2,0,00)
Boot0002* CD/DVD Drive  BIOS(3,0,00)P0 DVD DC 16X8X5  

Perhaps this helps?

AFAIK EasyBCD does not work right on EFI systems

The problem seems to be that you installed thing independently on the two drives. I don’t know why OS-prober is not showing the Windows OS???

I think what I would try is to copy the files and folders from the SDA /boot/efi to the sdb /boot/efi. That would make in theory anyway Windows bootable from there maybe???

If you had installed to sda (maybe just a small /boot partition the rest on sdb) I think things would have worked. There seems to be some confusion because you made 2 boot disks.

Thanks gogalthorp…So, is it in general problematic to install Win7 and Linux to two separate hard drives?

Is there a boot/efi folder on sda, the drive where I installed Win7? If so, how do I copy those files?

I remain hopeful that there is a way to make this work…just have to find it. Like I said, I don’t mind reinstalling OpenSUSE, if necessary.

It is not a general problem but EFI adds a complication. To add to that each brand seems to have tweaked the UEFI standard differently so one machine may need a different setup from another. As I said I think the problem is that you installed to 2 drives and made them both the boot drives.

Install but mount the /boot/efi partition on the first drive only. Put the rest of Linux on the second.

So this would require a reinstallation of OpenSUSE?

I have been doing a bit more research, and exchanged some messages with another person who seems to have had a similar issue to mine.

My Asus P8P67 LE motherboard BIOS says EFI, but not UEFI. I think this may be some earlier implementation of UEFI. There are no options in the BIOS to change any EFI settings, and there is no “secure boot” option. Perhaps a more recent version of the BIOS has changed that, but since my system was so stable, I did not update the BIOS.

As far as I can tell, my Win7 installation from DVD went in MBR mode and my OpenSUSE 13.1 installation from USB flash drive went in UEFI mode. It seems to come down to the fact that neither boot process can see the other OS loader because of this difference. EasyBCD was totally unable to find OpenSUSE, and even os-prober on the SUSE side sees not Windows installation. So, it has been suggested that I reinstall OpenSUSE using MBR mode rather than EFI mode. Is this possible? Could anyone point me in the right direction of documentation to guide this process? Would it be better to install OpenSUSE from DVD rather than USB flash?

I would much rather do this than do anything that might bork my Win7 installation, since over the past several days while I have been tinkering with what’s wrong with the dual boot, I have spent countless hours setting up the Win7 side with proper settings and apps…

I managed to fix this myself by re-installing 13.1.
On the second time around, instead of creating 4 partitions (boot, root, swap, and files), it created only 3 partitions, without the boot. There was no way to choose a boot partition that did not say EFI. When it gave me the “installation summary” page, I made sure both MBR boot and “boot from / partition” were enabled. After the install process completed, I went into my Asus BIOS and selected the drive that Windows 7 is installed on to be my primary boot drive. Now, when the system starts, it gives me the grub menu and allows me to choose OpenSUSE or Win7 (yaay!). Each OS is on its own drive, yet boots properly.
Well, everything with Linux is a learning adventure…
Thanks to those who tried to help.

Having done a couple of re-installs to the same machine, I wanted to relate my experience here for others who might have similar issues. On my system, it makes a big difference if I do the OpenSUSE 13.1 install using a DVD vs. a USB stick. With the USB drive, it appears to force the use of grub-EFI (chooses this by default and warns of system incompatibilities if I try to change to Grub2). Ultimately, I cannot get the install to work properly (i.e., present the grub menu at system startup and allow to select either Win7 or OpenSUSE) using the USB drive installation process. However, by using a DVD for the install, I can select a version of the DVD drive in BIOS that does not say “EFI”; thus, when the Suse installer sets up the install configuration, it allows for Grub2, I tell it to use the MBR on the Win7 drive, and all goes well when I boot the machine (i.e., Grub2 presents both O/S’s and boots from either on their separate drives).

Maybe some with more experience with the installer and EFI can weigh in, but that is what I have found by experimentation.

This probably depends on the BIOS.

On both of my UEFI boxes (one from Dell, one from Lenovo), if I have CSM (compatibility support module) enabled and hit F12 during bootup, it allows me to select either USB in UEFI mode or USB in MBR mode.