dual boot OEM win8 with OpenSuSE 13.1, boots straight into Windows

I just got myself this Acer Aspire S3 391 laptop with a 20GB SSD and an 320GB HDD. For over a decade, I’ve only been running linux on my computer, but now that I got MS Windows 8.1 as well, I want to keep it functional on the computer, just in case I need some specific software.

I used this website as a reference, but instead of using the SSD for linux, I wanted to keep the windows recovery partition intact and installed SuSE 13.1 (from the KDE live usb stick) on the HDD. EFI boot should be on the /sda2 partition. /sda3 is the microsoft reserved partition where Grub2 should be pointed to. I expect that that would be a possible issue, not being able to start MS Windows. Instead the computer just starts the Windows login screen and doesn’t show Grub2. I already set the boot order with the HDD on top. There used to be a Windows Boot loader above that, but now it seems to be gone. Regardless, it still starts Windows. That is, if I set it to the UEFI bios. If I set it to the legacy bios, it claims that there is no boot medium and I should stick the usb-stick back in.

Do you have any advice on how to run SuSE now?

You are having UEFI problems.

I’m pretty sure that this can work, though it might take some patience.

First things first. Did you install opensuse to use UEFI, or did you switch the computer to legacy mode for the install?

As a cross check:

1: Boot your install media (the KDE live USB stick that you used);
2: Open a command prompt as root (or use “su” to become root);
3: Mount the EFI partition somewhere. If I understand, that is “/dev/sda2”. So use

mount /dev/sda2 /mnt

4: List the EFI directory from that partition

ls -l /mnt/EFI

5: Post the output, using code tags.

What I really want to know, is whether a directory “/mnt/EFI/opensuse” shows up. If that shows up, then you installed in UEFI mode, and we have to find out what went wrong with booting. If that directory does not show up, then you installed in legacy mode and will probably need to reinstall.

While I’m about it – how did you create the KDE live USB stick? (Some ways of creating it won’t handle UEFI).

Hi nrickert,

thank you for your quick response! I’m very sure that I switched to the legacy mode to install. When I bought the machine last week, this is what the salesperson told me to do in order to boot from the usb stick. I never tried to install in the uefi mode and change the boot order. Not sure if it actually allows me to change the boot order when in uefi mode though, will check right away.

I created the stick from the OpenSuSE KDE iso download on another windows computer using an application downloaded from pendrivelinux.com. This always went well so far, during the last few years where I’ve been running Linux Mint on my netbook. This one also worked fine as a live cd on my computer, is that a good indication that this stick is a proper installation medium as well? I also checked the md5sum after the download, it was correct.

Anyway, I clearly did install in the legacy mode which I shouldn’t have. I’ll try to reinstall and see whether I am able to boot from the stick in uefi mode. I’ll only proceed if I can figure out which partition should go where. Now that the partitions are already created, it seems like a big mess to me. See, so far I’ve only been running linux only on my computer so I just let the installer take over the entire disc and don’t worry about partitioning. Now I have to actually be careful not to mess with the windows stuff. Not that it contains valuable data at this point, but it feels nice to have this shiny new computer at least being able to do something ;).

I’ll give it a shot installing in uefi mode and report back!

Ok, I changed the boot order in uefi and now set the usb device on top (the windows bootloader is second, hdd is third). With the usb stick in the slot, it does actually run the stick, but it is different. For one, it doesn’t show the option to run it as a live version. I can use it to install, check the installation media and two other options I can’t recall. I tried both mentioned above and it starts with the KDE background, but then goes back to some text stuff. I can’t recall exactly, but it was something with cache and MBR not working. It would then reboot in 120 seconds.

I just checked your instructions on creating a bootable usb stick and the website doesn’t mention the pendrivelinux.com application. I’ve got a MacBook Air here from work and as the instructions for creating the stick using OSX seem slightly easier than the ones for creating it from Windows, I’ll try to recreate the stick on the Apple and see if that helps. I’ll report back, but then I’m going to sleep so I won’t respond immediately to any well appreciated feedback after that.

Follow the instruction from openSUSE. You probably destroyed the ability of the boot image to boot to EFI


Once you have a proper image on the stick you will need to tell the machine to boot the stick in EFI mode.

Never listen to sales people they as a rule know nothing.:open_mouth:

Thanks, the apple computer is busy creating the stick. That is, when I run top in the shell environment, there is a CVMCompiler very busy doing something. I hope it is working on the usb stick.

The thing is, I’m by no means a computer expert either, so I expected I could at least ask the salesperson. People often take you for a computer expert when you’re running linux, but I’m pretty much the opposite I guess. I’ve been using MS-Dos 5.0 on a 286 with DD floppy drives (3.5" and 5.25") until 2001 or so. Any machine running MS-Windows seemed to crumble under my fingers. This turned out to be more and more incompatible with what fellow students and the university were using back then, so for my purpose linux seemed the most obvious choice. Trying to take the easiest path, I went for Corel Linux what later turned into Xandros, but as they didn’t support my monitor that well, I went with SuSE 7.0 and grew until version 8 or so. I only moved to Mint as when I moved and there was too little room for my chunky desktop and large monitor, I got a netbook whose graphics card was only (slightly) supported by Ubuntu. Now that I got a new computer, I wanted to go back to SuSE again, now OpenSuSE. But still, I’m by no means an experienced user and didn’t consider myself more knowledgeable than the person selling computer hardware all day.

The apple computer is finished. Final question, how do I edit a post on this forum? I haven’t found a button for it yet. I don’t want to bother you with large successions of posts from me though. If I’ve got something to add, it would’ve been better to add it to a previous post.

There is a 10 min limit on edits.

You probably know more then that guy. LOL

In any case not sure what you are doing to create the stick are you following the instruction on the link I gave you?

Some salespeople are very knowledgeable. However, most are very good at using BS to make it seems as if they know a lot, when they really don’t.

Rely on your own knowledge, and ask questions (as you are doing in this thread) to supplement that. I think you’ll do fine.

My guess is that once you are able to boot the live USB in UEFI mode, and reinstall, things will work out. But if they don’t, then post an update here and we will try to provide further assistance.

Reporting from the apple computer here, my own computer is very busy doing updates. Yes, thanks it worked out! Everything seems to work flawlessly. This means that I could close this thread. Obviously I’m still configuring SuSE, like getting the backlight adjustment to work (it is beaming full blast now) and configuring multi-touch. As I mentioned in my first post in this thread, second paragraph, I’m using another website as a reference. It relates to Ubuntu, Mint and OpenSuSE 12.1 and applies to the 951 version of the Aspire S3 whereas i’ve got the 391, but there should still be enough I can learn from it. What do you prefer to keep this forum neat? Post my new questions in this same thread so that I don’t have to introduce what I’m working with, or create a new thread for each specific issue mentioned. I’d expect the latter, but I’m open for it if you have different ideas.

Moreover, now that the initial issue got sorted, what tags should I add to this thread to make it show up in searches on this forum and be helfull to others? I can imagine it would be something like “uefi”, “acer aspire s3”, “installation”, “Microsoft Windows”, “OpenSuSE 13.1”. Shall I add them like that?

Yeah, I suppose you’re right with relying on your own knowledge initially. If I wouldn’t have asked the salesperson, i would probably just have changed the boot order but wouldn’t have shifted from uefi to the legacy bios. Anyway, glad we got this thing sorted so quickly. Gogalthorp, I did indeed use the link you gave me. That is, it describes a way to do it in linux, but obviously at that point I didn’t have access to a working linux environment. The page you linked to got two links to make the stick in either OSX and MS Windows. As the OSX way seemed easier and I do have access to a MacBook here, I used that. It did work, luckily :), thanks for that!

SuSE is still busy, I’ll call it a day (or night). Depending on your responses to my remarks above, I’ll post further questions within the next few days in this or another thread. Thanks again!

Start a new thread for each problem, give the thread a good descriptive title so we can see the issue right away, and that way you will get help sooner from the people who understand that particular issue.

And, that makes it easier for Users looking for answers: If they see in the thread title that it is the same problem they are having, they just need to read through that thread to find their solution, or follow it if it has not yet been resolved.

Welcome aboard.

I’m glad that it worked out.

Some implementations of UEFI cause problems. But ACER seems to be okay with UEFI.

If other problems arise, start a new thread with an appropriate title.

Installation turned out to be pretty painless actually. Some issues with version 12.1 mentioned in the document I refer to are already sorted, apparently. OpenSuSE also decided to make a 3.7GB linux partition on the SDD, probably to boot quicker, similar to what MS Windows uses it for. So yeah, I’m impressed. Over the next few weeks, I’ll be configuring it to get some minor stuff working. But should I have questions about these and cannot find an answer on the forum, I’ll open new, proper thread again.

Cheers :)!