Dual boot issue

Hello All,
I’m trying to config a “dual boot” for my Dell Precision M40 laptop, thats equipped with a 80 GB HDD, 512 MB of SDRAM, nVidia video chipset with 32 MB of VRAM, and Sansung DVD-ROM / CD Burner.
I started by installing ‘Windows 2000 Professional SP3’ OS, creating:

/dev/sda1 (C:, formatted FAT32)
/dev/sda5 (D:, formatted NTFS)

,where Win2k Prof resides on ‘/dev/sda5’. After Win2k Prof. installation, I installed OpenSuSe v.11.2 on:

/dev/sda1 (/data1, location of GRUB)
/dev/sda6 (/swap)
/dev/sda7 (/root)
/dev/sda8 (/home).

As expected during the openSuSe installation Win2k Prof. ‘MBR’ was replaced with GRUB. So, using notes from the net I edited ‘/boot/grub/menu.1st’; adding script:

title Windows 2000 Professional SP4
map (hd0) (hd0)
rootnoverify (hd0,4)
chainloader +1

This is ‘/boot/grub/menu.1st’ script:

Modified by YaST2. Last modification on Mon Jun 21 07:25:35 MST 2010


Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,6)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.2
root (hd0,6)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST980815A_5LYCG35J-part7 repair=1 resume=/dev/disk/by-id/ata-ST980815A_5LYCG35J-part6 splash=silent quiet showopts vga=0x314
initrd /boot/initrd-

###Don’t change this comment - YaST2 identifier: Original name: other###
title Windows 2000 Professional SP4
map (hd0) (hd0)
map (hd0) (hd0)
rootnoverify (hd0,4)
chainloader +1

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – openSUSE 11.2
root (hd0,6)
kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-ST980815A_5LYCG35J-part7 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x314
initrd /boot/initrd-

###Don’t change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (fd0)
chainloader +1

Results of ‘# fdisk -l’ :
Device Boot: Start: End: Blocks: Id: System:
/dev/sda1 1 13 104391 83 linux (/boot)
/dev/sda2 14 9729 78043770 f W95 Ext’d (LBA)
/dev/sda5 14 1925 15358108+ 7 HPFS/NTFS
/dev/sda6 1926 2180 2048256 82 linux (swap)
/dev/sda7 2181 3710 12289693+ 83 linux (/root)
/dev/sda8 3711 9729 48347586 83 linux (/home)

This is the ‘/etc/grub.conf’ script:

setup --stage2=/boot/grub/stage2 --force-lba (hd0,1) (hd0,6)


This is the ‘/boot/grub/device.map’ script:

(fd0) /dev/fd0
(hd0) /dev/disk/by-id/ata-ST980815A_5LYCG35J


I’ve tried all sorts of combinations of script code to get GRUB to boot Win2k Prof. w/o success. OpenSuSe v.11.2 boots w/o issue, and from inside linux OS I’m able to access NTFS Win2k Prof OS partition; which resides in root directory ‘/windows/C’. The ‘/dev/sda1’ partition is currently formatted w. ‘ext3’ as a result of GNU-linux OS install, containing GRUB (root dirctory ‘/data1’).
Any help would be appreciated, Thaxs.

fdisk -l ( that i lower case L)

Where is the boot flag set?

You seem to have lots of issues here, none the least being trying to run Windows from the fifth partition. Normally, it should be 0 through 3 and use a primary partition. Further, anytime I am trying to use a dual boot system, I use a generic MBR and place grub in the openSUSE partition, which I also suggest being in 0-3. You can have a logical partition and drives within for your 4 or more partitions, but keep Windows (FAT32 or NTFS) , SWAP and openSUSE (EXT 3 or EXT4) as the first three then the fourth can be logical with as many partitions as you have space.

So, what do I suggest right now? Abandon your setup and reload Windows as the first primary partition, zapping everything else. Make SWAP and then openSUSE the next two Primary partitions. Load GRUB in the openSUSE partition and use generic MBR. Set the openSUSE partition as the active booting partition. Create a fourth logical partition for any added partitions that you want to create.

Thank You,

These two lines need to be taken out:

map (hd0) (hd0)
map (hd0) (hd0)

so you end up with this:

###Don’t change this comment - YaST2 identifier: Original name: other###
title Windows 2000 Professional SP4
rootnoverify (hd0,4)
chainloader +1

Thanks for the assistance,

I followed jdmcdaniel3 advice, concerning logical partitions sda1 → sda4, where I:

1.) scrapped the current installation

2.) installed Win2k Prof. OS on ‘/dev/sda1’

3.) install openSuSe v11.2 on:
a.) /dev/sda2 (/root)
b.) /dev/sda3 (/swap)
c.) /dev/sda4 (/home)
respectively. We placed GRUB in ‘/root’ , using a generic MBR. openSuSe v11.2 installer identified the windows OS partition and provided automatic inclusion of Win2k OS into GRUB boot loader menu. Now, all is well, no hands on editting of ‘/grub/menu.1st’ needed’.

elloydaz I am very happy to hear you got your setup working just fine. This setup works very well when you are doing a dual boot setup. If you wanted an additional version of Linux, the second copy would need to go into the logical drive (and have more than one logical drive within) and I would attempt to use the openSUSE grub for all Linux versions that did not require grub version 2.

By using a standard MBR (generic), most Windows systems work just fine. By placing grub into the openSUSE partition, it is now possible to just mark the Windows partition as active and boot directly into Windows if something should happen to openSUSE or its loaded grub. I would suggested building a boot disk with gparted installed on it that can be booted like a live CD and would allow you to change the active partition when required.

Thank You,