Dual Boot: Installed GRUB in root, but why do i see GRUB on startup??

Hi all,
I’m returning back to openSUSE after long time…about 2 years.
Earlier also i’d had problems with the bootloader, and so i went on to try out other distributions. I tried out Archlinux, and liked it a lot, but kde on Arch wasn’t as good an experience as gnome.
So now I’m back, to try out openSUSE’s very nice KDE.

Here’s my setup:
Windows 7 already installed:
C: /dev/sda1,
D: /dev/sda2
/dev/sda3 is the third primary partition, and has the following partitions under it:
/dev/sda6 (swap)
Free Space of 150 GB (under /dev/sda3)

What i wanted to do:
Resize free space, install openSUSE with GRUB in its root, and use easybcd for windows 7 to add an openSUSE entry to the windows boot menu. I assume it adds a GRUB stage 1 entry. This is how i’ve been booting ubuntu and archlinux so far.

Here’s what i did:
Formatted the free space to ntfs, resized to 100 GB.
Planned to use remaining 50 for openSUSE. Everything went fine, until bootloader install. Opensuse asked me to install GRUB to /dev/sda3, which i assume is correct as it won’t touch Windows 7 bootloader.
But when i start up my comp, it displays the openSUSE boot menu first, and then i can choose to go to windows boot menu.
Does this mean my MBR has been overwritten??

Please suggest some ways out of this!I don’t want to turn back from openSUSE again…

Oh and i forgot to mention, the dev/sda4,5,6 belong to Ubuntu.

So when you boot up, do you see something like this:


But when you select windhoes, what exactly do you get?

Not sure what you did. Things do not add up since you can only have 4 primary partitions on a disk.

post output of

fdisk -l

We could do with that
(I kind of assumed it would mean it was an extended)

We may also need

cat /boot/grub/menu.lst

when i select windows, i get the typical windows boot menu(sorry i can’t see the picture you posted), with the following:

Choose an operating system to start, or press TAB to select a tool:
(Use arrow keys to highlight your choice and press enter)

Microsoft Windows 7

So i guess this is the typical boot screen of Windows 7.

And a quick error correction:

/dev/sda3 is an extended partition. Sorry about the error.
Im in office so don’t have the personal comp, but i remember the boot options from openSUSE correctly:

OpenSUSE (i remember the kernel image was in /dev/sda9)
Other Linux on /dev/sda5
Windows 1
Windows 2

I’ll post the whole menu once i get home in about 3 hours.

But if you then choose Windows 7 from that menu - What happens?

Well, then windows 7 boots up!

But that is if i choose Windows 1, i haven’t checked what happens if i choose Windows 2.

It sounds fine to me
Windows 2 will probably be a recovery partition or something.

It seems all is well with your system.
Suse is taking you to what sounds like easybcd on the windows boot sector and I guess you can boot ubuntu from there too?

So this means that Windows bootloader is intact. My question is, if the windows bootloader is still in MBR, then shouldn’t the windows boot menu be displayed first upon boot? Why is the Suse menu being displayed on boot?
For example, for ubuntu, GRUB is in root partition. When i boot, the windows boot menu shows up, i select Ubuntu, and then it goes to the Ubuntu Boot Menu, where i see the ubuntu options, plus the windows chainloader.

In other words, why is it:
Boot -> Suse Boot Menu
Suse Boot Menu -> Windows Boot Menu

I’d like it to be like this:
Boot -> windows Boot Menu
Windows Boot Menu -> Suse Boot Menu

Because I bet you any money suse has put the active boot flag* on the extended partition

when you do fdisk -l

the partition with a * will be sda3

Yes windows mbr is intact :slight_smile:

I would leave it as it is.

Hmm…Thats pretty sneaky of Suse…
But Thanks!! :slight_smile:

And I’d also like to say, THIS IS THE BEST LINUX COMMUNITY FORUM I’VE EVER been on…fastest responses ever…

We do our best
If you lived in the UK you could buy me a beer, if I was a beer drinker, but I’m not, so a virtual pat on the back is fine;)

One final doubt. If i have to remove openSuse to reinstall/upgrade etc, will i have to change the active boot partition myself?

This is a non-specific question *reinstall/upgrade *-

  1. If reinstall suse. It remains the same
  2. If upgrade suse. It remains the same
  3. If reinstall widows - It will move the flag back to winders (you might find it complicated to everything back) Because winders only want you to use winders.

the list could go on according to different permutations…

Ok, I’ll make it more specific, if i remove Suse, then ?

If you remove SUSE would that be as in remove and not put anything in it’s place that could currently do the same thing as suse is currently. If yes, then you would need to do something or you’ll not be able to boot.

Perhaps if you are that concerned about it, you might want to switch the flag back to the winders partition. But to advise which that is for sure I would need to see

fdisk -l


cat /boot/grub/menu.lst

and if possible I would double check which partition has BOOTMGR on it

This would put you back to using EasyBCD

I thought of a solution on my way back. I checked that /dev/sda3 was flagged ‘bootable’.
So i used gparted live to change the boot flag, and set /dev/sda1 as bootable.
Then i installed openSUSE without any bootloader, and then used the live cd to install GRUB to /dev/sda9.
Then i added an entry in windows boot menu via easy bcd.

Now it’s working perfectly!!
Here’s the fdisk:

Device Boot Start End Blocks Id System
/dev/sda1 * 1 7650 61440000 7 HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2 7650 12749 40960000 7 HPFS/NTFS
/dev/sda3 12750 38913 210162330 5 Extended
Partition 3 does not end on cylinder boundary.
/dev/sda5 12750 14572 14643216 83 Linux
/dev/sda6 14573 14815 1951866 82 Linux swap / Solaris
/dev/sda7 14816 19678 39062016 83 Linux
/dev/sda8 19679 32426 102398278+ 7 HPFS/NTFS
/dev/sda9 32427 35021 20844306 83 Linux
/dev/sda10 35022 38913 31262458+ 83 Linux

Thanks for pointing me to the correct direction! This wouldn’t have been possible without your help! And i got to learn a thing or two today!:slight_smile: