DSL settings and failed to open media error


I have only recently started using Linux as I need that for controlling a Texas DaVinci processor (DM6446), but I soon found out that I know absolutely NOTHING about Linux, and even less about NFS servers, etc! My host computer is a virtual machine (VMWare workstation) using a freshly installed OpenSUSE 10.3, although I tried with OpenSUSE 11.1 as well but I never got anyhting right. The 10.3 did however produce fewer error messages than the 11.1 when is came to NFS settings, etc., but neither of these got me anywhere near where I want to be…

My problem is that I can’t seem to install a DSL connection, which I think I need to update drivers and install “modules” like the NFS-server, etc. I have tried with the YaST Network Card and DSL installations settings, but I don’t know if everything is set up correctly. The internet connection takes place over an ethernet network (all the other computers are using Windows XP), and I don’t know anything about DNS servers, etc. Where can I find a good guideline on how to set up this connection? I have used the following setup from this forum for the Network card settings: Setting Up Internet Connection - openSUSE Forums. How do I know if the modem / hub supports DHCP and how should I then set up the system? If I set the IP addresses to static, then I can ping the VM from the Windows and all the other computers from the VM Linux, so the hardware side of the network is working. But I still cannot enable / install a new internet connection.

The other problem I have is that I have tried installing other “modules” from Software Management such as Yast2 NFS server, etc., but everytime the system spits out the following error:
In SUSE 10.3: "Insert ‘CD 1’ and in SUSE 11.1 it said something like Cannot access media (Medium 1), but clearly this is the same error message. The detail is something like “Failed to mount cd:///?devices=/dev/sr0…” Is there a problem with the repositories? The DVD that is in the drive is the same one that I just used to install OpenSUSE from. I have tried with fresh installations of both OpenSUSE 10.3 and 11.1, but am now close to giving up hope…

Can someone please help me?

Thanks in advance


If you can ping by ipaddress, the network card is working. You need to go to Yast>network and add a gateway and dns server address.
Once the network is running, you can get around the mount failure by adding the relevant http address for your version. (Browse Index of /distribution to get the correct version). It will now find the installation sources and you can remove the local cd source.

Thanks for the reply. Please excuse me, as I didn’t exaggerate when I said I know nothing about Linux!

I did the following now:

Using my main PC (winXP and IP address and not the one that the VM is installed on, I obtained the following data from typing ipconfig/all in command prompt.

Windows IP Configurations
(I don’t think this is the important part so Im not going to copy it)

Ethernet adapter Local Area Connection

Connection specific DNS Suffix:
DHCP enabled : No
IP Address:
Subnet Mask:
Default Gateway: (nothing)

PPP adapter InfoDoor

DHCP enabled: No
IP Address:
subnet mast:
Default Gateway:
DNS servers: and
NetBios over tcpip: disabled

The IP address of the WinXP PC on which VMWare is installed is and the Virtual machine’s IP address is

Under the Network Card settings, I entered the 2 DNS server addresses under the “Name Servers and domain search list” and then under Name Server 1, Name server 2, etc? What do I write in the domain search box?

Should I use the gateway address under the PPP adapter info (eg. , or can I simply use the IP address of another computer on the network eg.

How do I test whether it is working?

OK from the xp settings, the dns you have entered is correct.
Use the gateway address you got from winXP’s ipconfig /all - it is valid for everyone on the network.
(The settings from:

PPP adapter InfoDoor

DHCP enabled: No
IP Address:
subnet mast:
Default Gateway:
Are the settings your DSL connection uses.
the ipaddress 196.209. … is the public network on your isp and is a different network to the private range 192.168. …
The gateway address is some address on the 192.168.0.? range.)

The domain search box means it will treat whatever you entered as the local domain (like localnet or whatever you called your network when you installed suse). It’s not that critical at the moment.
As an aside, network basics are the same for all operating systems. Either install the suse how-to’s or look at tldp and you should find some basic tcpip how-to’s which explain the principles. Although some are old and basic, they are still valid and help with a background.

I did not manage to set up the system from the advice given here (although it did point me in the right direction so thanks a lot!). The biggest problem was that the router/modem wasn’t installed properly, so even though all the Windows computers were able to connect to the internet, I couldn’t use any of the automatic IP address features, etc. I finally came right when I reset the modem/router (a Telkom Mega 105WR) and was able to install it properly on one of the WinXP computers. This then enabled me to use DHCP and automatic IP addresses were assigned, making the network a lot simpler. I installed a fresh SUSE 10.3, enabled the network and online repositories and … Voila! But thanks for the assistance in any case!

Glad you got it working.
Generally, most common questions have been answered here and a bit of searching helps.
The great part about the forum is that the most common setup problems have a how-to.