DSL connection problem with Open Suse 12.1 KDE

Hello everybody! First post here and already need some help… I’ve been using Linux Mint for the last couple of years, but now decided to give Open Suse a try. Just installed it from the live KDE CD, everything looks very well and like it a lot so far. But I don’t know how to setup my network connection. I am using a wired DSL connection with username and password. Tried to setup a connection from the YAST menu but nothing happene. Also - there is now network icon on the taskbar so I have no idea what the status of the connection is, or how to choose to connect to it.

In Mint, I was using the “pppoeconf” command from the terminal to setup my connection. Tried it here, but it tells me that there is no such a command :slight_smile: As you can see - I’m not that good at understanding what’s going on under the hood in the Linux systems… But I can type commands and give you the output of them if needed or change a text in a file somewhere in the system.
Any help will be really appreciated, since I quite like the look and feel of Open SUSE and would like to stay longer with it :slight_smile: Thanks!

Welcome here, new poster.

First thing you have to do is to decide if you use a traditional network setup (called “with ifup”) or a network manager setup.
The first is for systems that are rather static and connect allways to the same network (computer room systems, desktops). The second is for “travel around” systems where you often connect to different network, manaqing this from the desktop as an end-user (laptops, but not if ypu use your laptop allwaya inside your home on your personal router).

Also, when you say “Tried to setup a connection from the YAST menu but nothing happene”, that is not anything where we can help you. I doubt if you mean with “nothing happens” that not even the main YaST window opens. You have to tell much more if you want us to understand what you do.

Hi hcvv and thanks for the reply :slight_smile:

On the first point - I think I’ll have to use a traditional network setup, since this is a desktop only connecting to one network.
On the second point - in YAST, under networking, I tried to setup a new DSL connection. Entered the name of the provider, my username and password. The system saved the settings and that was all. As I said - I don’t have a network manager icon in the taskbar and don’t know hot to try to connect to the newly created DSL connection. Under “nothing happens” I wanted to say that when I finished with the new connection there was no internet and I didn’t knew how to try to activate this connection :slight_smile: Sorry for the poor explanation…

Thanks for the explanation.

While using the command line it is very easy to post all and everything here, but with a GUI we depend on you telling everything (or making screenshots).

I tried to follow what you did. I started YaST > Network devices > DSL. I hope that you did the same (your explanation is still very consise). Then YaST tried to find DSL devices. Nothing at my system, thus I can not go any further. Did it find something on your system?

I am not that good at direct DSL connections (connect through a router to DSL), In any case, by using traditional with ifup, the idea is that that is started on boot (and of course immediatly after configuration). Thus the end-user, loged in or not, has nothing to do/manage with the connection. Thus (s)he does not need anything. And not using network manager, (s)he also does not get a (needless) icon.

I hope that some DSL users tune in soon. But it can take some time, those at the other side of the globe will still be at sleep :wink:

That’s exactly what I did. Then I clicked on “Add” at the bottom and added a new dsl connection with the name of the provider, my username and password. After I entered this data - there was an entry on the other screen - “Providers” with the name of the provider that I entered. Now if I try to delete it, it says that I can’t because it’s in use.
I will try searching in internet for a command in terminal similar to debian’s “pppoeconf” and try from the terminal.

Though, I too hope that the DSL gurus tune in :slight_smile:

Now you say that you have no connection, but we are strict non-believers and thus allways want computer evidence of this.

Can you please post the output of

/sbin/ifconfig -a

And, while you are new here, please allways post computer text (prompt,command and output inclusing the next prompt) by copy/paste from the terminal emulator in the post between CODE tags. And here is a howto: http://forums.opensuse.org/english/information-new-users/advanced-how-faq-read-only/451526-posting-code-tags-guide.html

/sbin/ifconfig -a

eth0      Link encap:Ethernet  HWaddr 00:0A:48:0C:47:99  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:20 Base address:0xc000 

eth1      Link encap:Ethernet  HWaddr 4C:00:10:50:63:8F  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:23 Base address:0xc000 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:76 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:4040 (3.9 Kb)  TX bytes:4040 (3.9 Kb)

I’m a little hesitant jumping in here but,

On your DSL modem… There are usually three lights. Power, DSL and Internet. Are all three on and not flashing?

If so, simply set your gateway to the address of your router.

You can use your browser (Firefox, or Konqueror or any other you like, and go to (usually) The documentation that came with your router will tell you the address. Log in and you can change whatever you need to.

Then simply change your gateway address to match your router, and away you go.

At least that’s all I do.

Well, unfortunately, there is no manual or any document with the DSL modem and I can’t open in the browser…

You could try

Those are the only two I have even seen. Is your modem/router provided by your ISP? Do you have the option of calling your DSL provider? I know they’ll sometimes insist that they don’t provide support for Linux, but they should tell you what the address of the router is.

You know, I am assuming you have a router/modem, not just a modem. Am I correct? If I’m not, you’ll have to use the procedure you had started with. And, I’m not familiar with it and am over my head. I’ll leave you to Henk who is very capable.

Hm, aren’t you two talking different things? I may be wrong, but my impression is that montana_suse_user is discusing a seperate router/gateway/DSL-modem, that is connected to the system via ethernet (a LAN). Many have that situation. But, again as I understood it, bookeh has a DSL device internal to his his system, and thus connects directly to the telephone line. No LAN involved.

When that is correct, it is no use to try to connect to the DSL device over the LAN (with often used addresses like those in the 192.168… range). The more while bookeh posted his ifconfig -a output which shows that there is no device with any IP adddress (though eth0 is UP, but without any address).

That is why I said I hope somebody having experience with such an internal DSL card will jump in.

I now believe that you have made the correct assumption and I had not. I saw that there was no ip address but thought that perhaps his router, which can usually act as a DHCP server had been not configured to do so.

I’m going on quite limited experience, and seem to have made a common newby error by jumping to a conclusion without all facts. I thought I might be able to help, but alas, I cannot. Now I’ll be quiet and let someone who knows something step up and help.

Never mind. Your willingness to help is appreciated. And now we both wait for a guru on this subject now :wink: