Dropping to grub console


I had a system with window 7 and opensuse 12.2. I installed windows 8 on it and laptop went straight to windows when it booted. I followed the instructions on SDB:Repair MBR after Windows install - openSUSE. Now when it boots, it drops me straight to the Grub Minimal Bash-like console. I tried

find /boot/grub/stage2

and got hd0,2 so,

root (hd0,2)
setup (hd0,2)

messages look right, but when I reboot, I get the console again.

I could just reinstall opensuse again, but I want to avoid that if possible.


Follow this

The guide you quoted deals with an older version of grub
As you are using 12.2 it uses grub2 by default (unless you know you changed that in the install or your 12.2 install is a ‘dup’ from 12.1?)

If you install Windows 7 or 8 after you have installed openSUSE, this will result in a system that only boots into Windows if both Windows and openSUSE are using the same hard drive. You will need to look at this guide to reinstall Grub 2, the default boot loader in openSUSE 12.2:

Re-install Grub2 from DVD Rescue: https://forums.opensuse.org/content/128-re-install-grub2-dvd-rescue.html

You can also reinstall openSUSE, but by default, openSUSE will not reuse its old partitions. You would need to do a manual partition setup to reuse your existing setup. If you should get openSUSE working again, have a look at my Grub 2 bash script you can find here:

GNU Grub2 Command Help/Config Editor - Version: 1.90: https://forums.opensuse.org/blogs/jdmcdaniel3/gnu-grub2-command-listing-helper-help-input-106/

Thank You,

Thanks for the replies. What makes things more complicated is that I am using encrypted LVM. So currently I have /dev/sda1, windows boot, /dev/sda2, windows, /dev/sda3, /boot, and /dev/sda4, LVM.

I ran the installation and after I entered the passphrase I dropped to the console with ctrl+alt+f2. Then, I did

$ mount /dev/mapper/system-root /mnt
$ mount --bind /dev /mnt/dev
$ chroot /mnt

Then I did

grub2-install /dev/sda

but I’ve got

Path `/boot/grub2` is not readable by GRUB on boot. Installation is impossible. Aborting.

Please let me know what I did wrong. Thanks!

Actually I figured it out! I will write how I did this soon - I just wanted to let you know ASAP that this is solved (so you don’t waste time replying). Thanks for your help!!


Basically I’ve got some tips from [ubuntu] Restore grub2 with encryption? - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1309205)

What I did was:

  • Boot with live cd, select installation
  • After agreeing EULA, it will ask you for the passphrase to unlock the encrypted LVM
  • After unlock, ctrl+alt+f2 to drop to a console

$ su
$ lvscan

  ACTIVE            '/dev/system/home' [119.13 GiB] inherit
  ACTIVE            '/dev/system/root' [20.00 GiB] inherit
  ACTIVE            '/dev/system/swap' [2.00 GiB] inherit

$ mount /dev/system/root /mnt
$ mount /dev/sda3 /mnt/boot
$ mount --bind /dev /mnt/dev

I don’t know the following is needed, but I did it anyway,

$ mount --bind /proc /mnt/proc
$ cp /etc/resolv.conf /mnt/etc/resolv.conf


$ chroot /mnt
$ grub2-install /dev/sda

And also, thank you jdmcdaniel3 for GNU Grub2 Command Help/Config Editor!


Happy to hear of your success. Thanks for the detailed information on how you fixed the issue. You are also welcome for the bash script grub2cmd.

Thank You,