dropdown field sometimes does not open with touch

This one is weird. Sometimes, when using the touch screen, I cannot open dropdown fields… the latter looks like it is focused (the background slightly changes to a lighter color) but the dropdown does open the options… Sometimes it works, sometimes not.
It is quite annoying.
Anyone has a fix for that?

KDE? GNOME? Xfce? LXDE? LXQt? Enlightenment? Cinnamon? MATE? Pantheon? IceWM?

What CPU and GPU? (inxi -GCaz --zv)

Gnome (the default chosen on installation; so wayland. I don’t have an option to switch to xorg btw unlike on fedora)
Intel Core i5-8550U
Full Specs:

I have tried Gnome on xorg and it does not seem to have the issue but gnome on xorg has its own issues:

  • black screen for 3-5 seconds upon screen rotation
  • tearing on vertical scrolling or video playback involving a vertical motion
  • got a freezing needing a force shutdown… on the next restart, had some weird issues the UI not responsive and taskbar missing icons. Had to do a restart
  • unable to drag window by touch and move window title.

lol so far my opensuse experience has not been smooth at all… was expecting a solid stable experience similar if not better than macOS or windows.

My observation is openSUSE investment in Wayland lags Fedora and some others, but it’s as good as good gets using Xorg, at least with DEs other than Gnome. My primary PC remains KDE3, with it, TDE and Plasma additionally on my other 40+ multiboot PCs, including an iMac. If you’re not committed to Gnome, try Plasma on Xorg. Wayland still has a lot of shortcomings, particularly with NVidia. Here’s another good Wayland description what it can’t do.

You don’t need to reinstall if you wish to try Plasma. It can be added, and you can switch between them at the login greeter (no need to reboot). Same is possible with Xfce, LXDE, LXQt, Enlightenment, Cinnamon, MATE, Pantheon, & IceWM, the last of which you probably already have installed as a super lightweight fallback.

thx for your reply… the only reason I tried gnome and a distro supporting a native gnome was because tablet/touch experience is not great on windows and I kept reading people say gnome on touch screen is awesome.
lol what a joke.

oh my that’s the downside of using a less popular linux distro or even less popular OS.
Will try my luck with ubuntu but I have the feeling I will end up using windows; a part from customizations possibilities, windows is so much superior in every other aspects; you can even have linux subsystem and android subsystem on windows nowadays…

the more I use opensuse/linux/gnome the more bugs I find…these are not tiny bugs but bugs needing a complete force shutdown by holding the power button.

  1. Two times, I got stuck in overview tasks views and I can’t leave it…touching a window does not maximise and it just stay there and I can’t open any new app nor close existing app… force shutdown needed.
  2. Black screen and UI freezing (happened like 5-6 times on wayland and xorg also)… only mouse pointer seems to be visible but cannot do anything, again force shutdown needed.
    The fun part is after sometimes re powering the device on, it some how saved the previous state I was in and restores it… so sometimes I am stuck in the small bug after re powering the device… need another force shutdown…

I had installed and tried Fedora before opensuse and had similar issues… so I guess it’s probably gnome 42 the issue?