Dropbox on openSUSE 12.1 64bit

Are there any problems known installing the Dropbox client on openSUSE 12.1? When running the install I get the following:

linux-t7ar:/home/hendry/Downloads/nautilus-dropbox-0.7.0 # ./configure; make; make install;
configure: loading site script /usr/share/site/x86_64-unknown-linux-gnu
checking for a BSD-compatible install… /usr/bin/install -c
checking whether build environment is sane… yes
checking for a thread-safe mkdir -p… /bin/mkdir -p
checking for gawk… gawk
checking whether make sets $(MAKE)… yes
checking for gcc… gcc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ISO C89… none needed
checking for style of include used by make… GNU
checking dependency style of gcc… gcc3
checking build system type… x86_64-unknown-linux-gnu
checking host system type… x86_64-unknown-linux-gnu
checking for a sed that does not truncate output… /usr/bin/sed
checking for grep that handles long lines and -e… /usr/bin/grep
checking for egrep… /usr/bin/grep -E
checking for fgrep… /usr/bin/grep -F
checking for ld used by gcc… /usr/x86_64-suse-linux/bin/ld
checking if the linker (/usr/x86_64-suse-linux/bin/ld) is GNU ld… yes
checking for BSD- or MS-compatible name lister (nm)… /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface… BSD nm
checking whether ln -s works… yes
checking the maximum length of command line arguments… 1572864
checking whether the shell understands some XSI constructs… yes
checking whether the shell understands “+=”… yes
checking for /usr/x86_64-suse-linux/bin/ld option to reload object files… -r
checking for objdump… objdump
checking how to recognize dependent libraries… pass_all
checking for ar… ar
checking for strip… strip
checking for ranlib… ranlib
checking command to parse /usr/bin/nm -B output from gcc object… ok
checking how to run the C preprocessor… gcc -E
checking for ANSI C header files… yes
checking for sys/types.h… yes
checking for sys/stat.h… yes
checking for stdlib.h… yes
checking for string.h… yes
checking for memory.h… yes
checking for strings.h… yes
checking for inttypes.h… yes
checking for stdint.h… yes
checking for unistd.h… yes
checking for dlfcn.h… yes
checking for objdir… .libs
checking if gcc supports -fno-rtti -fno-exceptions… no
checking for gcc option to produce PIC… -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works… yes
checking if gcc static flag -static works… no
checking if gcc supports -c -o file.o… yes
checking if gcc supports -c -o file.o… (cached) yes
checking whether the gcc linker (/usr/x86_64-suse-linux/bin/ld -m elf_x86_64) supports shared libraries… yes
checking whether -lc should be explicitly linked in… no
checking dynamic linker characteristics… GNU/Linux ld.so
checking how to hardcode library paths into programs… immediate
checking whether stripping libraries is possible… yes
checking if libtool supports shared libraries… yes
checking whether to build shared libraries… yes
checking whether to build static libraries… yes
checking for pkg-config… yes
checking for pkg-config… /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0… yes
checking for NAUTILUS… configure: error: Package requirements (libnautilus-extension >= 2.16.0) were not met:

No package ‘libnautilus-extension’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NAUTILUS_CFLAGS
and NAUTILUS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Any ideas how to fix this? I installed the 32 bit component, but no go. I cannot find the package mentioned

Am 19.11.2011 21:06, schrieb hscholing:
> checking for NAUTILUS… configure: error: Package requirements
>> (libnautilus-extension >= 2.16.0) were not met:
There is a package on the obs for 12.1
No idea if it will help you (never used dropbox or tried to compile it)

PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

It works fine installed from

If you use kde you need this as well

That link didn’t work for me, YAST hung on downloading the repo metadata. I installed the repo from the command line using the link URL though, and that worked as advertised.

Could you update the useful page at openSUSE Forums - How to Install Dropbox (Gnome) ? This is one I always search for with a new install to get the URLs right!

Thank you all for the reply. I used the link mentioned above and now it works :slight_smile:

Work for me (dropbox-0.6). Not lasted version.

It worked for me! GNOME, Suse 12.1

Thank you so much!

I downloaded the 64bit package, and used: sudo zypper in nautilus-dropbox-1.4.0-1.fedora.x86_64.rpm


Problem: nothing provides nautilus-extensions >= 2.16.0 needed by nautilus-dropbox-1.4.0-1.fc10.x86_64
 Solution 1: do not install nautilus-dropbox-1.4.0-1.fc10.x86_64
 Solution 2: break nautilus-dropbox by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/c] (c): 2

I chose 2, and the installation finished ok. Dropbox is working fine.

I’m using openSUSE 12.1.