Dropbox doesn't autostart

OpenSUSE Leap 42.3
KDE Plasma 5.8.7

I installed Dropbox using instructions for headless servers (https://www.dropbox.com/install-linux). I started the Dropbox daemon the first time from the command line as the instructions says. I linked my account in a browser and Dropbox started synching. I setup autostart in Configure Desktop/Startup and Shutdown/Autostart by adding the Dropbox daemon dropboxd as a script file that should start at startup.

When I reboot Dropbox doesn’t start. I can start it by using the command

dropbox.py start

. I then change the command to autostart in Configure Desktop/Startup and Shutdown/Autostart to dropbox.py start (with full path to the script), dropbox will still not autostart when rebooting.

Is there no way to make Dropbox autostart? I know this has worked at some point in time.

Did you simply install the Fedora .rpm or, did you rebuild the Dropbox binaries from source?

Yes, the Fedora ‘dropbox’ executable which the .rpm drops into ‘/user/bin/’ is a Python script but, it’s named ‘dropbox’ and therefore, assuming that the user’s path includes ‘usr/bin’ simply calling ‘dropbox start’ should start the thing.

And, exactly so if from the KDE “System Settings” “Autostart” module the above command and parameter is added to the KDE session’s auto-start: <https://docs.kde.org/stable5/en/kde-workspace/kcontrol/autostart/index.html>.

you should have saved yourself a headache and just installed dropbox from the OSS repo.
Auto starts no problem for me in 42.3 - no extra config necessary

Yes, of course – use the openSUSE repositories . . . <https://software.opensuse.org/package/dropbox&gt;.
Or, simply search in YaST “install software” . . .

I’ve tried installing and using Dropbox from the openSUSE repositories but there is no difference, Dropbox behaves the same way.

I’ve noticed that Dropbox will start using “dropbox.py start” if I wait a while after reboot. I know this sounds weird. That is probably the reason for Dropbox not autostarting. It seems Dropbox cannot start until some time after booting.

The machine is a laptop so it could be related to network but then Dropbox would start whenever the network was up but that’s not the case either. If I try to start Dropbox immediately after logging in it won’t start but if I wait like say 5-10 minutes it will start.

Are you absolutely sure that you deleted and/or removed all of the files you installed from the Dropbox site before you installed from the openSUSE repositories?

May I suggest that, you

  1. remove the openSUSE package, either via YaST software management or with Zypper;
  2. remove any remaining files installed by the Dropbox installation method;
  3. re-install the openSUSE package.