drop into grub shell after password prompt


I have a problem which I can’t get my head around. I installed Tumbleweed with LVM and LUKS enabled and I could login and do stuff, but reinstalled it soon after (because reasons).
After the reinstallation, the grub password prompt throws me into the grub shell. And I have no idea what changed. It is a brand new laptop, the only thing done to it earlier was exactly the same installation.

After some tinkering (complete format or shred of the disk) it still persists. I installed Tumbleweed without LVM or LUKS and I can use it. But I need a LVM+LUKS installation.

How would I best troubleshoot this?

After a “complete format or shred of the disk” there probably isn’t anything there to troubleshoot, except for a small amount of grub code that is unable to find a system to boot.

You probably need to reinstall.

Thats what I thought at first, and did and it still it always the same issue.

I thought maybe some efi stuff was changed which I prevents this config. But I am unsure how a regular LVM+LUKS full encrypt install should look like (in terms of efi and grub config)
I am tempted to wipe my other laptop to test this…


maybe, what got me wondering was the prefix=(hd0,gpt1)/boot/grub2 but i couldn’t find it with ls in the grub shell

If this is a UEFI system, then that small bit of grub is likely to be “/EFI/opensuse/grub.efi” in the EFI system partition.

It’s hard to know what went wrong for the reinstall, because you have not described what you did.

True, and I will try to remedy this hereby.

First installation:

Disk > Guided Setup
[activated] LVM
[activated] LUKS
[activated] btrfs
[off] seperate home partition
[activated] swap
[activated] swap resize to memsize

later installations

Disk > Guided Setup
[activated] LVM
[activated] LUKS
[activated] btrfs
[off] seperate home partition
[activated] swap
[activated] swap resize to memsize
overview screen:
[enabled] secure boot
[enabled] trusted boot

If I reinstall always the same issue, after the grub password prompt it throws me into the grub shell. not even the rescue shell mind you.
the only way to get it working is installling it without LUKS+LVM (will test only one activated)

This implies that grub cannot find /boot/grub2/grub.cfg. Do you have any error decrypting your volume?

the only way to get it working is installling it without LUKS+LVM

Are you using LUKS2 by any chance?

It does not show any error, how can I output an errorlog?

Good question, I only click on that what the TUMBLEWEED installer offers here :wink:

also, it is just LUKS, no issue arose with LVM alone

As I explored the installation infos inside the Disk > Expert mode I stumbled upon this:
Encrypted: yes (Regular LUKS1)

It was for the /dev/nvme0n1p2 partition, the p1 is efi boot and the p2 is the encrypted rest

Ok I found the issue.

man this is stupid, so please laugh. Because it is funny in hindsight!

I have a german keyboard layout laptop, and of course on boot is uses such.
But on the installation process I chose a american one (imho better to code), and the password, of course, contains a y, or z depending in the layout.
So typing in the LUKS password, it used the US layout y and on boot, its the german layout and I type a z instead…
The error message disappeared so quickly (was doing stuff on the side so I didn’t notice it) and it threw me into the grub shell.
And of course, on my first install attempt I chose the german layout there is the US variant, which I usually use, but wasn’t available via the installer so I just kept it… And this worked obviously

So I, enjoyed death by keyboard layout :smiley:

You can close this now, thanks for everyone trying to help!