Driver update lost second display

Hi
Running opensuse 13.2 with nvidia geforce GTX 570 HD.
I have two monitors connected to the vide card and have been operasting the same environment for a few years.
I used 13.1 from last november and ran an update to 13.2 about 3 weeks ago.
The update to 13.2 went fine and retained my montor settings and configuration, and iused the oneclick install to add nvidia drivers, all OK.
system running and settled for those 3 weeks.
Yesterday I accepted a software update that I noticed included nvidia g03 and thought nothing of it, this has updated seamlessly over the past year.
Now on starting the second display does nothing. The Kinfocentre xserver shows only one display.
If I boot to windows 7 both displays work.
If I boot to linux advanced and select earlier version all my settings return.
Anyone help out please?
I have run suse since version 10 and used to set up displays and xserver, but things have moved about and I may make things worse, I do not know if previous help posts still relate.
Thanks for all replies.

This sounds like the kernel module is only installed for the earlier kernel, so the nvidia driver does not work at all with the newer one.

Please post the output of:

rpm -qa | egrep "nvidia|kernel"

And please also post /var/log/Xorg.0.log when booted to the standard 13.2 kernel, to see whether this is really the problem.

Hi, thanks for the reply.
another update for some kernel bits was applied thia AM and made no difference.
here are the requested data.

rpm -qa | egrep “nvidia|kernel”
kernel-devel-3.11.10-17.2.noarch
kernel-desktop-devel-3.16.7-7.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-331.89_k3.11.6_4-28.1.x86_64
kernel-devel-3.11.10-21.1.noarch
nvidia-uvm-gfxG03-kmp-default-340.32_k3.11.6_4-31.1.x86_64
nvidia-uvm-gfxG03-kmp-default-331.79_k3.11.6_4-27.1.x86_64
kernel-devel-3.16.6-2.1.noarch
nvidia-gfxG03-kmp-desktop-331.79_k3.11.6_4-27.1.x86_64
kernel-desktop-3.16.7-7.1.x86_64
nvidia-uvm-gfxG03-kmp-default-340.58_k3.11.6_4-31.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.46_k3.11.6_4-30.1.x86_64
kernel-desktop-devel-3.16.6-2.1.x86_64
x11-video-nvidiaG03-340.65-32.1.x86_64
nvidia-gfxG03-kmp-default-340.46_k3.11.6_4-33.1.x86_64
nvidia-gfxG03-kmp-default-340.46_k3.11.6_4-30.1.x86_64
nvidia-gfxG03-kmp-default-340.65_k3.16.6_2-32.1.x86_64
nvidia-gfxG03-kmp-default-331.89_k3.11.6_4-28.1.x86_64
nvidia-uvm-gfxG03-kmp-default-340.58_k3.16.6_2-31.1.x86_64
kernel-desktop-3.11.10-21.1.x86_64
kernel-devel-3.16.7-7.1.noarch
nvidia-uvm-gfxG03-kmp-desktop-340.46_k3.11.6_4-33.1.x86_64
nvidia-gfxG03-kmp-default-340.58_k3.11.6_4-31.1.x86_64
nvidia-gfxG03-kmp-default-340.58_k3.16.6_2-31.1.x86_64
nvidia-gfxG03-kmp-default-340.32_k3.11.6_4-31.1.x86_64
kernel-desktop-devel-3.11.10-17.2.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64
nvidia-uvm-gfxG03-kmp-default-340.65_k3.16.6_2-32.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.32_k3.11.6_4-31.1.x86_64
kernel-default-devel-3.11.10-17.2.x86_64
kernel-macros-3.16.7-7.1.noarch
nvidia-uvm-gfxG03-kmp-desktop-340.58_k3.11.6_4-31.1.x86_64
nvidia-uvm-gfxG03-kmp-default-340.46_k3.11.6_4-30.1.x86_64
nvidia-gfxG03-kmp-desktop-340.58_k3.16.6_2-31.1.x86_64
kernel-default-devel-3.16.7-7.1.x86_64
kernel-default-devel-3.11.10-21.1.x86_64
nvidia-computeG03-340.65-32.1.x86_64
nvidia-gfxG03-kmp-desktop-340.46_k3.11.6_4-33.1.x86_64
kernel-firmware-20140903git-2.4.noarch
nvidia-uvm-gfxG03-kmp-default-331.89_k3.11.6_4-28.1.x86_64
kernel-desktop-3.16.6-2.1.x86_64
nvidia-glG03-340.65-32.1.x86_64
nvidia-gfxG03-kmp-desktop-340.58_k3.11.6_4-31.1.x86_64
nvidia-gfxG03-kmp-desktop-340.32_k3.11.6_4-31.1.x86_64
kernel-default-devel-3.16.6-2.1.x86_64
nvidia-gfxG03-kmp-desktop-340.46_k3.11.6_4-30.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.58_k3.16.6_2-31.1.x86_64
nvidia-uvm-gfxG03-kmp-default-340.46_k3.11.6_4-33.1.x86_64
kernel-desktop-3.11.10-17.2.x86_64
kernel-desktop-devel-3.11.10-21.1.x86_64
nvidia-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64
nvidia-gfxG03-kmp-desktop-331.89_k3.11.6_4-28.1.x86_64

/var/log/Xorg.0.log

cat Xorg.0.log
17.133]
X.Org X Server 1.16.1
Release Date: 2014-09-21
17.133] X Protocol Version 11, Revision 0
17.133] Build Operating System: openSUSE SUSE LINUX
17.133] Current Operating System: Linux MeanMachine 3.16.7-7-desktop #1 SMP PREEMPT Wed Dec 17 18:00:44 UTC 2014 (762f27a) x86_64
17.133] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.7-7-desktop root=UUID=800209a2-7498-4902-b337-670f2af714e4 resume=/dev/disk/by-id/ata-WDC_WD5000AAKS-00V1A0_WD-WCAWF0798903-part1 splash=silent quiet showopts
17.133] Build Date: 08 October 2014 05:49:10PM
17.133]
17.133] Current version of pixman: 0.32.6
17.133] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
17.133] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
17.133] (==) Log file: “/var/log/Xorg.0.log”, Time: Sun Dec 21 16:40:40 2014
17.133] (==) Using config directory: “/etc/X11/xorg.conf.d”
17.133] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
17.133] (==) No Layout section. Using the first Screen section.
17.133] (==) No screen section available. Using defaults.
17.133] (
) |–>Screen “Default Screen Section” (0)
17.133] (**) | |–>Monitor “<default monitor>”
17.133] (==) No monitor specified for screen “Default Screen Section”.
Using a default monitor configuration.
17.133] (==) Automatically adding devices
17.133] (==) Automatically enabling devices
17.133] (==) Automatically adding GPU devices
17.285] (WW) The directory “/usr/share/fonts/misc/sgi” does not exist.
17.285] Entry deleted from font path.
17.285] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/ghostscript/,
/usr/share/fonts/cyrillic:unscaled,
/usr/share/fonts/truetype/,
built-ins
17.285] (==) ModulePath set to “/usr/lib64/xorg/modules”
17.285] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
17.285] (II) Loader magic: 0x80dc60
17.285] (II) Module ABI versions:
17.285] X.Org ANSI C Emulation: 0.4
17.285] X.Org Video Driver: 18.0
17.285] X.Org XInput driver : 21.0
17.285] X.Org Server Extension : 8.0
17.285] (II) xfree86: Adding drm device (/dev/dri/card0)
17.286] (–) PCI:*(0:1:0:0) 10de:1086:1462:2571 rev 161, Mem @ 0xf4000000/16777216, 0xe0000000/134217728, 0xe8000000/33554432, I/O @ 0x00005000/128, BIOS @ 0x???/524288
17.286] (II) LoadModule: “glx”
17.894] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
20.076] (II) Module glx: vendor=“NVIDIA Corporation”
20.386] compiled for 4.0.2, module version = 1.0.0
20.386] Module class: X.Org Server Extension
20.665] (II) NVIDIA GLX Module 340.65 Tue Dec 2 09:10:06 PST 2014
20.669] (==) Matched nvidia as autoconfigured driver 0
20.669] (==) Matched nouveau as autoconfigured driver 1
20.669] (==) Matched nv as autoconfigured driver 2
20.669] (==) Matched nvidia as autoconfigured driver 3
20.669] (==) Matched nouveau as autoconfigured driver 4
20.669] (==) Matched nv as autoconfigured driver 5
20.669] (==) Matched modesetting as autoconfigured driver 6
20.669] (==) Matched fbdev as autoconfigured driver 7
20.669] (==) Matched vesa as autoconfigured driver 8
20.669] (==) Assigned the driver to the xf86ConfigLayout
20.669] (II) LoadModule: “nvidia”
20.669] (II) Loading /usr/lib64/xorg/modules/updates/drivers/nvidia_drv.so
20.669] (II) Module nvidia: vendor=“NVIDIA Corporation”
20.669] compiled for 4.0.2, module version = 1.0.0
20.669] Module class: X.Org Video Driver
20.669] (II) LoadModule: “nouveau”
20.669] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
20.669] (II) Module nouveau: vendor=“X.Org Foundation”
20.669] compiled for 1.16.1, module version = 1.0.11
20.669] Module class: X.Org Video Driver
20.669] ABI class: X.Org Video Driver, version 18.0
20.670] (II) LoadModule: “nv”
20.670] (II) Loading /usr/lib64/xorg/modules/drivers/nv_drv.so
20.670] (II) Module nv: vendor=“X.Org Foundation”
20.670] compiled for 1.16.1, module version = 2.1.20
20.670] Module class: X.Org Video Driver
20.670] ABI class: X.Org Video Driver, version 18.0
20.670] (II) LoadModule: “modesetting”
20.670] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
20.670] (II) Module modesetting: vendor=“X.Org Foundation”
20.670] compiled for 1.16.1, module version = 0.9.0
20.670] Module class: X.Org Video Driver
20.670] ABI class: X.Org Video Driver, version 18.0
20.670] (II) LoadModule: “fbdev”
20.670] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
20.670] (II) Module fbdev: vendor=“X.Org Foundation”
20.670] compiled for 1.16.1, module version = 0.4.4
20.670] Module class: X.Org Video Driver
20.670] ABI class: X.Org Video Driver, version 18.0
20.670] (II) LoadModule: “vesa”
20.670] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
20.670] (II) Module vesa: vendor=“X.Org Foundation”
20.670] compiled for 1.16.1, module version = 2.3.3
20.670] Module class: X.Org Video Driver
20.670] ABI class: X.Org Video Driver, version 18.0
20.670] (II) NVIDIA dlloader X Driver 340.58 Fri Oct 31 16:27:22 PDT 2014
20.670] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
20.670] (II) NOUVEAU driver
20.670] (II) NOUVEAU driver for NVIDIA chipset families :
20.670] RIVA TNT (NV04)
20.670] RIVA TNT2 (NV05)
20.670] GeForce 256 (NV10)
20.670] GeForce 2 (NV11, NV15)
20.670] GeForce 4MX (NV17, NV18)
20.670] GeForce 3 (NV20)
20.670] GeForce 4Ti (NV25, NV28)
20.670] GeForce FX (NV3x)
20.670] GeForce 6 (NV4x)
20.670] GeForce 7 (G7x)
20.670] GeForce 8 (G8x)
20.670] GeForce GTX 200 (NVA0)
20.671] GeForce GTX 400 (NVC0)
20.671] (II) NOUVEAU driver
20.671] (II) NOUVEAU driver for NVIDIA chipset families :
20.671] RIVA TNT (NV04)
20.671] RIVA TNT2 (NV05)
20.671] GeForce 256 (NV10)
20.671] GeForce 2 (NV11, NV15)
20.671] GeForce 4MX (NV17, NV18)
20.671] GeForce 3 (NV20)
20.671] GeForce 4Ti (NV25, NV28)
20.671] GeForce FX (NV3x)
20.671] GeForce 6 (NV4x)
20.671] GeForce 7 (G7x)
20.671] GeForce 8 (G8x)
20.671] GeForce GTX 200 (NVA0)
20.671] GeForce GTX 400 (NVC0)
20.671] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
20.671] (II) FBDEV: driver for framebuffer: fbdev
20.671] (II) VESA: driver for VESA chipsets: vesa
20.671] (++) using VT number 7

20.671] (II) Loading sub module "fb"
20.671] (II) LoadModule: "fb"
20.671] (II) Loading /usr/lib64/xorg/modules/libfb.so
20.671] (II) Module fb: vendor="X.Org Foundation"
20.671]    compiled for 1.16.1, module version = 1.0.0
20.671]    ABI class: X.Org ANSI C Emulation, version 0.4
20.671] (WW) Unresolved symbol: fbGetGCPrivateKey
20.671] (II) Loading sub module "wfb"
20.671] (II) LoadModule: "wfb"
20.672] (II) Loading /usr/lib64/xorg/modules/libwfb.so
20.672] (II) Module wfb: vendor="X.Org Foundation"
20.672]    compiled for 1.16.1, module version = 1.0.0
20.672]    ABI class: X.Org ANSI C Emulation, version 0.4
20.672] (II) Loading sub module "ramdac"
20.672] (II) LoadModule: "ramdac"
20.672] (II) Module "ramdac" already built-in
20.672] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
20.672] (EE) NVIDIA:     system's kernel log for additional error messages and
20.672] (EE) NVIDIA:     consult the NVIDIA README for details.
20.672] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
20.672] (EE) NVIDIA:     system's kernel log for additional error messages and
20.672] (EE) NVIDIA:     consult the NVIDIA README for details.

20.673] (WW) Falling back to old probe method for modesetting
20.673] (II) Loading sub module "fbdevhw"
20.673] (II) LoadModule: "fbdevhw"
20.673] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
20.673] (II) Module fbdevhw: vendor="X.Org Foundation"
20.673]    compiled for 1.16.1, module version = 0.0.2
20.673]    ABI class: X.Org Video Driver, version 18.0
20.673] (**) FBDEV(1): claimed PCI slot 1@0:0:0
20.673] (II) FBDEV(1): using default device
20.673] (WW) Falling back to old probe method for vesa
20.673] (EE) Screen 0 deleted because of no matching config section.
20.673] (II) UnloadModule: "modesetting"
20.673] (II) FBDEV(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
20.673] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
20.673] (==) FBDEV(0): RGB weight 888
20.673] (==) FBDEV(0): Default visual is TrueColor
20.673] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
20.673] (II) FBDEV(0): hardware: VESA VGA (video memory: 5120kB)
20.673] (II) FBDEV(0): checking modes against framebuffer device...
20.673] (II) FBDEV(0): checking modes against monitor...
20.673] (--) FBDEV(0): Virtual size is 1280x1024 (pitch 1280)
20.673] (**) FBDEV(0):  Built-in mode "current": 131.1 MHz, 80.3 kHz, 76.6 Hz
20.673] (II) FBDEV(0): Modeline "current"x0.0  131.09  1280 1312 1472 1632  1024 1028 1032 1048 -hsync -vsync -csync (80.3 kHz b)
20.673] (==) FBDEV(0): DPI set to (96, 96)
20.673] (II) Loading sub module "fb"
20.673] (II) LoadModule: "fb"
20.673] (II) Loading /usr/lib64/xorg/modules/libfb.so
20.673] (II) Module fb: vendor="X.Org Foundation"
20.673]    compiled for 1.16.1, module version = 1.0.0
20.673]    ABI class: X.Org ANSI C Emulation, version 0.4
20.673] (**) FBDEV(0): using shadow framebuffer
20.673] (II) Loading sub module "shadow"
20.674] (II) LoadModule: "shadow"
20.674] (II) Loading /usr/lib64/xorg/modules/libshadow.so
20.674] (II) Module shadow: vendor="X.Org Foundation"
20.674]    compiled for 1.16.1, module version = 1.1.0
20.674]    ABI class: X.Org ANSI C Emulation, version 0.4
20.674] (II) UnloadModule: "vesa"
20.674] (II) Unloading vesa
20.674] (==) Depth 24 pixmap format is 32 bpp
20.674] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
20.674] (==) FBDEV(0): Backing store enabled
20.674] (==) FBDEV(0): DPMS enabled
20.674] (==) RandR enabled
20.851] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
20.988] (II) config/udev: Adding input device Power Button (/dev/input/event1)


21.008] (II) No input driver specified, ignoring this device.
21.008] (II) This device may have been added with another device file.
21.008] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event6)
21.008] (II) No input driver specified, ignoring this device.

had to truncate file to fit sorry

from default boot load.
Thanks

Yes, there was a kernel update today.

here are the requested data.

rpm -qa | egrep “nvidia|kernel”

Wow. Quite a mess.

Please remove everything and install it again:

sudo zypper rm nvidia-gfxG03-kmp-default nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-default nvidia-uvm-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-glG03 nvidia-computeG03
sudo zypper in nvidia-gfxG03-kmp-desktop nvidia-uvm-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-glG03 nvidia-computeG03

And maybe you should clean up your kernels a bit. You still have two of the 13.1 kernels installed.
Please run “sudo systemctl enable purge-kernels” to have the old kernels removed automatically on updates.

/var/log/Xorg.0.log

rpm -qa | egrep “nvidia|kernel”

???
Seems like you pasted the wrong text… :wink:

Anyway, better upload/paste the file to a site like http://susepaste.org and post a link.
But hopefully the above should fix your problem already anyway.

As suspected, the kernel module cannot be loaded:


 cat Xorg.0.log
...
    20.672] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
    20.672] (EE) NVIDIA:     system's kernel log for additional error messages and
    20.672] (EE) NVIDIA:     consult the NVIDIA README for details.
    20.672] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
    20.672] (EE) NVIDIA:     system's kernel log for additional error messages and
    20.672] (EE) NVIDIA:     consult the NVIDIA README for details.

Therefore the nvidia driver does not work, and Xorg falls back to fbdev instead.

Removing/reinstalling the driver should fix it.

Hi,
Problem still same.
did commands asrequested and again give output from rpm command as

rpm -qa | egrep “nvidia|kernel” rpm -qa | egrep “nvidia|kernel”
kernel-desktop-devel-3.16.7-7.1.x86_64
nvidia-uvm-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64
kernel-devel-3.16.6-2.1.noarch
kernel-desktop-3.16.7-7.1.x86_64
kernel-desktop-devel-3.16.6-2.1.x86_64
nvidia-glG03-340.65-32.1.x86_64
kernel-devel-3.16.7-7.1.noarch
x11-video-nvidiaG03-340.65-32.1.x86_64
kernel-macros-3.16.7-7.1.noarch
kernel-default-devel-3.16.7-7.1.x86_64
kernel-firmware-20140903git-2.4.noarch
kernel-desktop-3.16.6-2.1.x86_64
kernel-default-devel-3.16.6-2.1.x86_64
nvidia-gfxG03-kmp-desktop-340.65_k3.16.6_2-32.1.x86_64
nvidia-computeG03-340.65-32.1.x86_64

In log still has
21.917] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
21.917] (EE) NVIDIA: system’s kernel log for additional error messages and
21.917] (EE) NVIDIA: consult the NVIDIA README for details.

re booted after driver changes, Next steps? Thanks

Did you get any error messages when installing the driver?
Try to reinstall it please and post the output:

sudo zypper in -f nvidia-gfxG03-kmp-desktop

What does “dmesg|grep nvidia” say?

Hi,
massive ammount of output when trying to run this
most repetitive item is this

/usr/src/linux-3.16.7-7/include/linux/compiler.h:159:40: note: in definition of macro ‘likely’

define likely(x) __builtin_expect(!!(x), 1)

                                                                                        ^

another line is this
/usr/src/linux-3.16.7-7/include/asm-generic/qrwlock.h:93:35: warning: comparison between signed and unsigned integer expressions -Wsign-compare]
cnts, cnts | _QW_LOCKED) == cnts);
^

do you need full output?
appears to not run properly

dmesg output

dmesg|grep nvidia
2.061143] nvidia: module license ‘NVIDIA’ taints kernel.
2.081788] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 0
2.083593] nvidia_uvm: Loaded the UVM driver, major device number 250
15.191664] nvidia_uvm: Unregistered the UVM driver
21.817915] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 0
21.915277] nvidia_uvm: Loaded the UVM driver, major device number 250
21.918505] NVRM: nvidia_frontend_ioctl: minor 255, module->ioctl failed, error -22

Thanks Could olddsh firmware make difference?
Cheers

Well, the things you posted is a “note” and a “warning”. Both should not matter.
To really be able to judge whether there is a problem or not, the full output would be necessary, yes.
Is there anything saying “error”?
But according to the other output, it seems to have worked ok anyway, so no need to post it I suppose.

dmesg output

dmesg|grep nvidia
2.061143] nvidia: module license ‘NVIDIA’ taints kernel.
2.081788] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 0
2.083593] nvidia_uvm: Loaded the UVM driver, major device number 250
15.191664] nvidia_uvm: Unregistered the UVM driver
21.817915] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 0
21.915277] nvidia_uvm: Loaded the UVM driver, major device number 250
21.918505] NVRM: nvidia_frontend_ioctl: minor 255, module->ioctl failed, error -22

Hm, so apparently the module is found, but something else goes wrong and causes it to not start correctly.
I never saw this particular message though.

Does it still work with the 3.16.6 kernel?

Thanks Could olddsh firmware make difference?

The nvidia driver doesn’t use any additional firmware AFAIK.
But if you mean the UEFI firmware (or the BIOS), then yes. But you should have had the same problem before the driver update then I would think.

I do have another suspicion though:
Open /etc/sysconfig/displaymanager in a text editor (with “kdesu kwrite /etc/sysconfig/displaymanager” e.g.) and search for the following line:

DISPLAYMANAGER_XSERVER="X.x11-video-nvidiaG03"

Replace the “X.x11-video-nvidiaG03” with just “Xorg”.
Does this help?

Hi,
thanks again for your patience here, much appreciated.
I tried again to boot into different desktop and appears to have fewer options now?
the other options on 3.16.6.2 again do not show on second screen.
Sorry I did not take notes when I tried this before, I think i picked an option that ended 7.20 and this worked with the second screen correctly but none of the options now available gives second display. windows still does so definately no hardware impact.

Did not see any errors on that driver install, I posted the bits that looked odd and I think errors would have been strongly displayed.

the displaymanager file is already set at xorg

Thanks

You mean you have fewer options in the boot menu now?
Well, that’s to be expected, if you removed the two 3.11.10 kernels which were left-overs from 13.1.

the other options on 3.16.6.2 again do not show on second screen.
Sorry I did not take notes when I tried this before, I think i picked an option that ended 7.20 and this worked with the second screen correctly but none of the options now available gives second display. windows still does so definately no hardware impact.

So it doesn’t work with 3.16.6 as well?
But it did work with 3.16.6 before the nvidia driver update?

As the older packages are not available any more, your only option would be to install the previous version “the hard way”. But let’s wait with that.

You could just try the G02 driver instead of G03 as well though.

the displaymanager file is already set at xorg

Hm, it shouldn’t if you installed the nvidia driver. Maybe that’s causing your problem then?
Try to change it to “X.x11-video-nvidiaG03” instead.

Hi,

So it doesn’t work with 3.16.6 as well?
But it did work with 3.16.6 before the nvidia driver update?

Yes and Yes again

edited displaymanager file rebooted and same results.
Cannot be too much as worked fine yesterday and updates to driver have come through and gone seamlessly through 13.1, update and few weeks on?

Thanks

Well, maybe the latest driver has a problem with kernel 3.16, whereas the previous version didn’t.
But then other people should have experienced the same of course…

Hm. Try to add “nomodeset” to the kernel options then (YaST->System->Boot Loader->Kernel Parameter). Should not be necessary, but well…

And try to re-create the initrd. Maybe a wrong nvidia kernel module is in there causing a problem later on. Although X.x11-video-nvidiaG03 should take care of that anyway I think.

sudo mkinitrd

Hi,
in the boot loader area added no modeset to the optional cmd line params box, That right?
It is already within the failsafe box.
ran the mkinitrd command and ran through with no errors or problems.
rebooted and still same.
Is it easy to try nouveau driver? comparison couldprovide info
thanks

It should be “nomodeset”, without any space.

Is it easy to try nouveau driver? comparison couldprovide info

Trying the nouveau driver will not give any clue as to why the nvidia driver is not working.
They are completely different drivers, so there is nothing to compare really.

And it is not easy to try it at all when nvidia is installed.

One thing I would suggest to try though, is remove all 5 nvidia packages and install the G02 driver instead:
nvidia-gfxG02-kmp-desktop, x11-video-nvidiaG02, nvidia-computeG02

The G02 driver should support your card as well.

This won’t help either in finding out why the G03 driver doesn’t work, but it may be an acceptable work-around for you.

Hi,
Thanks for your efforts here but had enough for now.
I always seem to get some prob when I update system and easiest fix is to re install.
Since I have a separate disk as / home it is not too bad and it tends to fix these probs.
Anyway enough for now and again thanks for your help.
have a godd christmas and have a beer on me.Cheers

I noticed a very suspicious Nvidia update today that I declined, which I suspect may be behind this problem (and other problems reported the last few days).

Here is what I currently have installed and what YaST wants to downgrade me to:

# Status    Package                        | Summary                                  | Installed (Available)                         |       Size

[Keep]      nvidia-computeG03              | NVIDIA driver for computing with GPGPU   | 340.65-36.1 (340.65-32.1)                     |   41.4 MiB
[Keep]      nvidia-gfxG03-kmp-desktop      | NVIDIA graphics driver kernel module ... | 340.65_k3.16.6_2-36.1 (340.65_k3.16.6_2-32.1) |   32.7 MiB
[Keep]      nvidia-glG03                   | NVIDIA GL libraries for OpenGL accele... | 340.65-36.1 (340.65-32.1)                     |  129.3 MiB
[Keep]      nvidia-uvm-gfxG03-kmp-desktop  | NVIDIA Unified Memory kernel module      | 340.65_k3.16.6_2-36.1 (340.65_k3.16.6_2-32.1) |   16.1 MiB
[Keep]      x11-video-nvidiaG03            | NVIDIA graphics driver for GeForce 8x... | 340.65-36.1 (340.65-32.1)                     |  126.3 MiB

As you can see, I currently have 340.65-36.1 installed and the system wants to downgrade me to 340.65-32.1.

Additionally, FWIW, the current version has a vendor string of “obs://build.suse.de/home:michal-m:drivers” and the downgrade to be installed has a vendor string of “obs://build.suse.de/home:sndirsch:drivers”.

Another thought from having read this thread: has the “update” lost the blacklisting of the nouveau module?

In any case, I’d try reverting to 340.65-36.1 before trying anything else.

Good luck!

There’s nothing suspect about that update.
S. Dirsch was on holiday, so M. Marek created the previous packages (36.1).
That’s why 36.1 has the vendor “obs://build.suse.de/home:michal-m:drivers”.

This got reported as bug, so S. Dirsch rebuilt the packages now so that people will actually see the update. (the software management stack doesn’t do automatic vendor changes and won’t show “updates” from different repos).

Now the version is lower (32.1), but that’s just how OBS works, that number is totally irrelevant when comparing packages built in different repos.
And the vendor is now “obs://build.suse.de/home:sndirsch:drivers” again, just like it always was before.

In any case, I’d try reverting to 340.65-36.1 before trying anything else.

This will not help at all. And the 36.1 packages are not available any more anyway.

I have YaST configured to use the default community repository “nVidia Graphics Drivers” (http://download.nvidia.com/opensuse/13.2/) and it had no problem both showing and switching between the different builds. The only place “vendor” showed up was when viewing the versions tab for the various packages.

While it may be normal for a package’s version to potentially backtrack when built by different maintainers, it still seems that the release of this update happened about the same time that various people started having a variety of different problems.

I haven’t dug deeper than what I mentioned in my earlier post, so I can’t say with any certainty if this is a coincidence, or if there is indeed a problem in the packages, or perhaps software management is having a hickup somehow over the version numbers going down.

In any case, my system is healthy and happy with 340.65-36.1 and I don’t plan on installing 340.65-32.1 to see if it works OK for me or not.

Thanks for clarifying the issue of the vendor string having changed.

No. YaST will not switch vendor automatically by default.
Unless you configured it otherwise.

Note that you will of course see the different vendor’s version in YaST when you click on the “Versions” tab. But neither YaST nor “zypper up” nor the updater applet will automatically want to install it (unless you allowed “vendor switch” in the configuration).

You can of course tell YaST manually to switch.

While it may be normal for a package’s version to potentially backtrack when built by different maintainers, it still seems that the release of this update happened about the same time that various people started having a variety of different problems.

Well, most people didn’t install the 36.1 packages at all because they didn’t notice them (because of the different vendor).
So that would rather indicate something’s wrong with 340.65 in general…

But actually some bugreports and forum posts seem to indicate that all the problems were caused by left-over libglx versions from older 13.1 packages.
Apparently the 13.1 340.58 (or whatever version it was exactly) did not remove those files on uninstallation.
As long as you used the same nvidia driver version (340.58) on 13.2 there was no problem, but now as the driver was updated to 340.65 it didn’t work any more with the older 340.58 libglx and people started having problems.

I did not see any problem on a 13.1 system with the nvidia driver here that I upgraded to 13.2 a month ago.
So from my experience I cannot confirm any problem with left-over files.

I haven’t dug deeper than what I mentioned in my earlier post, so I can’t say with any certainty if this is a coincidence, or if there is indeed a problem in the packages, or perhaps software management is having a hickup somehow over the version numbers going down.

There is no problem in the current packages AFAIK. At least no problem that wasn’t in the 36.1 packages by m-marek already.

In any case, my system is healthy and happy with 340.65-36.1 and I don’t plan on installing 340.65-32.1 to see if it works OK for me or not.

The packages are exactly the same, just the vendor changed back to the normal one.
If your system works fine with 36.1, it should work fine as well with 32.1.

Thanks for clarifying the issue of the vendor string having changed.

You’re welcome.