Driver problem

I found the driver for the network on openSuse 12.1 64Bit and I don’t know how to install it. So if someone could direct me on how to get into the terminal and the kernel I would be happy.My driver requires me to get into the kernel in order to dix the problem I am having so if someone could tell me how to do it that would be great.
Cheers
Chris

Are you sure?

Is the network device wired or wireless?

If you open a terminal, get the result of this:

/sbin/lspci -nnk

I know cuz I pay for it its wired I just want to solve this problem it has been a ruff one and I am just ready to go back to Mint
Chris

Try this

Open Yast > Network Devices > Network Settings
Your device should be in there, just highlight it and keep clicking Next to move through the configuration until it’s done.

I opened Yast > now network services or network settings? neither one lets me choose next. My options are add and ok in network settings and add and finish in network services(xinetd) along with help in them.I don’t know what this was supposed to do for me but for a test I’ll do it and learn in the process I like opensuse and don’t want to give up on it just yet but my patience is growing thin. But there is still some left

Chris

Select the device and click OK > just follow it thru >

When I click on OK it looks like its about to do something but then it does nothing I am almost sure I have to install the correct driver which is r8168 for the Realtek ethernet card unless you have more for me to do:-)’

So again what do I do to get the terminal in the kernel for those of you who think I will screw things up I have a sort of saftey harness which is keep printing screen the whole time I am in the kernel I just want to fix my internet problem which has me doing the hardest things one of the reasons I like open suse so much.
Chris

It should just work

Post the result of

/sbin/lspci -nnk | grep -iA2 net

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:0390]
Kernel driver in use: r8169
It gives me some internet but only the forums and one page of multiple page sites like skype or linux freedom cuz its the wrong driver I need r8168

Sounds more like a DNS problem
I have to sleep now
I’ll come back in the morning UK

On 08/12/2012 02:06 PM, Synic74 wrote:
>
> caf4926;2479617 Wrote:
>> It should just work
>>
>> Post the result of
>>
>>>
> Code:
> --------------------
> > > /sbin/lspci -nnk | grep -iA2 net
> --------------------
>>>
>
> 02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
> RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev
> 03)
> Subsystem: Acer Incorporated [ALI] Device [1025:0390]
> Kernel driver in use: r8169
> It gives me some internet but only the forums and one page of multiple
> page sites like skype or linux freedom cuz its the wrong driver I need
> r8168

If it gives you ANY Internet, then the driver is working, and something else
is wrong.

The r8169 driver supports your chipset 10ec:8168

# modinfo r8169
filename:       /lib/modules/2.6.37.6-0.20-desktop/kernel/drivers/net/r8169.ko
version:        2.3LK-NAPI
license:        GPL
description:    RealTek RTL-8169 Gigabit Ethernet driver
author:         Realtek and the Linux r8169 crew <netdev@vger.kernel.org>
srcversion:     AC5D7EED6B5BA89A66B3E62
alias:          pci:v00000001d00008168sv*sd00002410bc*sc*i*
alias:          pci:v00001737d00001032sv*sd00000024bc*sc*i*
alias:          pci:v000016ECd00000116sv*sd*bc*sc*i*
alias:          pci:v00001259d0000C107sv*sd*bc*sc*i*
alias:          pci:v00001186d00004300sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008169sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008168sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008167sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008136sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008129sv*sd*bc*sc*i*
depends:        
vermagic:       2.6.37.6-0.20-desktop SMP preempt mod_unload modversions 
parm:           use_dac:Enable PCI DAC. Unsafe on 32 bit PCI slot. (int)
parm:           debug:Debug verbosity level (0=none, ..., 16=all) (int)

As the others have already said, and from the info you’ve given, you appear to have a different issue.