Driver for VIA Unichrome PRO CN400 graphics card?

When I had suse 10.2, my graphics card was doing 800-900 FPS with ‘glxgears’. The driver I used was “via” (came along with the distro).

But now with suse 11.1, there exists no via driver (default ‘fbdev’ is used). There is one driver in the distro called ‘unichrome’, but it does not support my card (VT3118 series).

I have tried the drivers ‘chrome9’ and ‘openchrome’ but they give arise to a blank screen when X tries to start up.
The ‘fbdev’ driver works but max 150 FPS running glxgears…plus the driver is not supported by compiz-fusion.

Please anyone, any ideas?

/Mikael

Try here:
Software.openSUSE.org
Type openchrome in the searchbar on that page.
The one click install should work,it does on mine.

Hi,

I got my openchrome driver from exactly that page as well. When I try ‘openchrome’ in /etc/X11/xorg.conf and restart X, then screen gets blank (no mouse cursor shows up either).
I guess it does’nt matter which of the two options for openchrome drivers (from that page) you choose?

How does your /etc/X11/xorg.conf file look like?
Can you give me the full name of your graphics card?

Regards

/Mikael

The opensource via driver should be icluded with xorg packages by default. If you type

man via

it mentions CN400 among supported models:

Direct rendering 3D is available using experimental drivers in Mesa, Mesa Home Page. Also
there is an XvMC client library for hardware MPEG1 / MPEG2 decoding acceleration available on
the CLE266, CN400, PM/N800 and K8M/N800 chipsets that uses the Direct Rendering Infrastruc‐
ture, DRI. The XvMC client library implements a nonstandard “VLD” extension to the XvMC stan‐
dard. The current Direct Rendering Manager Linux kernel module is available at dri.source‐
forge.net.

You could try configuring (as root) in failsafe mode (runlevel 3), with

sax2 -r -m 0=via

See how that goes.

I run ‘sax2 -r -m 0=via’:


SaX: your current configuration will not be read in
<some stuff>
SaX: X-Server: :0.0 -> grant


then I hit ^C because the command does not progress nor finish.

I have the via manpage. But how come you cannot just set driver in /etc/X11/xorg.conf to via? It was possible in suse 10.2. When I restart X it says that no via driver found.
Also, there is no via driver in ‘/usr/lib/xorg/modules/drivers’.

/Mikael

That is strange, because on my openSUSE 11 installation, I get

ls /usr/lib/xorg/modules/drivers |grep via
via_drv.la
via_drv.so

and

linux:/home/dean # rpm -qf /usr/lib/xorg/modules/drivers/via_drv.so
xorg-x11-driver-video-7.3-138.5

Maybe something has changed…

BTW, post the output of

sax2 -p

Maybe there is a clue here.

Referring back to your earlier post #3, you mention you get a black screen. Without wishing to confuse the issue, I had a look a this

openchrome
page, where they have a FAQ section which describes a similar problem:

FAQ.3 - With via driver I only get a black screen on my laptop. What’s wrong?
On some laptops via driver initializes the external monitor first leaving laptop internal LCD screen black / blank. One solution is to disable external output (sometimes called CRT) in system BIOS or change order of LCD and CRT there. Another solution is to add Option “ForcePanel” to the above Device section. (thx br. Bonaventura for this hint).

This obviously only applies to laptop situation, so disregard if I’m off track here…

I run ‘sax2 -p’:


chip: 0 is -> VIA VT3259: PM800,PM880,CN400,CN333 01:00:0 0x1106 0x3118 AGP chrome9


Output from my other SUSE 10.2 machine:


mikael@c-131-74-vas-l3:/> rpm -qf /usr/lib/xorg/modules/drivers/via_drv.so
xorg-x11-driver-video-7.2-33


My target machine (with SUSE 11.1) does not have via_drv.so. The version of xorg driver is: xorg-x11-driver-video-7.4-19.4

Cheers

You are not off-track, I use a laptop. But I tried that ‘trick’ a few days ago (been googling this issue for several days now), it does not work.

Thanks anyway =)

How infuriating… :expressionless: Guess you’ll have to wait for Sagmenta (or another via graphics user) to reply with requested info. I’m interested in following this one…

Also, concerning this matter, my BIOS does not support disabling CRT (second output) nor change order between LCD and CRT.

Cheers

I believe openSUSE 11.1 uses Xorg 7.4 and the “via” driver is deprecated in this release. Its not in this list here.

Furthermore, IMO and experience, openSUSE official support for unichrome chips or the openchrome driver has never risen to equal that of other popular or less well-off distros (they don’t use Xorg 7.4). I still use a VT3108 and the openchrome driver from OBS (good 2D).

The “unichrome” driver hasn’t worked with it on any distro for a long time, it’s not even mainstream. The chrome9 driver has some rendering problems (2D mode).

Also, AIGLX doesn’t appear to hack it on openSUSE with openchrome and DRM. I only get software rendering and glxgears performance similar to the OP. I can also achieve the higher fps rates on 10.x releases and testing on other distros;).

So…the bottom line is to either go back to suse 10.x (my card works great in that version) or change distro i guess…

Thanks for all the posts!

Cheers

/Mikael

@mag02

I still use 10.3 with kde 3.5 as my everyday system as it is still supported for maintenance. I want to move everything to 11.1 as it’s a great performer (kde 3.5.10) and I am confident that will happen as the issue(s) are fixed. There is much more to openSUSE than just this latest release;).

The openchrome situation has improved a lot and they are working more closely with VIA now. Even chrome9 is ok for 2D, and hopefully that will improve as VIA begin to get their act together on linux. I gather that openSUSE are trying to sort out 3D.

So I will stay with the programme (as they say) for now. You,I, and other VIA unichrome owners have invested a lot of time over the 10.x releases so far:).

Good luck with whatever you choose.

Thanks.

Have been running Suse (10.0, 10.2, 11.1) for 2-3 years now, like the distro and will most probably not change to another distro.
I can live with the fact that I will not get fancy stuff like compiz or similar working on that laptop…

Cheers man =)

Thank you conused, for clarifying where everything is at with the via driver. I hope they get it sorted soon! (The last time I had anything to do with via was on my friends ASUS laptop running openSUSE 10.2, so its been a while).

@mag02, @deano_ferrari
Your both welcome:). I wished I had seen the thread earlier. This 11.1 was the first distro to dump me in the console on first boot following installation. Eventually found how to switch sax2 to vesa, and so on…

The only other problem I have on 11.1, that may be associated with the video driver or Flash 10, is badly performing video streaming (Unstable picture - TV replays in particular). Although local video playback is fine. The problem is accompanied by around 95% cpu utilization. On 10.3 (Xorg 7.2) it’s around 60% with very smooth video performance and Flash 9. Other distros I multiboot and test on (they use Xorg 7.3) give smooth video performance with Flash 10. I think direct rendering is working on those. It is probably true that the more bloated Flash 10 has probably pushed the system into their minimum config territory, but it just works on other distros, even with a 10-15% extra cpu utilization, so I keep 10.3 for now.

Anyway that’s just for info, I don’t expect it to be fixed soon.