Driver for Radeon HD 3200 Integrated

Which driver is better for OpenSuSE 11 running on M3A78-EMH HDMI mobo:

  • ati-driver-installer-8.41.3-x86.x86_64 from the ASUS site
  • ati-driver-installer-8-8-x86.x86_64 from the ATI site
  • other driver?

I use the latest drivers from the ATI repository. No problems to report so far, though I do pretty light 3d work and only use the DVI output on mine.

Thank you for reply. I only plan to use DVI also.

I tried installing the ATI driver from .run file and 1-click-install. The results slightly differ, the common thing is drivers don’t work properly. When I try to configure “Graphics Card and Monitor” in YaST the following message pop-ups:

“Cannot Deactivate All Displays
At least one display must be active”

There in “SaX2: X11 Configuration” window is still “Card: VESAFramebuffer Graphics”.

SaX2 also wasn’t working properly before installation of any drivers. When I pressed “Test” to test changes for keyboard settings there was a window for positioning the display.

In “My Computer” I can see the following information:
Display Info
Vendor: ATI Technologies Inc
Model: ATI Radeon HD 3200 Graphics (RS780 9610)
Driver: fglrx (No 3D Support)

I wanted to try “The Hard Way” also but I couldn’t find all the required packages.

Is it enough to have libstdc++43 instead of libstdc++ and
libgcc43 instead of libgcc?

Installer will generate a package for another OS but not for mine! May my system be missing something?
I’d like to keep openSUSE, but I really need a video driver as using the default one hurts the eyes which displays page scrolling “in waves”.

All Linux distros are very nice. They do stuff for you … but they don’t do it right. They think they are more clever than you …but they are not … Basically they all suck, they behave like Windows. Ok ! Enough complaining. Here’s how I got it to work. But don’t think it is science ! It was just luck.

I edited xorg.conf the only way I know:
vi /etc/X11/xorg.conf (Don’t do it !)
I created a device section for the graphic device, gave it a name which made sense to me. Also I renamed all sections, because Device[0], Monitor[0], Screen[0] … yep … to many zeros ! I remembered there was an Open Source driver for the HD 3200 called “radeonhd”, I didn’t find it in the modules though … but who knows, I wrote a line :
Driver “radeonhd”
in the device session, thinking it might be compiled in the kernel (don’t laugh !)

Well … all I had to do was to restart X and it would work. Of course, it didn’t. X didn’t come up… but Sax, that funny guy, telling me what I just noticed (X didn’t come up) and offering me to configure it for me … Then I don’t remember, everything went blurry (in my mind not on screen), I vaguely remembered from the old good Windows days that I had to say “OK” to everything and I did… and everything went well. Sax2 from the control panel reported an “ATIATI Radeon HD 3200 Graphics (RS780 9610)” and “Activate 3D Acceleration” was checked. Also after enabling “desktop effects” I saw transparency and dancing Windows. “Desktop Cube” is enabled but doesn’t show up … probably because I don’t know when and where to look.

I found a brand new /etc/X11/xorg.conf but I didn’t recognized my style … Somebody might have written it for me. Here is it (not my work !) :


SaX generated X11 config file

Created on: 2008-09-14T01:22:52-0700.

Version: 8.1

Contact: Marcus Schaefer <>, 2005

Contact: SaX-User list <>

Automatically generated by [ISaX] (8.1)


Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”

Section “ServerFlags”
Option “AIGLX” “on”
Option “AllowMouseOpenFail” “on”
Option “IgnoreABI” “on”
Option “ZapWarning” “on”

Section “Module”
Load “glx”
Load “type1”
Load “extmod”
Load “dbe”
Load “freetype”
Load “dri”

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “9”
Option “Device” “/dev/input/mice”
Option “Name” “ImExPS/2 Generic Explorer Mouse”
Option “Protocol” “explorerps/2”
Option “Vendor” “Sysp”
Option “ZAxisMapping” “4 5”

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 338 270
HorizSync 30-83
Identifier “Monitor[0]”
Option “DPMS”
Option “PreferredMode” “1280x1024”
VendorName “GSM”
VertRefresh 43-75
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”
Modeline “1280x1024” 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 16
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 24
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 8
Modes “1280x1024” “1280x960” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”

Section “Device”
BoardName “ATI Radeon HD 3200 Graphics (RS780 9610)”
Driver “fglrx”
Identifier “Device[0]”
Option “XAANoOffscreenPixmaps” “0xcadad0”
Option “Capabilities” “0xe21ed0”
Option “OpenGLOverlay” “0xe22fb0”
Option “FSAAScale” “0xe21de0”
Option “FSAAEnable” “0xe220e0”
Option “VideoOverlay” “0xe22870”
Screen 0
VendorName “ATI”

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”

Section “DRI”
Group “video”
Mode 0660

Section “Extensions”


So shortly, assuming you installed the latest drivers from the ATI repository … the following trick might work for you :

open /etc/X11/xorg.conf with a text editor, find the line ‘Driver “fbdev”’ and replace it with ‘Driver “****”’ (or whatever you have in mind) … log out, kill X if you know how or reboot … X won’t come up (because, as we already know, there is not a single ****ing driver in Linux). Instead Sax will rewrite xorg.conf from scratch and pick the ATI driver ( called ‘fglrx’ ) for you.

That’s all folks !

Not to mention than those ****ing stars are ridiculous… But try “Driver luck” in case Sax (!) has a bad words dictionary.

Someone correct me if I’m wrong, but the repo drivers will only work with your current kernel version. So if your kernel gets updated via automatic update, your video drivers may not work any more.

However, if you run the ATI installer, it will build the correct driver for your current kernel. Just read the instructions carefully and install the dependencies and you should be OK. If your kernel gets updated, you might need to run the installer again, but that’s not too difficult.

You should not update your kernel automatically for this and other reasons. However as soon as the updated kernel becomes your current kernel, reinstalling from the repo should put the module again in the correct directory. If this module wasn’t compiled with version number (probably the case), copying the module from the previous directory might work as well … Problem: I just checked and that directory is empty now. Nice !

Anyway … /lib/modules/ is the interesting file by now (as the line Drive “fglrx” indicates in /etc/X11/xorg.conf). If that file is missing after a kernel update in the corresponding subdirectory, the driver won’t work - because it’s not there . I don’t know why OpenSuse doesn’t saved the previous kernel and keep an entry in the Grub menu to give you the choice of the kernel to boot. Debian does. As far as I can remember, Fedora and Mandriva too … even Ubuntu (!). Maybe that’s a feature and not a bug, and it is possible to change it somehow.

I also had the problem with the graphics driver that firefox scrolled in waves. Here is how I solved it.
I first had to install


from the ATI repository, where for me [KERNELTYPE] was default. The first package actually was already installed, but the second was missing. After that the procedure described above worked:

  1. Edit /etc/X11/xorg.cong as root by replacing the driver “flgrx” by “****”,
  2. killing the X-server via Ctrl-Alt-Backspace (or calling “init 3” as root),
  3. logging in as root and calling sax2. Then sax wrote the new xorg.conf which now works fine.

What should I replace the driver “fglrx” by ______.
You did not mention the name that should replace fglrx.
I am having the same problem now with the pages scrolling in waves.

Hey all. I hope someone will read this threat again. I’m having issues with my ATI Radeon HD 3200 as well. I tried to access xorf.conf but I am not permitted to overwrite it. I’ve been having this “authority” issue since I installed openSUSE. How can I get under root, and never get out of it ? I cannot delete some other things as well. It’s stupid.

Please help.

In a window, you can type:
su root
You’ll be prompted for the root password, which is likely the same as your default user’s password. You should then be able to go to /etc/X11 and delete or modify the xorg.conf from within that window.

You need to be root to delete or modify system files in linux. This is to protect these files from being accidentally or maliciously changed.

However, in all honesty, the set-up tools that come with Suse make having to edit any system files by hand an exceedingly rare thing. It’s likely simpler, easier, and safer to use SAX2 to modify your x configuration.

If you do decide to do something by hand, make a copy of the original (working) file and call it something like – this way if you mess up your graphical configuration you can log in as root, delete the bad xorg.conf file and “cp xorg.conf” to recover your original set-up.

You’ll be prompted for the root password, which is likely the same as your default user’s password. You should then be able to go to /etc/X11 and delete or modify the xorg.conf from within that window.

Modify it in the terminal ?

you can just run an editor from that terminal window where you switched to root-- you only get root privileges in the one window that you “su root” in.

I’ll give it a shot. Thanks for the response.(I’m at school on a MAC … )