Draftsight segfault after OpenSUSE 13.1 update


I have draftsight segfaulting:

/opt/dassault-systemes/draftsight/bin/draftsight: line 34: 1842 Segmentation fault “$BINARY”

It started after update of openSUSE 13.1. It’s one of updates between 7.1 to 9.1 2013. I tried downgrading upgraded packages, but it didn’t help. I have this problem on two of my systems - 64bit OpenSUSE XFCE and 64bit OpenSUSE GNOME.

Did anyone encounter this problem too? Any solutions?

After digging into the issue, I found that draftsight is missing some libraries

ldd /opt/dassault-systemes/draftsight/bin/draftsight.bin 
    linux-gate.so.1 (0xf77b0000)
    libfxsisl.so.1 => not found
    libFXExport.so.1 => not found
    libFXRenderBase.so.1 => not found
    libFXCommandsBase.so.1 => not found
    libFXCrashRpt.so.1 => not found
    libFxFileDialogs.so.1 => not found
    libDDKERNEL.so.1 => not found
    libFxImages.so.1 => not found
    libFxResources.so.1 => not found
    libX11.so.6 => /usr/lib/libX11.so.6 (0xf764b000)
    libdl.so.2 => /lib/libdl.so.2 (0xf7646000)
    libTD_BrepRenderer.so.1 => not found
    libTD_Br.so.1 => not found
    libTD_AcisBuilder.so.1 => not found
    libTD_PdfExport.so.1 => not found
    libTD_SvgExport.so.1 => not found
    libTD_Dwf7Export.so.1 => not found
    libTD_PDFToolkit.so.1 => not found
    libDwfToolkit.so.1 => not found
    libW3dTk.so.1 => not found
    libWhipTk.so.1 => not found
    libDwfCore.so.1 => not found
    libTD_Db.so.1 => not found
    libTD_DbRoot.so.1 => not found
    libTD_SpatialIndex.so.1 => not found
    libTD_Gs.so.1 => not found
    libTD_Gi.so.1 => not found
    libTD_Ge.so.1 => not found
    libTD_FtFontEngine.so.1 => not found
    libTD_Root.so.1 => not found
    libTD_Alloc.so.1 => not found
    libAecGeometry.so.1 => not found
    libQtWebKit.so.4 => /usr/lib/libQtWebKit.so.4 (0xf588a000)
    libQtSvg.so.4 => /usr/lib/libQtSvg.so.4 (0xf5835000)
    libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0xf57f2000)
    libQtOpenGL.so.4 => /usr/lib/libQtOpenGL.so.4 (0xf56f3000)
    libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0xf4c2d000)
    libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0xf4aea000)
    libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0xf47fd000)
    libGLU.so.1 => /usr/lib/libGLU.so.1 (0xf4775000)
    libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0xf4670000)
    libpthread.so.0 => /lib/libpthread.so.0 (0xf4653000)
    libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf4566000)
    libm.so.6 => /lib/libm.so.6 (0xf4520000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf4502000)
    libc.so.6 => /lib/libc.so.6 (0xf4351000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf432e000)
    /lib/ld-linux.so.2 (0xf77b1000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf4323000)
    libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0xf42c8000)
    libpng16.so.16 => /usr/lib/libpng16.so.16 (0xf428b000)
    libwebp.so.4 => /usr/lib/libwebp.so.4 (0xf423f000)
    libxslt.so.1 => /usr/lib/libxslt.so.1 (0xf4201000)
    libz.so.1 => /lib/libz.so.1 (0xf41ea000)
    libgstapp-0.10.so.0 => /usr/lib/libgstapp-0.10.so.0 (0xf41dc000)
    libgstinterfaces-0.10.so.0 => /usr/lib/libgstinterfaces-0.10.so.0 (0xf41c9000)
    libgstpbutils-0.10.so.0 => /usr/lib/libgstpbutils-0.10.so.0 (0xf41a6000)
    libgstvideo-0.10.so.0 => /usr/lib/libgstvideo-0.10.so.0 (0xf4188000)
    libgstbase-0.10.so.0 => /usr/lib/libgstbase-0.10.so.0 (0xf4125000)
    libgstreamer-0.10.so.0 => /usr/lib/libgstreamer-0.10.so.0 (0xf4038000)
    libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf3fe6000)
    libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf3ede000)
    libxml2.so.2 => /usr/lib/libxml2.so.2 (0xf3d82000)
    libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xf3ccd000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf3c91000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf3c03000)
    libSM.so.6 => /usr/lib/libSM.so.6 (0xf3bf9000)
    libICE.so.6 => /usr/lib/libICE.so.6 (0xf3bdf000)
    libXi.so.6 => /usr/lib/libXi.so.6 (0xf3bce000)
    libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf3bc3000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf3bbd000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf3bb1000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf3bac000)
    libXext.so.6 => /usr/lib/libXext.so.6 (0xf3b99000)
    libssl.so.1.0.0 => /lib/libssl.so.1.0.0 (0xf3b39000)
    libcrypto.so.1.0.0 => /lib/libcrypto.so.1.0.0 (0xf3980000)
    librt.so.1 => /lib/librt.so.1 (0xf3977000)
    libnvidia-tls.so.331.20 => /usr/lib/tls/libnvidia-tls.so.331.20 (0xf3972000)
    libnvidia-glcore.so.331.20 => /usr/lib/libnvidia-glcore.so.331.20 (0xf172f000)
    libXau.so.6 => /usr/lib/libXau.so.6 (0xf172b000)
    liborc-0.4.so.0 => /usr/lib/liborc-0.4.so.0 (0xf169a000)
    libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xf1694000)
    libffi.so.4 => /usr/lib/libffi.so.4 (0xf168c000)
    libpcre.so.1 => /usr/lib/libpcre.so.1 (0xf1622000)
    liblzma.so.5 => /usr/lib/liblzma.so.5 (0xf15f8000)
    libexpat.so.1 => /usr/lib/libexpat.so.1 (0xf15cf000)
    libuuid.so.1 => /usr/lib/libuuid.so.1 (0xf15c8000)

But all those missing libraries seem to be in draftsight’s own folder /opt/dassault-systemes/draftsight/lib . How come the program is missing those libraries? I am not sure if this is the problem, since I didn’t check for missing libraries before having problem with draftsight.

I can not find draftsight in the standard repos. Nor does a search on software.opensuse.org give me one. The fact that is seems to be located in /opt also points to it being installed in another way from some other resource.

Maybe you want to tell a bit more on how you installed it and if you tried to get more information from the place you got it from.

I never registered my draftsight install so it won’t start - time has expired.

BUT, I believe you need to start it with the script in /opt/dassault-systemes/draftsight/bin/draftsight,
which does the library set-up before executing /opt/dassault-systemes/draftsight/bin/draftsight.bin

hcvv: Draftsight is not in OpenSUSE repo, it’s proprietary software:


It’s distributed as a binary, so I know that OpenSUSE people cannot do much about troubleshooting it. Trying Draftsight forums is useless, because draftsight is only supported on 32bit linux architecture. I have been running it for 3 years on 64bit linux architecture, without any big problems though. This is the first big one.

cmcgrath5035: I tried running both /opt/dassault-systemes/draftsight/bin/draftsight and /opt/dassault-systemes/draftsight/bin/draftsight.bin with the same result - rhe above mentioned segfault.

Thanks for that information. While most here are willing to try to help as much as possible, even if it is a bit more remote to openSUSE. it would be nice if you from your side would not post here as if it is logical that everybody knows what this non openSUSE product is, what for, how it works, etc. Now people have to go and search and ask what this is all about. where a few lines from you could have put our noses in the right direction.

In other words, this info should have been in your first post IMHO.

OK, on my 13.1/KDE 4.12 desktop machine I removed my old install and downloaded a fresh rpm from the 3ds.com website.

I right-clicked on the “Draftsight for Fedora option”, Save-Link-as and received draftSight.rpm in my Downloads folder (I use Firefox).
I then installed the new RPM using YAST.
I then executed

carl@PVE-LinuxSRV5:/opt/dassault-systemes/draftsight/bin> ./draftsight

, draftsight opened and ran.
I successfully created a simple drawing (a line and a circle) and was able to save it, did nothing extensive.

semhustej, how did you install 13.1, “clean” install or dup?

I wonder if there are missing or perhaps incompatible 32 bit libraries in play here.

Here is was ldd does on my system

carl@PVE-LinuxSRV5:/opt/dassault-systemes/draftsight/bin> ldd draftsight.bin
        linux-gate.so.1 (0xf7737000)
        libfxsisl.so.1 => ../lib/libfxsisl.so.1 (0xf764a000)
        libFXExport.so.1 => ../lib/libFXExport.so.1 (0xf7517000)
        libFXRenderBase.so.1 => ../lib/libFXRenderBase.so.1 (0xf726b000)
        libFXCommandsBase.so.1 => ../lib/libFXCommandsBase.so.1 (0xf6cb8000)
        libFXCrashRpt.so.1 => ../lib/libFXCrashRpt.so.1 (0xf6c7d000)
        libFxFileDialogs.so.1 => ../lib/libFxFileDialogs.so.1 (0xf6c65000)
        libDDKERNEL.so.1 => ../lib/libDDKERNEL.so.1 (0xf67c8000)
        libFxImages.so.1 => ../lib/libFxImages.so.1 (0xf67ba000)
        libFxResources.so.1 => ../lib/libFxResources.so.1 (0xf6713000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xf659e000)
        libdl.so.2 => /lib/libdl.so.2 (0xf6599000)
        libTD_BrepRenderer.so.1 => ../lib/libTD_BrepRenderer.so.1 (0xf64fc000)
        libTD_Br.so.1 => ../lib/libTD_Br.so.1 (0xf64ce000)
        libTD_AcisBuilder.so.1 => ../lib/libTD_AcisBuilder.so.1 (0xf6362000)
        libTD_PdfExport.so.1 => ../lib/libTD_PdfExport.so.1 (0xf62e1000)
        libTD_SvgExport.so.1 => ../lib/libTD_SvgExport.so.1 (0xf627f000)
        libTD_Dwf7Export.so.1 => ../lib/libTD_Dwf7Export.so.1 (0xf61f8000)
        libTD_PDFToolkit.so.1 => ../lib/libTD_PDFToolkit.so.1 (0xf612e000)
        libDwfToolkit.so.1 => ../lib/libDwfToolkit.so.1 (0xf5c61000)
        libW3dTk.so.1 => ../lib/libW3dTk.so.1 (0xf5b23000)
        libWhipTk.so.1 => ../lib/libWhipTk.so.1 (0xf5a23000)
        libDwfCore.so.1 => ../lib/libDwfCore.so.1 (0xf5912000)
        libTD_Db.so.1 => ../lib/libTD_Db.so.1 (0xf49cc000)
        libTD_DbRoot.so.1 => ../lib/libTD_DbRoot.so.1 (0xf4963000)
        libTD_SpatialIndex.so.1 => ../lib/libTD_SpatialIndex.so.1 (0xf4951000)
        libTD_Gs.so.1 => ../lib/libTD_Gs.so.1 (0xf47ad000)
        libTD_Gi.so.1 => ../lib/libTD_Gi.so.1 (0xf4581000)
        libTD_Ge.so.1 => ../lib/libTD_Ge.so.1 (0xf42da000)
        libTD_FtFontEngine.so.1 => ../lib/libTD_FtFontEngine.so.1 (0xf4251000)
        libTD_Root.so.1 => ../lib/libTD_Root.so.1 (0xf4150000)
        libTD_Alloc.so.1 => ../lib/libTD_Alloc.so.1 (0xf414c000)
        libAecGeometry.so.1 => ../lib/libAecGeometry.so.1 (0xf3fa4000)
        libQtWebKit.so.4 => ../lib/libQtWebKit.so.4 (0xf2d62000)
        libQtSvg.so.4 => ../lib/libQtSvg.so.4 (0xf2d09000)
        libQtXml.so.4 => ../lib/libQtXml.so.4 (0xf2cc4000)
        libQtOpenGL.so.4 => ../lib/libQtOpenGL.so.4 (0xf2bd2000)
        libQtGui.so.4 => ../lib/libQtGui.so.4 (0xf20dd000)
        libQtNetwork.so.4 => ../lib/libQtNetwork.so.4 (0xf1f9f000)
        libQtCore.so.4 => ../lib/libQtCore.so.4 (0xf1ced000)
        libGLU.so.1 => /usr/lib/libGLU.so.1 (0xf1c65000)
        libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0xf1bca000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xf1bad000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf1abf000)
        libm.so.6 => /lib/libm.so.6 (0xf1a79000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf1a5c000)
        libc.so.6 => /lib/libc.so.6 (0xf18ab000)
        libcups.so.2 => /usr/lib/libcups.so.2 (0xf1856000)
        libz.so.1 => /lib/libz.so.1 (0xf183e000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf181b000)
        /lib/ld-linux.so.2 (0xf7738000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xf17f2000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf17e6000)
        libphonon.so.4 => ../lib/libphonon.so.4 (0xf178e000)
        libQtDBus.so.4 => ../lib/libQtDBus.so.4 (0xf170e000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf16d1000)
        libfreetype.so.6 => ../lib/libfreetype.so.6 (0xf165d000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xf164a000)
        libaudio.so.2 => /usr/lib/libaudio.so.2 (0xf162f000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0xf15d1000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xf15cd000)
        librt.so.1 => /lib/librt.so.1 (0xf15c4000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf14bd000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf146b000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0xf1462000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xf1447000)
        libatiuki.so.1 => /usr/lib/libatiuki.so.1 (0xf142c000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0xf13e8000)
        libssl.so.1.0.0 => /lib/libssl.so.1.0.0 (0xf1388000)
        libcrypto.so.1.0.0 => /lib/libcrypto.so.1.0.0 (0xf11cf000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xf11ca000)
        libpcre.so.1 => /usr/lib/libpcre.so.1 (0xf1160000)
        libffi.so.4 => /usr/lib/libffi.so.4 (0xf1158000)
        libuuid.so.1 => /usr/lib/libuuid.so.1 (0xf1152000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0xf1092000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0xf105c000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0xf1057000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0xf104a000)
        libkeyutils.so.1 => /lib/libkeyutils.so.1 (0xf1045000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xf102d000)
        libselinux.so.1 => /lib/libselinux.so.1 (0xf1008000)

To be honest, not clear to me how ldd “knew” to use …/lib/ to find the draftsight specific libraries, perhaps that is a default (?).

Hi Henk,

I am sorry for the inconvenience I caused. Next time I’ll have a problem I’ll try to describe the situation better. I admit I should describe the program more in my first post, because it’s proprietary program which is not included in OpenSUSE repos.


so the solution of the problem was to rebuild font-cache with

sudo /usr/sbin/fonts-config

command. I found a hint on Archlinux AUR draftsight’s page. ldd now shows all dependencies resolved.

Both my systems were 'dup’ed from 12.3. I noticed change in font rendering after one of updates between 7.1 and 9.1, but didn’t think it could be the problem.

Thanks to cmcgrath5035 for trying draftsight on his machine.

Wow, good find!

I’m curious, “…between 7.1 and 9.1…” of what?

Oops, sorry for my unprecise expression again. Those numbers were meant to be dates: 7.1. to 9.1.2013. I USA you would write 1/7/2013 and 1/9/2013 I guess.

Got it, correct.
As I contemplated after posting message, I realized I was not thinking globally.
And, unless you are in a parallel universe, one year behind us, it is actually 2014 :wink:

The more important question, any insight as to what package update in the date range created the need for
sudo /usr/sbin/fonts-config ?

As I write this, thinking a bit more globally, I realize you may be using native font packages that I don’t even have loaded.

I update regularly, have never seen this issue before, but use only US or UK English.

I seem to screw up every piece of information I try to givo in this thread! Of course it was 7 to 9 January 2014 :).
I found information about rebuilding font cache on archlinux AUR forum. People had to rebuild 32bit font cache after installing draftsight on 64bit systems. So I don’t think it has anythink to do with my usage of national Czech keyboard - it’s some weird quirk of draftsight.
Even downgrading packages didn’t solve the issue - most of them were ImageMagick, ghostscript, cups and zypper packages.

Two items that might be useful info, I don’t know.

  1. Using YAST (GUI) I removed my old draftsight RPM and installed a newly downloaded one twice today. Neither time did I have to do the font cache rebuild for Draftsight to start up. Using US/UK English here.
  2. I looked quickly at /var/log/zypp/history, and do not see any indication there of an rpm install triggered rebuild of the font cache for today’s installs. I would think such an activity might show up there (if, for example, Dassault had attempted to implement a fix for the issue)

Was your need to rebuild font cache perhaps 12.3 to 13.1 upgrade related, potentially affecting all 32 bit apps, rather than draftsight specific?

One other item that may be of use - I note that while draftsight starts up and I can create new drawing, save it and reload it, I have had some issues opening existing file.dwg s that I have created in QCAD, which I normally use. What is particularly bothersome is that this issue is somewhat intermittent.

Good luck with your CAD work.

I guess draftsight is the only 32bit app on my system. Apart from Skype, which works OK.
The problem wasn’t directly related to upgrade form 12.3 to 13.1. I upgraded on 23 December 2013. Draftsight was working all right up until 9 January 2013.
Now I realize that after one update I saw different font rendering - in web browser, in terminal etc. But I cannot recall which time and package it was exactly.
It’s a shame open source CAD solutions are not up to par with proprietary ones in functions.