Drad-and-drop to Firefox


I have strange behavior in Firefox.
When I try to drag file (e.g. pdf, mp4 html) into Firefox, it say in the main window ‘Server not found’ and some crazy Japanese characters. In the address bar I have http:// and afterwards the same Japanese characters.

When I was using OpenSuse 13.2 it work normally - I could drag and paste any file Firefox recognized.

any help, suggestion?

Hi, seems a Plasma 5 related issue, I can reproduce it in a VM with a standard KDE install.
Drag 'n Drop works fine on my main Gnome install though.
Maybe you can check it out by logging in to IceWM…

It’s the same in IceWM - error + Japanese characters

Interestingly, I can confirm your finding logging in with IceWM on the VM “KDE” install: same error and “Japanese” characters.
BUT logging in IceWM in my main “Gnome” install, everything works as expected.
So it seems that the culprit is hidden in some difference between the “KDE” and “Gnome” standard install, not in the WM proper.:\

SDDM problem maybe??? OR QT5??

Tried to update Firefox to 44.0.2 to no effect.
Tried to remove mozilla-kde4-integration (this is NOT installed in Gnome, of course) to no effect.
Looks like some quirks happening when interpreting pairs of UTF-8 characters as single UTF-16 characters, but I could not find a pattern so far.
Opening the test files in Firefox by its** “Open File” command works as expected**, so it seems just a “Drag’n’Drop” problem.
BTW LibreOffice tells me that the strange characters are “Chinese-simplified”, not really Japanese (don’t call on me to assess this lol! )

I think you’ve maybe been bitten by this Qt bug:

https://bugreports.qt.io/browse/QTBUG-49947 (Dropping text/urilist over browser windows stop working.)

Yes, Paul, the symptoms appear to be the same and might explain why dragging from a GTK3 File manager (Nautilus on Gnome) works fine.
Maybe the OP is willing to join that bug report.

Where shall we then turn to with this problem?

As said, you may join this bug report with a “me too” comment: https://bugreports.qt.io/browse/QTBUG-49947
On my side, I’m not a regular KDE user and won’t follow that bug any further.