Downloading problems

I seem to have problems everytime I try and download a package. I get this info…
Error: IO:Failed to provide Package xerces-j2-xml-resolver-2.8.1-238.15. Do you want to retry retrieval?

[openSUSE 11.1-0|cd:///?devices=/dev/sr0,/dev/sr1] Can’t provide file ‘./suse/noarch/xerces-j2-xml-resolver-2.8.1-238.15.noarch.rpm’ from repository ‘openSUSE 11.1-0’
History:

  • Can’t copy /var/adm/mount/AP_0x00000003/suse/noarch/xerces-j2-xml-resolver-2.8.1-238.15.noarch.rpm to /var/cache/zypp/packages/openSUSE 11.1-0
  • Can’t provide ./suse/noarch/xerces-j2-xml-resolver-2.8.1-238.15.noarch.rpm : Can’t copy /var/adm/mount/AP_0x00000003/suse/noarch/xerces-j2-xml-resolver-2.8.1-238.15.noarch.rpm to /var/cache/zypp/packages/openSUSE 11.1-0

not just on this download but on most others it is getting annoying, especially as I have a Bandwidth.

Tony

It wants your DVD in the drive to install other dependencies.

Thats the problem, it is in the drive and its not seeing it. How can I get it not to ask for the disk and just get what it needs from the web? Having to get out the disk every 5 mins is a bit of a pain. But regardless of that it just isn’t reading the disk. How does one resolve this? Thanks

Tony

You can add a source repository in Yast and disable the DVD.

You can see it done here.

Add Software Repositories

Thanks I will see if it has achieved the problem later.

Tony