Downloaded iso not mountable

I have downloaded the ISO to create a DVD for the openSUSE OS. When I try to burn the ISO image to DVD, I get an error saying that it there is no mountable file systems. I have downloaded the image three times and and three times I have the same error. I am currently using a Mac to download the image on and plan using openSUSE on a spare laptop (PC not MacBook) that has no OS installed on it.

Can you tell us which application you’re using to try an burn the iso?

Maybe this will be relevant to you

You might also consider burning the image from the command line - if that’s acceptable to a MAC user :slight_smile:

Two methods that I’ve read about

  1. Assuming image.iso is the name of the .iso file
hdiutil burn image.iso
  1. Use dd with something like
dd if=/path/to/image.iso of=/dev/disk1sN

where N= number of disk device

Good luck.

I tried using Disk Utility, but must have been trying to do it incorrectly. I have never used Disk Utility before to burn an ISO but after following the link you provided me, it is writing to disc now. Thank you!

Good stuff! :smiley:

Hiii. so you are fed up of the fact that you are getting the no mountable file system error on Mac when you are trying to install the dmg file of the software. You can resolve it by getting the fresh copy of the file but in cases that doesn’t work then there is a possibility that there is something wrong with the drive which you have have to format. Now the problem is solved but you may lose some of your data while doing this and want them back somehow. Th know more about recovering the Mac data you can visit :](