download halts with buffer full after updates with zypper patch and zypper up

12.2/64 & KDE, Intel Centrino Wireless-N 2200

I recently ran

zypper patch

followed by

zypper up

I then updated KDE from 4.9.5 to 4.10 in Yast

On this Lenovo P580 the downloading process in Yast2 was a nightmare. All the
small files came down very fast, however any file of over 2Mb would cause the
connnection to rapidly slow to a halt.

When I restarted the network

# rcnetwork restart

and resumed the
download I saw it resume at over 500KBs, then rapidly slow to as low as 5Bs,
then stop altogether. I also ran a ping test on a terminal during the download,
and I saw the ping times gradually slow from 55+ms to over 9000ms. Then the
connection would fail with an error message indicating that the buffer was full.
The time from restart to failure varied from under a minute to almost three

Each time I ran

# rcnetwork restart

and then clicked retry in Yast2
the process would repeat until the buffer was full again, anywhere from one to
three nimutes later. (I eventually completed the download but it took over two
hours, and I had to restart the network over 50 times.)

Note: No other PCs connected to the same router were affected when this
happened, so I don’t suspect that it was the router’s buffer that was full,
and I’d previously done the same things on another PC with no ill effects,
and this PC was running great until the patches & upgrades.

I suspect that either a patch or an upgrade had changed the network card
driver. Does this sound like a reasonable assumption?

I did note that there was an update to the kernel in the patches.
Any suggestions how I could resolve this?

I’d like to file a bug report too, but I’m not sure with whom.

# uname -a
Linux 3.4.28-2.20-desktop #1 SMP PREEMPT Tue Jan 29 16:51:37 UTC 2013 
(143156b) x86_64 x86_64 x86_64 GNU/Linux

excerpt from

# ifconfig
wlan0     Link encap:Ethernet  HWaddr 9C:4E:36:30:04:38  
          inet addr:  Bcast:  Mask:
          RX packets:94480 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82876 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:65033646 (62.0 Mb)  TX bytes:9923478 (9.4 Mb)

excerpt from

# lspci -v
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2200 (rev c4)
        Subsystem: Intel Corporation Centrino Wireless-N 2200 BGN
        Flags: bus master, fast devsel, latency 0, IRQ 46
        Memory at e0400000 (64-bit, non-prefetchable) [size=8]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [e0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 9c-4e-36-ff-ff-30-04-38
        Kernel driver in use: iwlwifi


Is it possible;e to connect to internet through a LAN cable to confirm that it is a wireless related issue ?

I can, but I’m dealing with several non-PC issues for the next several hours. I will post results ASAP.

Sorry to have been away so long, major non-PC related issues to deal with.

Since my last post I ran zypper patch again and was surprised to see a large # of significant patches come down (246Mb). Since then the problem appears to be fixed.