Downclocking a Nvidia graphics card with dual monitors

Is there a way to re-allow downclocking with multiple monitors? Nvidia, in their very finite wisdom shut the ability off.

My machine is a dual boot, and with Nvidia Inspector in Windows I was successfully able to do it with no ill effects, although having to manually add which applications should run with half or full power was a pain.

In OpenSuse 13.1 performance levels 0 and 1 are greyed out, even with adaptive PowerMizer enabled. I have no need for performance level 2 while running Linux, and the wear on the fans and the wasted power and higher temperatures is ridiculous.

Seems to me you need to address this to NVIDIA it really is not a openSUSE problem

All you need to do is add to the relevant xorg.conf file;

Option         "Coolbits" "1"

This should allow you via nvidia-settings to set the clock speed.

Hmmmm, why? openSUSE provide a link to a Nvidia driver for download.

Well if their software setup does not support it we can’t fix it. All opnSUSE does is provide a link

On Tue 06 May 2014 12:26:02 AM CDT, gogalthorp wrote:

Well if their software setup does not support it we can’t fix it. All
opnSUSE does is provide a link

Please, how many folks ask about configuring all sorts of hardware,
lets try to help folks ok, if you can’t help someone, it might be best
to skip the thread :wink:

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.1 Kernel 3.11.10-7-desktop
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Thanks for your response.

My system doesn’t have an xorg.conf file. Will adding one, mess anything up?

I would imagine that the install of the nvidia driver put files down in /etc/X11/xorg.conf.d?

If so, then which ever file (I’m guessing 50-device.conf) calls the nvidia driver would be the one to add the option to.

No, it doesn’t.

XOrg prefers to use the nvidia driver when it is installed, even without any configuration.

So you have two options:

  • create an xorg.conf (no, it won’t mess anything up, unless it is invalid of course), maybe with nvidia-settings, and add that option there
  • use a file in /etc/X11/xorg.conf.d/ for setting that option. I suppose something like this in 50-device.conf (or create a new file and name it like you want, 50-nvidia-device.conf f.e.) should do:
Section "Device"
  Identifier "Default Device"
  Driver "nvidia"
  Option         "Coolbits" "1"

If you have problems getting into graphical mode because of your changes, just boot to “Recovery Mode” (“Advanced Options” in the boot menu) and revert your changes.