Doubts about Pulseaudio

Hi all.

I was trying to make the mic to work on openSUSE 11.3 x64 (it’s a headset’s mic). At the beginning I thought it was just a mater of plugging the mic on, as it’s the earphones’ case, but didn’t work.

Then I found this link:
Skype, KDE4, OpenSUSE 11.3 and PulseAudio
Doesn’t sound bad, but I also use Wine and Pulseaudio is said to be not compatible with it.

So, if Pulseaudio is enabled with setup-pulseaudio --enable, how do I disable it should I find problems with Wine? Is Pulseaudio really needed to make the mic to work, or it depends on what I want to use it for?

Thanks for your help.

You can disable pulse audio in Yast > Hardware > Sound > Other > Pulse Audio Configuration

Don’t know anything pulse compatibility with wine specially in 11.3 as it seems an age since I used it, but you should be able to configure your mic in kmix and if you are going to use pulse it’s not a bad idea to install the pulse audio mixer, search pavucontrol in Yast Software Manager

In find installing (from OSS repository) and then using the pulse audio volume control application ‘pavucontrol’ very handy when it comes to controlling pulse, including for microphone capture. The first time I run a multimedia application I also run ‘pavucontrol’ which then configures pulse for that application (and the settings are automatically saved and applied each time one runs the multimedia application). Ensure in pavucontrol under the RECORDING tab one has SHOW ‘all streams’ selected, and under the ‘INPUT DEVICES’ tab one has SHOW ‘all input devices’ selected.

For recording with a mic, I recommend users test their mic with this command:

arecord -vv -f cd test.wav

and press to stop recording, and then play back ‘test.wav’ with a media player.

To show one’s mixer settings, send the command:


then copy and paste that to SUSE Paste and post here the website/url location where the paste is located.

Also, to show what mics are setup on one’s system, it is useful to send the command:

arecord -l

and post here the output.

I checked Yast > Hardware > Sound > Other > Pulse Audio Configuration and got a message: “Pulseaudio is not installed or cannot be configured”. So I tried to install pulseaudio with Yast, but I get the following message:

patterns-openSUSE-kde4_pure-11.3-22.1.i586 is in conflict with pulseaudio provided by pulseaudio-0.9.21-9.2.i586

Then suggests me either uninstalling patterns-openSUSE(…) or not installing pulseaudio. What should I do with this conflict?

Also, if I only want the mic for a small test on a website, do I still need Pulseaudio?


I did not read your initial post carefully enough. With openSUSE-11.3 KDE4 pulse audio is not enabled by default, so my suggestion of ‘pavucontrol’ was not a good suggestion.

Reference getting your mic work, please provide the output recommended to be provided in the quoted section of this multimedia forum stickie: Welcome to multimedia sub-area

based on that I should hopefully be able to give you a better suggestion than the last one.

alsa_info -

rpm -qa ‘alsa’:

rpm -qa ‘pulse’:

rpm -q libasound2:

uname -a:
Linux #1 SMP PREEMPT 2011-04-06 18:11:26 +0200 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/50-sound.conf:
options snd slots=snd-hda-intel

u1Nb.uFfEBSd3JdA:82801H (ICH8 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

ok thanks. I see a 64-bit openSUSE-11.3 with the on a Dell Inspiron 1520 with alsa driver and libary/utilities 1.0.23. The hardware audio codec is a STAC-9205.There are no model options applied.

I note this from the diagnostic script arecord section:

**** List of CAPTURE Hardware Devices ****
**card 0:** Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

which suggests your hardware for recording is known as hw:0,0

I note this for the PC’s mixer:

!!Amixer output
!!-------Mixer controls for card 0 [Intel]
Card **hw:0** 'Intel'/'HDA Intel at 0xfebfc000 irq 29'
**  Mixer name    : 'SigmaTel STAC9205'**
**Simple mixer control 'Headphone',0**
  Front Left: Playback 48 [75%] -12.00dB] [on]
  Front Right: Playback 48 [75%] -12.00dB] [on]
**Simple mixer control 'Mic Jack Mode',0**
  Items: 'Mic In' 'Line In'
  Item0: **'Mic In'**
**Simple mixer control 'Capture',0**
  Front Left: Capture 8 **[53%]** [12.00dB] [on]
  Front Right: Capture 8 **[53%]** [12.00dB] [on]
**Simple mixer control 'Digital',0**
  Front Left: Capture 0 **[0%]** -30.00dB]
  Front Right: Capture 0 **[0%]** -30.00dB]
**Simple mixer control 'Mux',0**
  Front Left: Capture 0 [0%] [0.00dB]
  Front Right: Capture 0 [0%] [0.00dB]

There are less controls than I expected. The capture at 53% is a bit low. I myself would try higher, then once capture successfully established back off on the level in order to reduce noise. I see both Digital and Mux are at 0%. If it were me, not having experience with your hardware, I would move UP the digital capture levels.

ie FIRST - try tuning your mixer better

see below for the arecord command I recommend.

NEXT (if that fails), I did a search on the Dell Inspiron 1520 and on one of the websites I noted a user claimed that for them to obtain proper sound functionality they had to apply the model option “dell-laptop”.

I note from the alsa documentation HD-Audio-Models.txt file for version 1.0.22 of alsa the following model options are allowed (one at a time):

  ref		Reference board
  dell-m42	Dell (unknown)
  dell-m43	Dell Precision
  **dell-m44**	Dell Inspiron
  eapd		Keep EAPD on (e.g. Gateway T1616)
  auto		BIOS setup (default)

None of those options are ‘dell-laptop’ and further I note ‘dell-laptop’ is intended for PC’s with a Conexant 5066 hardware audio codec which your Inspiron does not have. Hence my assessment is that user applied the wrong setting.

What you can do, thou, is apply each of those settings in the STAC9205/9254 list I quoted, one at a time, restarting the alsa driver after each application, to see if one improves your mixer settings and hence your mic controlability.

To do that, say you wish to try the setting ‘dell-m44’ (which is purportedly optimal for a Dell Inspiron), then add this line to the FRONT of your /etc/modprobe.d/50-sound.conf file:

options snd-hda-intel model=dell-m44 

and save the change. Then with root permissions run:

rcalsasound restart

and do NOT keep any old KDE settings if asked, and as a REGULAR user restart kmix (if a KDE user) or alsamixer (if gnome) and then try to tune your mic.

Note for tuning your mic, I recommend you try one at a time these commands:

arecord -vv -f cd test.wav

and press < ctrl > < c> to stop the recording and then replay ‘test.wav’ with a media application.

You can also try:

arecord -D hw:0,0 -vv -f cd test.wav

but that may need to change based on a successful application of a model option.

Good luck.

Sounds a bit complicated in general since I’m novice. So I should first try tuning my mixer better. How exactly do I do that? Just with the arecord command or with volume control? Or should I just try directly the STAC9205/9254 option?

Also, I’m planning to upgrade to KDE 4.6 on 11.3. Would that affect any of all the sound settings we’re talking about? Should I try to upgrade KDE first?


Your mixer in kde is called ‘kmix’ and it is the little speaker icon in the lower right corner. If you left click on that speaker and select mixer, it will bring up the entire kmix menu. If you look in kmix > Settings > Configure channels you should get a kmix dialog box where you can with the mouse drag ‘available channels’ to ‘visible channels’ and use the additional controls to tune your mic. This works in openSUSE-11.3 (but not in 11.4).

In my view it won’t help. In my view it could make things worse.

There was a time (a brief time) when to get the best behaviour from KDE4 one had to go for an update. That is no longer the case and the KDE4 in openSUSE-11.3 is fine. No need to update. Remember when you update with KDE4 you install a KDE version with less testing. I would not do it. My experience is it causes more problems than it is worth, I don’t like tinkering with KDE problems on my PC and I as an unpaid volunteer I DEFINITELY won’t support a user with a non-stock KDE version on their PC. I can do without the aggravation.

As soon as I learn a user has a version (of KDE) that was not packaged with openSUSE (and not updated as part of nominal SuSE-GmbH updates, NOT KDE team updates) I won’t support a user.

Anyway, no worries there wrt support for KDE. I won’t support this thread any more after you update, but there are many many thousands of other users who visit our forum and hopefully one of them will provide you support after you update KDE (besides my support is not helping anyway). So update KDE for the reasons YOU want to update.

OK, I get your point, and thank you. Although I don’t know why you say your support is not helping.

Just out of curiosity, why do you say updating KDE upgrades to a less tested/stable version? KDE 4.6 is even now the “Stable” version repo, meaning that it’s the KDE repo I added when just came out 11.3 and which I still have, they may just have changed packages. My point is I thought KDE 4.6 was now fully stable and enough tested…

Many experienced and knowledgeable users like updating to the latest ‘stable’ KDE, where in this sentence ‘stable’ is per the KDE team definition of stable. I won’t dispute with them their success in updating their KDE to the latest version deemed stable by the KDE team. These users are also skilled enough with GNU/Linux and KDE and openSUSE to handle any problems that may come their way. Typically they do not have sound problems.

I am not a ‘cutting edge’ software user. I like my operating system stable. One reason I like software that is tried and proven is so I do not have to waste time when encountering problems that may have slipped through the testing process.

In the case of the KDE team, they need to pick a platform (or various platforms) and do their testing on that (or those) platforms to declare their KDE version ‘stable’. That platform is quite possibly NOT identical to what one has on their PC’s GNU/Linux.

When one uses KDE in an openSUSE release, it has gone through a number of levels of increased testing. It has been clearly tested by the KDE team as being stable before being accepted in openSUSE, and it is been tested by the openSUSE packagers and it has been tested by members in the openSUSE community. Plus typically within a few months after an openSUSE release, there are SuSE-GmbH updates for KDE4 which are fixes for security problems and the more serious bugs (backports from more new/advanced KDE versions). Those slightly older KDE4 versions (of openSUSE) get a LOT more testing than the cutting edge KDE4 version deemed stable by the KDE developers.

When KDE4 1st came out, for a couple of years the version put out by the KDE4 developers was more stable than the version(s) in openSUSE. That’s because the early KDE4 was not so mature then. Its a different story now. KDE4 is more stable. Currently, the version of KDE4 in openSUSE has seen more testing , and is IMHO typically more stable than the version declared stable by the KDE developers.

By all means update to the latest KDE4, but I won’t do so (because I don’t like the less stability) and I also don’t want to be dragged into someone else’s encounter with what I think ‘might’ be due to instability. Thats a personal view of mine. But one advantage of being an unpaid volunteer is sometimes we can pick and choose where we volunteer. This is such a case for me.

OK, understood.

Back to topic, you said you noted in the diagnostic script arecord section that my hardware for recording was called hw:0,0. So it’s indeed detecting a device for recording sound, but I didn’t have the headset plugged when I generated the diagnostic file. So is it that the lap has really an integrated mic or something like that?

No. The headset NEEDs to be plugged in when testing. You can’t record without the headset. But the script can not tell if the headset is plugged in.

I provided the advice as to what you NEED to try.

(1) try tuning your mixer - I explained where.

if that does not work then

(2) tune your alsa configuration via the 50-sound.conf file. I explained how.

If you can not figure out how to do either of those two (and my advice inadequate in detail for your GNU/Linux level) then explain where you are stumped so we can go on from there.

Thanks for your help, mr Oldcpu. I think I somewhat managed to configure the mic. Although, there’s a more specific yet related question that I would like to ask via PM if you don’t care (I explain why PM in the message itself). Already tried it, but I got an error saying the receptor had reached the limit amount of allowed messages in the Inbox…

Sorry, but guidelines for moderators are not to provide support by PM.