Don't have permissions to my own desktop?

Hi everyone. I have suse 11.1 with kde 4.1. I’m new to this plasma thing that appears on desktop. All I’m trying to acchieve is to change the icon of one shortcut residing in “Desktop Folder”, but I can’t :frowning: ufff, when I try to press apply it says “Could not save properties. You do not have sufficient access to write to /home/jani/Desktop/VirtualBox.desktop.”, ok so I check:

jani@linux-e685:~/Desktop> dir
total 20
-rw-r--r-- 1 jani users 283 2009-01-30 15:37 MozillaFirefox.desktop
-rw-r--r-- 1 jani users 123 2009-01-30 15:37 myComputer.desktop
lrwxrwxrwx 1 jani users  40 2009-01-30 15:52 nxclient.desktop -> /usr/share/applications/nxclient.desktop
-rw-r--r-- 1 jani users 334 2009-01-30 15:37 Office.desktop
lrwxrwxrwx 1 jani users  37 2009-01-30 15:50 opera.desktop -> /usr/share/applications/opera.desktop
-rw-r--r-- 1 jani users 140 2009-01-30 15:37 Support.desktop
-rw-r--r-- 1 jani users 260 2009-01-30 15:37 SuSE.desktop
lrwxrwxrwx 1 jani users  42 2009-02-03 18:43 VirtualBox.desktop -> /usr/share/applications/VirtualBox.desktop

So, I am the owner of the link and have write permissions, now I check the file to which the link points:

jani@linux-e685:/usr/share/applications> dir Virtual*
-rw-r--r-- 1 root root 494 2009-01-22 19:16 VirtualBox.desktop

The result is the same, why don’t I have permission to modify the icon, grrr? Thanks for any advice.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

The result on the destination of the link isn’t the same at all… only
‘root’ has write rights, and you’re not ‘root’ (which is good). Either
become root temporarily to change that or change rights on that file so
anybody can modify it (you’ll need to change rights as ‘root’) or just
copy the file to your desktop and lose the softlink completely and then
you can tinker any way you like.

Good luck.

arcull wrote:
> Hi everyone. I have suse 11.1 with kde 4.1. I’m new to this plasma thing
> that appears on desktop. All I’m trying to acchieve is to change the
> icon of one shortcut residing in “Desktop Folder”, but I can’t :frowning: ufff,
> when I try to press apply it says “Could not save properties. You do not
> have sufficient access to write to
> /home/jani/Desktop/VirtualBox.desktop.”, ok so I check:
> Code:
> --------------------
> jani@linux-e685:~/Desktop> dir
> total 20
> -rw-r–r-- 1 jani users 283 2009-01-30 15:37 MozillaFirefox.desktop
> -rw-r–r-- 1 jani users 123 2009-01-30 15:37 myComputer.desktop
> lrwxrwxrwx 1 jani users 40 2009-01-30 15:52 nxclient.desktop → /usr/share/applications/nxclient.desktop
> -rw-r–r-- 1 jani users 334 2009-01-30 15:37 Office.desktop
> lrwxrwxrwx 1 jani users 37 2009-01-30 15:50 opera.desktop → /usr/share/applications/opera.desktop
> -rw-r–r-- 1 jani users 140 2009-01-30 15:37 Support.desktop
> -rw-r–r-- 1 jani users 260 2009-01-30 15:37 SuSE.desktop
> lrwxrwxrwx 1 jani users 42 2009-02-03 18:43 VirtualBox.desktop → /usr/share/applications/VirtualBox.desktop
>
> --------------------
> So, I am the owner of the link and have write permissions, now I check
> the file to which the link points:
> Code:
> --------------------
> jani@linux-e685:/usr/share/applications> dir Virtual*
> -rw-r–r-- 1 root root 494 2009-01-22 19:16 VirtualBox.desktop
>
> --------------------
> The result is the same, why don’t I have permission to modify the icon,
> grrr? Thanks for any advice.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJiIlO3s42bA80+9kRAsQ+AJ9KSEf1Bz3NG3qxOYb+kxwJoLgyeQCfWl0B
9Iif/nK1X1w6wN/dNDWoYdI=
=17vE
-----END PGP SIGNATURE-----

Yes, you’re right ab@novell.com, I’m sorry I’ve overlooked the owner of the file was root and not me. Ok I can can add the “w” rights to group and others, but what about changing the owner via chown to my username? Could that have any bad consequences? Thanks again.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Sure it could… other users on your system won’t have access anymore.
If you’re the only user, though, that’s less-bad. Also packages that
update that file may replace everything and undo it for you. Making the
group able to write that file along won’t help you as you’re not a
member of the ‘root’ group unless you’ve modified things.

Good luck.

arcull wrote:
> Yes, you’re right ab@novell.com, I’m sorry I’ve overlooked the owner of
> the file was root and not me. Ok I can can add the “w” rights to group
> and others, but what about changing the owner via chown to my username?
> Could that have any bad consequences? Thanks again.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJiJGo3s42bA80+9kRAiMLAJ4pYNURY6SF5d5u3jvnbBWfVqn2DgCfajWY
yq61aznTrbBBzX4DWD1R0Jk=
=7GrK
-----END PGP SIGNATURE-----

I got the point, thanks

I know it’s not my thread or anything but I have to ask as that doesn’t make complete sense to me

Why would other users need access to a specific user’s desktop shortcuts?

Still using kde 3.5 myself so I don’t know a lot about kde 4/4.1/4.2, is the plasma thinger on the desktop an ‘all users’ thing then or is it a ‘per user’ one?

I would expect any changes a particular user made to it would only be reflected in that user’s account, am I wrong there?

It’s of interest to me because I tried making a custom menu of ‘most popular app’ shortcuts that could be available to all users and failed, got no replies when I asked about it here

Yes, I gues the icons on the desktop folder (even if plasma) are owned by the user by default. But I my case the shortcut to VirtualBox is just the symbolic link to the application /usr/share/applications/VirtualBox.desktop, which unfortunately is owned by root, since it the application VirtualBox was installed as root, I did just pull the icon to my desktop, but that does not grant me permissions to make any changes to it, since it inherits permisions from the file it points to. If I’m wrong, correct me :slight_smile:

Ah I see

Might be easier for yourself next time to find the icon on your suse or kmenu, right-click on it and click Add to Desktop

This worked with version 11.1 but having installed openSuse 11.2 for a friend on her laptop, I discovered I could not make any new ones on the desktop as user. So I tried to right-click from the menu and Add it to the Desktop.
Yes, you get an Icon but that one is also owned by root.
The result is that these icons do not behave according to the user’s desktop settings (e.g. text color) and also you get that plasma menu popup when the mouse gets near.
This does not happen with the default installed desktop icons.

Since this friend is brand new to linux, it’s better to not getting her confused by such different behaviour.
This to avoid panic:X:X in case she clicks accidently and ending up with opening some settings panel.

Personally, I do NOT like this change with openSuse 11.2:(

At least when you decide to add a desktop icon by right clicking from the menu, these should be user editable.

Is there a way to change this permanently in case you want to have it that way?

sliding wrote:

> Yes, you get an Icon but that one is also owned by root.

are you logged into the DE as root?

if not i can not understand how it becomes owned by root unless it is
first owned you you the user, and then you the user change ownership
to root…


palladium

Hi Palladium,

I just rebooted the system (for getting WLAN to work) and added an icon to the desktop by right-clicking a menu item.
This icon is set to user=root and group=root, while I am logged in as the user.

So far the only option to create desktop icons without the menu popup, is to copy an existing one to another location, edit that one (as user) set to the application you want to run and then copy it back to the desktop folder with the new name.

I guess this should not be the case.
The desktop settings for root have black text for the icons, the user desktop white to be contrasting with the background. In case this is dark behing the icon, it becomes diffecult to read.

There are more problems with openSuse 11.2. I enabled a screen saver, but it does not show, screen becomes black. But this can be caused by the laptop’s behaviour.

On my own regular openSuse box, the update from 11.1 to 11.2 raised a lot of problems. It messed up a lot of customised settings and broke my sound, which I cannot manage to restore.
I wished I had stayed with 11.1 with KDE 4.3.3, running fine

it certainly sounds like a very damaged system that causes a user
placed icon to be owned by root…suggest you start over! and make
SURE your install media is perfect!!


palladium

It was on a fresh new install. Later I checked the updater applet as it mesaged that there were a few updates. On of which had something to do with pam and some other that were marked as being required to solve some bugs.
So I let the updater do its job.
At the end there were some errors with the updater. Later when I restarted the laptop, I noticed there had been some kernel changes, as the Grub menu had been changed.
I checked with Yast to see if there were any dependency errors or some left updates. The updater generated some messages that it could not complete some things at the end of its job.
But every update I had seen before updating had been completed.
Certainly something can have been messed up.

Re-installing would be an option. Would it be an option if I re-install these latest updates again with yast? I know more or less the ones that have been updated. Things get reconfigured at the end or am I wrong?

sliding wrote:

i’m not positive how to get you fixed, but i think this will do it:
first lets see what repos you have:

do this in a terminal


zypper lr -d

and copy paste the results back to here…


palladium

Was the 11.2 installed with an old /home from a previous install?

If so check the User ID (UID) number of the user and that of the files. If the old user was not UID 1000 the files look like they belong to some other user. The machine uses the UID not the account name as the ID. You would need to either change the UID of the new user to match the old or change the ownership of ~/ directory.

Here is the result:

anja@ijsbeer:~> zypper lr -d

| Alias | Naam | Ingeschakeld | Vernieuwen | Prioriteit | Type | URI | Service

–±----------------±----------------------±-------------±-----------±-----------±-------±----------------------------------------------------------------±-------
1 | openSUSE_11.2-0 | openSUSE 11.2-0 DVD | Ja | Nee | 99 | yast2 | dvd:/// |
2 | repo-debug | openSUSE-11.2-Debug | Nee | Ja | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
3 | repo-non-oss | openSUSE-11.2-Non-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
4 | repo-oss | openSUSE-11.2-Oss | Ja | Ja | 99 | yast2 | Index of /distribution/11.2/repo/oss |
5 | repo-source | openSUSE-11.2-Source | Ja | Ja | 99 | yast2 | Index of /source/distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Ja | Ja | 99 | rpm-md | Index of /update/11.2

Yes, the home was a result of some earlier attempts of installing it on a Fujitsu Amilo L1310G.
These attempts failed because at 50% the **** thing was shutting down because of overheating. Fan shut off.
The only way was to start the installation from the live CD with acpi.power_nocheck=1. This kept the fan on and I could complete installation.
I now that / became formatted again while the /home partition was only mounted. Better had that reformatted again.

I will try to change the UID or may create a new user and copy the 1Gb data from the originally installed WinXP home

Yep. People forget that the UID is there real user identification the name is just for us meat bags.

Well I tried with a newly created user. Same problem!!
I guess it is some KDE configuration error since all menu item copied to the desktop or panel have root settings.
Must probably look into KDE to reset, but where.
Try to look on KDE for a solution.
For now I copied the needed ones for the desktop from the /usr/share/applications…


sliding wrote:
> anja@ijsbeer:~> zypper lr -d
> # | Alias           | Naam                  | Ingeschakeld | Vernieuwen
> | Prioriteit | Type   | URI
> | Service
> --+-----------------+-----------------------+--------------+------------+------------+--------+-----------------------------------------------------------------+--------
> 1 | openSUSE_11.2-0 | openSUSE 11.2-0 DVD   | Ja           | Nee
> |   99       | yast2  | dvd:///
> |
> 2 | repo-debug      | openSUSE-11.2-Debug   | Nee          | Ja
> |   99       | NONE   | 'Index of /debug/distribution/11.2/repo/oss'
> (http://download.opensuse.org/debug/distribution/11.2/repo/oss/)  |
> 3 | repo-non-oss    | openSUSE-11.2-Non-Oss | Ja           | Ja
> |   99       | yast2  | 'Index of /distribution/11.2/repo/non-oss'
> (http://download.opensuse.org/distribution/11.2/repo/non-oss/)    |
> 4 | repo-oss        | openSUSE-11.2-Oss     | Ja           | Ja
> |   99       | yast2  | 'Index of /distribution/11.2/repo/oss'
> (http://download.opensuse.org/distribution/11.2/repo/oss/)        |
> 5 | repo-source     | openSUSE-11.2-Source  | Ja           | Ja
> |   99       | yast2  | 'Index of /source/distribution/11.2/repo/oss'
> (http://download.opensuse.org/source/distribution/11.2/repo/oss/) |
> 6 | repo-update     | openSUSE-11.2-Update  | Ja           | Ja
> |   99       | rpm-md | 'Index of /update/11.2'
> (http://download.opensuse.org/update/11.2/)


the above is ok, but having the DVD enabled will cause it to ask you
for the disk…if you disable it, YaST will stop asking for the
disk–BUT, anything on the disk will have to be downloaded if you need
it…

you can try this, i do not know if it will help…on the other hand, i
don’t know what to do to help your situation but believe this will not
hurt it:

in a terminal do this


zypper ref

then do this


zypper dup

if you have any errors copy and paste them back to here…
when it is finished log out of the session you are in, and then log
back in (that is, you don’t have to reboot…but it may be as easy)

-cross your fingers- if it doesn’t work, post again…and i’ll back
off 'cause just guessing…


palladium