Dolphin - Unable to create network folder.

Running on KDE desktop and using Dolphin I am trying to create a network folder on a Webdav connection. I have the server address, port and intended address but no joy and no request for password pop up so something is missing. Please can somebody help me.
Budge

Still hoping for help with this please. Does anybody use Dolphin for this?
Any help would be appreciated please.

No description whatsoever about what you tried. I assume that you do not expect “request for password pop up so” spontanious while you are sitting there, arms folded, staring to the system. So you did something, but what?

Hi Henk,
The background to this starts with working with Mozilla Thunderbird and trying to find a calendar which handles task with repeated tasks such as those required for maintenance every 3 months. Google Calendars does not do this and if I try and create a new task using T’Bird I get a warning:-

Please select a calendar that supports tasks

I subscribe to pCloud and have been advised that my subscription includes support for a WebDav server. In order to find out a bit more about whether this might work I thought I would try and create a directory on the WebDav server which I might then be able to share a caldav.ics calendar. This is the background and I have been trying to work first with Dolphin.

From Dolphin under Remote in the left hand panel I can select Network and this offers an option to Add Network Folder. Selecting this offers a Network Folder Wizard popup and from this I can select WebFolder (webdav) and this brings up entry boxed for Name, User, Server, Port, Folder and a couple of tick boxes to create and icon for this remote folder and also to Use encryption. No mention of password.

My pCloud support suggests that pCloud supports the WebDav protocol with the following:-

Please use the below settings for the WebDav protocol:
Link for US accounts: https://webdav.pcloud.com
Link for EU accounts: https://ewebdav.pcloud.com
Port: 443
Username: {Your user name}
Password: {Your password}

My account is on a US server so, with these details I tried to complete the Wizard questions but the connection failed:-

Unable to connect to server. Please check your settings and try again.

My first question concerns the folder path. I have tried with a path:-

/home/alastair/pCloudDrive/Thunderbird&Lightning_Test_Folder

but I suspect the …/pCloudDrive/… is a proxy for something more complex.

I have also tried using a simple directory in my home tree:-

/home/alastair/test_webdav

But still no connection and as I mentioned at the beginning, still no opportunity to enter the password.

I know you like to see my working and I could try with screenshots but more relevant is finding which log to view. I tried using Yast to look at systemd journal entries but was overwhelmed by lines of data. Needles in haystack problem.

This is where I am at so if you have time to guide me further or in a better direction please do.
Regards,
Budge.

OK, this on my question, did you wait for spontanious action or did you do something in Dolphin, the answer is:

From Dolphin under Remote in the left hand panel I can select Network and this offers an option to Add Network Folder. Selecting this offers a Network Folder Wizard popup and from this I can select WebFolder (webdav) and this brings up entry boxed for Name, User, Server, Port, Folder and a couple of tick boxes to create and icon for this remote folder and also to Use encryption. No mention of password.

But we still have no idea what exactly did you filled in, items you checked. You say simply

with these details I tried to complete the Wizard questions

as if that tells us anything. We are no mind readers!

How do you think we can comment on what you did, suggest improvements, point to errors or whatever???

It is as with other threads you started. You define your problem in one-and-a-halve lines, where everybody can understands that it tells almost nothing. And the title is in this case even missing the key word ‘webdav’ :frowning:

Are you ever thinking about the people that have to try and understand what your problem is when you formulate it? IMHO is no wonder that this thread went unanswered for three days. People seeing it will think something like: “here we go again”. and then go for a beer or a nice walk. It is NOT our job, everybody here tries to help in free time and as volunteer. But the least thing some expect is well formulated problem descriptions.

And then you create a pages long story with is far beyond the technical merits of the problem (do you really think that informing us about the exact files you want to put in that webdavs store).

Please, please, when you make a post, then do not send it off, but first try to read it as if you were a person that is not clairvoyant, does know (almost) nothing about your computing environment. and then ask your self: would I understand what the problem is and would I thing I have at enough technical information to at least start helping when I would read this as helper?

How are you entering the server details? I expect that entering “webdav.pcloud.com” (without specifying https://) might be sufficient.

I would also expect the the authentication process would be handled by kwalletmanger5.

FWIW, here’s a how to (following a quick online search) which outlines the basic process for accessing a university’s WebDAV storage service…
Remote access to your storage location (File service) in Linux using KDE4 GUI (Dolphin). - IT services for students

It will give you the basic idea.

Hi Deano,
Many thanks. Your suggestion to omit the https:// took me much further along and a login popup appeared seeking my password. I entered my pCloud login password but this failed. The KNetAttach message Examining (Failed) was:-

webdavs://ajbudge%40errichel.co.uk@webdav.pcloud.com:443/home/alastair/


Will try again in case I have made an entry error but it would be good to check a log if I knew where to look.
Must break now as I have to work but will resume later.

While I do not see any actual error message - are you sure this path exists on pCloud webdav server? You may be confusing remote path and local mount point. Try without any path first.

Maybe an exam,lple of a “working” case. I have this already for years

webdavs://hcvv@webdisk.xs4all.nl:443/hcvv

I assume that the first hcvv is the username and the last one is the directory served (thus within the server root of the server).

Something like…

sudo journalctl -f | grep --line-buffered kde

…although I doubt it will give you much more.

Maybe try using cadaver (Linux CLI app for WebDAV access) for test purposes…

I don’t know how your cloud provider handles this but my cloud provider requires a separate password to be setup for access via webdav. I cannot use my “normal” user password for this.

Regards

susejunky

I have it now by deleting the https:// part of the url and for the path just using the root directory on the server. This gave me the root directory of my pCloud account stored data.

I now will start work on a calendar in T’Bird.
Many thanks to all and sorry I made another meal of this.
Regards,
Budge.

This will search system journal while messages from KDE components are most likely in user journal (journalctl --user …).

Interesting point. Still playing around with this. I am required to use the “normal” cloud login and password but I may need to allow some background app to remember this as at present everything I do, like adding a directory, required a login. However it now seems content as I acn close Dolphin and re-open and the network directory is still working.

Thanks for the thoughts.
Regards,
Budge.