Dolphin takes minutes to delete a file

Hello All,

I have observed that Dolphin takes minutes to delete a file, even if it is just a few megabites big. I do not have a particularly fast computer, but for all the other operations (including moving files from one folder to another) Dolphin is very responsive; but when it comens to delete a file, it could take up to 10 minutes for the operation to be completed, and in the meanwhile the whole system “hangs up” until the operation is reported completed. I have noticed that while this operation happens, there’s a process called trash.so that is reported by the system to wait for accessing the disk, which I probably should specify is not an SSD device.

Anyone else has seen this happening before?

Have you tried a Shift+Delete to permanently delete the file, instead of having it moved to the trash? That may help determine the issue.

This sounds like a file system issue. Which are we talking about ? Has the Trash been emptied lately ?

Just tried that, exactly the same thing happens, two processes called “trash.so” seem to make the system hang. They do not use much memory, but between the two of them while active they use up to 20% of the processor and often they will wait for the disk to respond.
I’ve copied here below some information on the process:

Process 12107 - trash.so

Summary

The process trash.so (with pid 12107) is using approximately 2.7 MB of memory.
It is using 1792.0 KB privately, and a further 13.1 MB that is, or could be, shared with other programs.
Dividing up the shared memory between all the processes sharing that memory we get a reduced shared memory usage of 975.0 KB. Adding that to the private usage, we get the above mentioned total memory footprint of 2.7 MB.
Library Usage

The memory usage of a process is found by adding up the memory usage of each of its libraries, plus the process’s own heap, stack and any other mappings, plus the stack of its one other thread.
|
|
|more|
|1636 KB|[heap]|
|52 KB|/usr/lib64/libKF5Solid.so.5.45.0|
|28 KB|[stack]|
|8 KB|/usr/lib64/libudev.so.1.6.6|
|8 KB|/usr/lib64/qt5/plugins/kf5/kio/trash.so|

|
|
|more|
|2740 KB|/usr/lib64/libQt5Core.so.5.9.4|
|956 KB|/lib64/libc-2.26.so|
|780 KB|[heap]|
|624 KB|/usr/lib64/libQt5Widgets.so.5.9.4|
|440 KB|/usr/lib64/libQt5Gui.so.5.9.4|

Totals

The thrash contains less than 1 GB of files, there should be plenty more space available

What happens if you create a small file with

touch ~/testfile

then remove it with

rm ~/testfile

Does that take as long as deletion from Dolphin ?

I’m using ext4.
I’m cleaning the thrash now, it may take a while (same issue as above even when cleaning the thrash folder)… I’ll update you on the outcome

Update:

after a few hours in the attempt of deleting the trash, I have decided to kill the trash.so processes, which were sucking up more than 50% of processor usage, and went brutally to empty the trash from the command line using rm -rf.
rm took just a few seconds to delete the folder content, so it is definitely the trash.so process that has some issues.

If this is a bug, any idea what kind of useful informations I could add to it to report it?

First, just see if that cleaning of the trash has solved the problem.