Dolphin services not working

When I install a service such as “Root Actions Servicemenu” it does not work, if I try to uninstall it, it does not uninstall.

Where are all the config files for Dolphin? Can I delete them and start fresh?

Thanks Bob

So what are you trying to do with the KDE file manager Dolphin you can not do? I have never found using “Root Actions Servicemenu” required in anyway.

Thank You,

Thanks, but it is really not the matter of what I can and cant do with out a particular add on. I would like to install what ever suits my taste.

Anyways /usr/share/kde4/services/ServiceMenus shows all the add ons as Chromium icons instead of gears? So I think my associations are screwed up? How can I set them to default?

All KDE appearance settings are selectable in Configure Desktop option. Have you not looked at this before?

Thank You,

Thanks, I have seen that before, but I am having a problem with dolphin.

If I look at d/.kde4/share/apps/dolphin/view_properties as root, it shows gears, if I look at it as desktop user it shows as chromium icons. I am starting to think that is why I can not install services?

I am going to try it in root dolphin and see if it helps?

Figured it out you have to go to /home/~/.kde4/share/apps/servicemenu-download, extract the files, then move the *.desktop files to /home/~/.kde4/share/kde4/services

Now it works, and configured the way I want :wink:

OK, while on the topic of Dolphin, why does it show a plus or minus when you click on folder, and you have to click the name to open it?

So, you should not be running Dolphin as root and I find the plus does open up the folder for me. As you make manual changes to how openSUSE works, you will finding odd things going on. I try to come up with scripts to things to be done as root when required. Like, editing files as root, look here:

Ouside of Dolphin: SYSEdit - System File Editor - Version 1.50 - Blogs - openSUSE Forums

And Inside of Dolphin you can use: fewrup - File Editor With Root or User Permissions - Blogs - openSUSE Forums

Thank You,

The plus icon should add the file/directory to the current selection.
That’s done to make it easier to select files when set to open on single-click.

You can turn off those plus and minus symbols in dolphin’s settings though. (option “Show selection markers” in “General”->“Behavior”)

I do not do a whole lot as root, but some times it is handy to edit a config file.

Sort of like clicking with Ctrl + RMB. I would like them to just open when I click the folders, I used Nautilus and Nemo for the past 5 years, dolphin does things different.

You can open a folder by clicking on it, just not if you click on that plus or minus of course.

But as I wrote, enter Dolphin’s settings (click on the “gear” button in the toolbar and select “Configure Dolphin…”) and turn that feature off if you don’t like it.

I kind of like the selection marker now that I know what it is, but given a choice, I will leave it off.

With Nautilus and Nemo we had recent documents or places. I see no way or setting to make this happen in Dolphin?


Something like this maybe?
Dolphin/File Management - KDE UserBase Wiki

Or enter “recentdocuments:/” as address and you’ll get the list of recently opened documents as shown in the start menu (“Recently Used” tab).

LOL, just was going to report that I found that and control>startup>location: timeline:/today

Well that solves it.;):wink: