Dolphin opens the wrong DVD-Drive when ejecting DVDs

I have Dolphin Version 4.14.2 (KDE 4.14.2) installed and I am expierencing the following problem(s) when ejecting DVDs:

My PC has two identical DVD-drives (TSSTcorp SSH-S203D Rev: SB00). My motherboard is the Gigabyte GA-990FXA-UD5.

After putting a DVD in one of the drives, Dolphin shows the inserted DVD. It has been auto-mounted like it should. When I right-click on the DVD-Symbol in Dolphin (places tab) and choose “eject” the wrong DVD-drive is opened. Dolphin opens an empty DVD-drive and the “ejected” DVD remains in the drive.

If I press the “eject” button on the DVD-drive with the DVD, it opens as expected. If I insert a different DVD, the DVD gets auto-mounted and appears in the places tab of Dolphin. So far, so good. Clicking on the symbol in the places tab results in Dolphin opening the folder the old DVD was mounted on. That folder is of course empty since the DVD with the corresponding name has been ejected manually. This leads to the impression that the new DVD cannot be read. This can only be solved by right-clicking, choosing eject (which opens the wrong DVD-drive) and then pressing the button on the drive to eject the right DVD and then inserting the new DVD in the drive I just manually opened.

This might be a hardware issue since this problem has persisted through several version of OpenSUSE.

What does the BIOS say?
Does switching the cables change anything?
Any master/slave switches on the back of the DVD drive?

What should the BIOS say? I think I can set them as master/slave there.

I haven’t tried switching the cables and, frankly, I don’t want to because it is just a big mess in my case.

There might me master/slave switches but I have never needed or set them because under windows “it just worked”.

There can be a confusion if the master slave settings are not right. This is traditionally set with tiny jumpers on the back.