Dolphin not showing free space on samba share

Hi all, does anybody know why dolphin does/can not show free space available on samba shares and nautilus and nemo can?
What does dolphin do differently than nautilus or nemo?
Do those file managers use different backends to get this information?

I am running this on tumbleweed, but it is the same in leap 15.

“Vrije ruimte” :). And what if you refresh it a couple of times? Otherwise I’d report a bug at

Refreshing doesn’t change anything.
Still looking to find how those programs get their information about samba shares.
I’m not running a samba server on the desktop machine, but samba is installed.

And i do not see anything on the commandline when i run dolphin from a terminal, so i could file a bug report, but it will be a vague one.
So i’m still trying to find out more myself first.

OK, i think i’ll report a bug, but will the infomation i provided here be enough?

I somehow doubt that this would be an openSUSE specific problem, better report it at

Actually this is probably more a (missing) upstream “feature”.
KDE Frameworks/Plasma/Dolphin don’t actually mount a share (they access it “directly”), and that’s the big difference to e.g. Nautilus.

Hm, dolphin does correctly show the free space for Samba shares here though…
(Leap 42.3 with latest Qt5/KF5/KDE Applications)

Thank you so much!!
So now i’m learning how to make a mount entry in fstab for my shares.

I managed to make it mount at boot and now dolphin can show the free space available! :smiley:
But i cannot alter file on the share, only root can.

This is my fstab entry:

//  /mnt/readyshare cifs user=blabla,password=blablabla,users,auto    0 0

What do i need to change there to allow me on my useraccount to alter files on the share?
But again, thank you for pointing me in the right direction!

First i thought, could it be so simple to change the permissions on /mnt/readyshare?
No, that didn’t work.

And now i learned that i can change/add/remove files in the root folder of the share, but not in the subfolders.
I hoped that it would behave like a local folder, but it doesn’t :\

Maybe the uid mount option would help?
From “man mount.cifs”:

       sets the uid that will own all files or directories on the mounted
       filesystem when the server does not provide ownership information. It
       may be specified as either a username or a numeric uid. When not
       specified, the default is uid 0. The mount.cifs helper must be at
       version 1.10 or higher to support specifying the uid in non-numeric
       below for more information.

(maybe together with “forceuid”…)

Or maybe you’d need to mount it as user. You’d need to replace “auto” with “noauto” though.

Btw, you can also browse and mount shares with smb4k, available in the KDE:Extra repo. IIRC, that can also automatically remount shares on login.

Yes that was all i needed to add to the entry!

//  /mnt/readyshare cifs user=blabla,password=blablabla,uid=chris,users,auto    0 0

Thanks everybody for helping me with this!


Just an additional note though: you may want to add the “nofail” parameter, or your system will not boot if the share cannot be accessed/mounted.
Also you normally should also set the _netdev option for network mounts, although I think systemd is probably able to figure it out itself in this case.

From “man mount”:

              The filesystem resides on a device that requires network access (used
              to prevent the system from  attempting  to  mount  these  filesystems
              until the network has been enabled on the system).

**       nofail **Do not report errors for this device if it does not exist.

Exellent advice!
Can’t wait for leap 15 to be released.
I have been playing around with linux mint for the past 5 months after using opensuse since SuSE 7.3 because i couldn’t make 42.3 work with my laptop.
So since leap 15 went up for testing i tried to make it look/work like my mint setup and this was just about the last hurdle :slight_smile:
Eventhough leap 15 is still beta, it seems rock solid allready!

Another option would be to use autofs btw, which mounts things as soon as they are accessed.
I never used it myself though, so cannot really help with its configuration.

Using autofs is pretty straight forward. After installing it edit the /etc/auto.master file and add an entry for the mount point after the example:

#/misc    /etc/auto.misc
/mnt    /etc/auto.nfs   --timeout=10

At the end of this file add the following line:


Next, create the /etc/auto.nfs file (this is mine that references a NAS box):

# This is an automounter map and it has the following format
# key  -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage


I referenced in coming up with this.

The neat thing about this approach is it works with anything: Dolphin, terminal (eg. ls /mnt/nfs), and in bash scripts. After the time delay the drive is automatically unmounted.