Dolphin is slow

I installed OpenSuse 12.2 about a month ago. It was a clean install, not an upgrade. As I recall it ran fine initially, but lately it seems to slow down or hang up at times and I have to wait.

For example, I booted it up today and opened up dolphin and it would not display the contents of the home folder for 30 seconds or something. I believe I had firefox up and running at the time. I did not have flash drives or hard drives connected to USB. I didn’t have anything else running, so simply starting up dolphin should be pretty easy for it.

How can I tell if I am using lvm encryption or not? I saw this in another post and it sounds like this could slow me down. I don’t remember anymore what I did when I formatted the partitions and installed.

Could it by my hardware? This pc isn’t very powerful. It originally came with Windows Vista. It is a pentium duo-core 1.6 GHz with 1 Gig or RAM. (I think)

Any other ideas?

Try seeing if you are actually low on available memory (using free -m) or if the disk is being heavily accessed during the time dolphin is loading. The processes using the most amount of cpu as reported by top would be useful as well. Also you can run the command dolphin from the terminal to see if it reports any error messages, etc. I hope this helps!

Agreed,
More specifically if you haven’t booted up openSUSE for a significant amount of time by default Apper will be running, analyzing your machine and downloading a list of updates.

I suspect that Apper’s performance and resource usage would be greatly improved if it continuously tracked and updated a profile in the background instead of hitting the machine so hard on bootup… assuming my assumptions based purely on subjective observation are correct.

One workaround if you don’t want to just wait is to disable Apper from autostarting but then you’ll be taking on your own responibility for keeping your machine properly updated.

HTH,
TSU

On 02/01/2013 05:56 PM, treeup wrote:
> I booted it up today and opened up dolphin

in addition to what the others have mentioned, if the time between
booting and opening dolphin is less than (say) two minutes then you
might also be having some slow downs due to the desktop indexer (maybe
Akonadi and/or Nepomuk and/or Tracker) those things are just plain
killers…especially if you just changed, moved, downloaded or whatever
a bunch of stuff…

if the time between booting and opening Dolphin is more like ten or
fifteen minutes then the system might be running all the
crons…openSUSE default ships with daily crons set to run about (i
forget) one or two in the morning, your local time…and, if the
machine is off then it will detect when booting that today’s crons have
not run and will then kick them off at the next 15, 30, 45 or on the
hour clock…some crons can suck a lot of power…especially if also
running the desktop indexer, apper, etc etc etc…

so, the already given advice to run top to see what is sucking CPU is a
very good one…


dd
http://tinyurl.com/DD-Caveat

Good advice all. As it happens, I was gone for about a week and a half before I booted up last time, so I think that’s why it was especially slow. It went much better today.

I tried the commands that nightwishfan suggested. The computer is running fine right now, but I guess I don’t have much free memory. I’m running thunderbird and firefox.

adam@desk12two:~> free -m
             total       used       free     shared    buffers     cached
Mem:           984        891         93          0         15        337
-/+ buffers/cache:        538        446
Swap:         3004         64       2939


top is a good command also. I didn’t post here, but nothing is using much CPU.

The lines that matter are these. So you have about 1/2 gb ram free and only a few mb of swap used. Please do report (if any) further symptoms you have and hopefully we can help you investigate and solve the issue. :slight_smile:

-/+ buffers/cache:        538        446
Swap:         3004         64       2939

Even my little eeepc Dolphin is fine
Loads in a second

I more Mem though, but even the 1GB you have should be OK

Compare with mine

Mem:          1997       1281        715          0         47        607-/+ buffers/cache:        626       1371
Swap:         4124          0       4124