Dolphin Freezes in Superuser Mode

Running 13.1 on 32 bit laptop with KDE desktop. I have a new problem. When I try and run Dolphin in superuser mode dolphin starts but then does not respond to and further actions and cannot be closed. I get a Terminate screen and this does not work. To stop it I have to go to monitor and kill the process.

I have tried creating a new dolphinrc but that doesn’t help. I start dolphin in superuser mode using gui not from terminal.

Can anybody help?

When running as root the KDE settings are in /root/.kde4 not in the user directory So you get the right ones??

Hi and good point which I hadn’t known before. Thanks. However I put /root/.kde4/dolphinrc aside and restarted dolphin in superuser mode. Still freezes once opened. The only way to get rid of it then is to kill the process as root in terminal.
So, what is wrong and how can I fix please?

try zapping the whole /root/.ke4 directory. It may be some other file that is causing the problem. It has always worked fine here.