Dolphin File Manager - Super User - Open text in....

OS: openSuSe 12.1
Environment: Gnome 3

In super user mode for Nautilus and Krusader I’m able to open text files in super user mode. I like Dolphin’s column view and it would be nice if this app had the same feature as mention or is there a setting somewhere to enable this?

On 23/02/12 00:56, VcDeveloper1 wrote:
> OS: openSuSe 12.1
> Environment: Gnome 3
> In super user mode for Nautilus and Krusader I’m able to open text
> files in super user mode. I like Dolphin’s column view and it would be
> nice if this app had the same feature as mention or is there a setting
> somewhere to enable this?

Nautilus has extra pane view from the menu ‘View’ > extra pane

Oh yes, I was aware of the extra pane, but what I like about Dolphin is when your in Column View Mode and as you keep opening folders it creates the extra column for it which is very nice and convenient. You don’t have to click the “Go Up to Parent”, you just use the Column it created to return to whatever level. If you have it installed give it a try… :slight_smile:

Mate. I use kde and enjoy it’s brilliance all the time!

Cool! Would you know if this is something on their TODO list before I go request it?

Sorry - I don’t follow
In who’s To Do list?

There is a substitute.
While in dolphin, right click the file and click open with, click other
and type

kdesu 'application you want to open the file'

If you knew that KDE had plans on adding the feature of opening text files in Super User Mode while in the same Mode just like “Krusader”, if not, I was going to go to there site and requested it…

Great! Thanks for telling me about this! I just tried it! Kewl! I appreciate it very much!.. :slight_smile:

As an alternative to running any file manager as a root user, if you just want to edit a system file, you have a couple of bash scripts that can do that for you. Have a look at these two:

fewrup - File Editor With Root or User Permissions - Blogs - openSUSE Forums


SYSEdit - System File Editor - Version 1.00 - Blogs - openSUSE Forums

Check them out, you might like it.

Thank You,

Thanks, James, for the script pointers.

Until I read this forum thread, I had not realized that Dolphin-SU was opening files Read Only in kwrite. I guess I have just been in the habit of using vi from the cli for so long to edit these files I had not tried.

I downloaded and installed fewrup, works great but I stumbled on something you might want to add to your blog.
It just happened that my “test case” file, for viewing and editing, was /var/log/messages, which is rw- r-- — root root permissions.
I assume because “others” cannot read the file, Dolphin cannot determine the file type and pops up the “Open With” dialog without the checkbox to associate the selected Application with this file type. One needs to select ~/bin/fewrup manually each time, but it does work.
I also used your example, opening /etc/fstab (rw- r-- r-- root root permissions) and it worked per the blog, including the option to add fewrup to the list of known applications.

I’ll add another observation:
I have gvim loaded on my system, GUI interface to vim.
When I run Dolphin-SU from my desktop, and select to open a file owned by root with gvim, it opens RW.
So I guess that is yet another option for those who speak vi.

Makes me sort of curious how Dolphin-SU is configured to run kwrite RO but gvim RW.

Dolphin SU is just configured to “Run As a Different User” which seems to mean root, for which you must enter the root user password. This does work OK, but if you open a personnel file and edit it, it suddenly belongs to root. So the idea of fewrup was to only edit a file as root if root already owns it and it works from a standard user file manager. If, due to the files permission settings, the file can not even be viewed by Dolphin, then fewrup never gets a chance to run. But not many places exist as that luckily. And thanks so much for your comments…

Thank You,

Hi, tried both and they’re just as convenient! Thanks! :slight_smile:

Also I just notice my “Dolphin - Super User Mode” which was auto created has the command of “dbus-launch dolphin %i -caption “%c” “%u”” and doesn’t actually give me a “root Admin status”, so I creates another menu item as “Dolphin KDE Super User” | “kdesu dolphin %i -caption “%c” %u”. This gives me what I want, but it doesn’t allow me to change permissions. Why is this?

So here is a description of: dbus-launch - Utility to start a message bus from a shell script which among other things means you can start a graphic mode program from a terminal session manually or from a bash script. Strictly speaking then, you can remove that entry as long as the short cut is only ran from a desktop. From a desktop it should work as well without it and perhaps its causing an issue for you. I just removed the dbus-launch from the menu option and on the run as different user, put in the name root and it seems to work the same for me that way. I really can not say why however, why there would be some kind of difference between the two. I will say that I would avoid running the file manager as root if I could manage to do so if editing system files is all you need to do. Moving and removing systems files is another matter though.

Thank You,

Too bad Column view has been axed in KDE 4.8 with Dolphin 2.0.

It seems so
You could wish for it at kde…

Oh, I can live without it. I thought it more as a warning not to become too enarmoured with that feature.

Thanks every for the help with Dolphin and about it future features. Even though I will miss the “Column Mode”, I do just a well with the “split | Detail View Mode”. Between this and “Krusader”, Krusader is awsome, but missing the “Tree View”.

…by the way, is KDE only a app upgrade, because when I added the repo I didn’t see any of the base upgraded? Is this something still in progress?

You need to use the switcher on the repo you added


Thanks caf4926, I really enjoy your visual aide in helping to understand how to accomplish a task! :slight_smile: